# Unable to fetch data from reporting collector"

**URL:** <https://discuss.elastic.co/t/unable-to-fetch-data-from-reporting-collector/170308>\
**Category:** Kibana\
**Created:** [February 28, 2019, 9:57am UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-reporting-collector/170308 "2019-02-28T09:57:11Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![legolas\_bilbao](https://avatars.discourse-cdn.com/v4/letter/l/3da27b/32.png) [@legolas\_bilbao](https://discuss.elastic.co/u/legolas_bilbao)\
**Post date:** [February 28, 2019, 9:57am UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-reporting-collector/170308/1 "2019-02-28T09:57:11Z")

</div>

Hi everybody,

the kibana doesnt start in the last days

the error is the following:

```
feb 28 09:50:25 ganondorf kibana[14813]: {"type":"error","@timestamp":"2019-02-28T09:50:25Z","tags":["warning","stats-collection"],"pid":14813,"level":"error","error":{"message":"[illegal_argument_exception]
feb 28 09:50:25 ganondorf kibana[14813]: {"type":"log","@timestamp":"2019-02-28T09:50:25Z","tags":["warning","stats-collection"],"pid":14813,"message":"Unable to fetch data from reporting collector"}
feb 28 09:50:35 ganondorf kibana[14813]: {"type":"error","@timestamp":"2019-02-28T09:50:35Z","tags":["warning","stats-collection"],"pid":14813,"level":"error","error":{"message":"[illegal_argument_exception]
feb 28 09:50:35 ganondorf kibana[14813]: {"type":"log","@timestamp":"2019-02-28T09:50:35Z","tags":["warning","stats-collection"],"pid":14813,"message":"Unable to fetch data from reporting collector"}
feb 28 09:50:45 ganondorf kibana[14813]: {"type":"error","@timestamp":"2019-02-28T09:50:45Z","tags":["warning","stats-collection"],"pid":14813,"level":"error","error":{"message":"[illegal_argument_exception]
feb 28 09:50:45 ganondorf kibana[14813]: {"type":"log","@timestamp":"2019-02-28T09:50:45Z","tags":["warning","stats-collection"],"pid":14813,"message":"Unable to fetch data from reporting collector"}
feb 28 09:50:55 ganondorf kibana[14813]: {"type":"error","@timestamp":"2019-02-28T09:50:55Z","tags":["warning","stats-collection"],"pid":14813,"level":"error","error":{"message":"[illegal_argument_exception]
feb 28 09:50:55 ganondorf kibana[14813]: {"type":"log","@timestamp":"2019-02-28T09:50:55Z","tags":["warning","stats-collection"],"pid":14813,"message":"Unable to fetch data from reporting collector"}
feb 28 09:51:05 ganondorf kibana[14813]: {"type":"error","@timestamp":"2019-02-28T09:51:05Z","tags":["warning","stats-collection"],"pid":14813,"level":"error","error":{"message":"[illegal_argument_exception]
feb 28 09:51:05 ganondorf kibana[14813]: {"type":"log","@timestamp":"2019-02-28T09:51:05Z","tags":["warning","stats-collection"],"pid":14813,"message":"Unable to fetch data from reporting collector"}

```

the cluster health is the following:

root@ganondorf:/etc/kibana# curl -X GET "localhost:9200/\_cluster/stats?human&pretty"  
{  
"\_nodes" : {  
"total" : 1,  
"successful" : 1,  
"failed" : 0  
},  
"cluster\_name" : "elasticsearch",  
"timestamp" : 1551347578159,  
"status" : "yellow",  
"indices" : {  
"count" : 2,  
"shards" : {  
"total" : 6,  
"primaries" : 6,  
"replication" : 0.0,  
"index" : {  
"shards" : {  
"min" : 1,  
"max" : 5,  
"avg" : 3.0  
},  
"primaries" : {  
"min" : 1,  
"max" : 5,  
"avg" : 3.0  
},  
"replication" : {  
"min" : 0.0,  
"max" : 0.0,  
"avg" : 0.0  
}  
}  
},  
"docs" : {  
"count" : 38505389,  
"deleted" : 4  
},  
"store" : {  
"size" : "8.6gb",  
"size\_in\_bytes" : 9245665985  
},  
"fielddata" : {  
"memory\_size" : "784b",  
"memory\_size\_in\_bytes" : 784,  
"evictions" : 0  
},  
"query\_cache" : {  
"memory\_size" : "1.2mb",  
"memory\_size\_in\_bytes" : 1353057,  
"total\_count" : 8120,  
"hit\_count" : 121,  
"miss\_count" : 7999,  
"cache\_size" : 87,  
"cache\_count" : 112,  
"evictions" : 25  
},  
"completion" : {  
"size" : "0b",  
"size\_in\_bytes" : 0  
},  
"segments" : {  
"count" : 117,  
"memory" : "19.1mb",  
"memory\_in\_bytes" : 20033176,  
"terms\_memory" : "13.9mb",  
"terms\_memory\_in\_bytes" : 14624801,  
"stored\_fields\_memory" : "3.6mb",  
"stored\_fields\_memory\_in\_bytes" : 3844168,  
"term\_vectors\_memory" : "0b",  
"term\_vectors\_memory\_in\_bytes" : 0,  
"norms\_memory" : "70.9kb",  
"norms\_memory\_in\_bytes" : 72640,  
"points\_memory" : "1.3mb",  
"points\_memory\_in\_bytes" : 1432371,  
"doc\_values\_memory" : "57.8kb",  
"doc\_values\_memory\_in\_bytes" : 59196,  
"index\_writer\_memory" : "0b",  
"index\_writer\_memory\_in\_bytes" : 0,  
"version\_map\_memory" : "0b",  
"version\_map\_memory\_in\_bytes" : 0,  
"fixed\_bit\_set" : "0b",  
"fixed\_bit\_set\_memory\_in\_bytes" : 0,  
"max\_unsafe\_auto\_id\_timestamp" : 1547970321160,  
"file\_sizes" : { }  
}  
},  
"nodes" : {  
"count" : {  
"total" : 1,  
"data" : 1,  
"coordinating\_only" : 0,  
"master" : 1,  
"ingest" : 1  
},  
"versions" : [  
"6.4.2"  
],  
"os" : {  
"available\_processors" : 4,  
"allocated\_processors" : 4,  
"names" : [  
{  
"name" : "Linux",  
"count" : 1  
}  
],  
"mem" : {  
"total" : "7.7gb",  
"total\_in\_bytes" : 8364498944,  
"free" : "562.3mb",  
"free\_in\_bytes" : 589635584,  
"used" : "7.2gb",  
"used\_in\_bytes" : 7774863360,  
"free\_percent" : 7,  
"used\_percent" : 93  
}  
},  
"process" : {  
"cpu" : {  
"percent" : 22  
},  
"open\_file\_descriptors" : {  
"min" : 309,  
"max" : 309,  
"avg" : 309  
}  
},  
"jvm" : {  
"max\_uptime" : "40d",  
"max\_uptime\_in\_millis" : 3460854107,  
"versions" : [  
{  
"version" : "1.8.0\_191",  
"vm\_name" : "OpenJDK 64-Bit Server VM",  
"vm\_version" : "25.191-b12",  
"vm\_vendor" : "Oracle Corporation",  
"count" : 1  
}  
],  
"mem" : {  
"heap\_used" : "656.9mb",  
"heap\_used\_in\_bytes" : 688877104,  
"heap\_max" : "990.7mb",  
"heap\_max\_in\_bytes" : 1038876672  
},  
"threads" : 148  
},  
"fs" : {  
"total" : "491.1gb",  
"total\_in\_bytes" : 527367929856,  
"free" : "440.6gb",  
"free\_in\_bytes" : 473110618112,  
"available" : "415.6gb",  
"available\_in\_bytes" : 446250455040  
},  
"plugins" : ,  
"network\_types" : {  
"transport\_types" : {  
"security4" : 1  
},  
"http\_types" : {  
"security4" : 1  
}  
}  
}  
}

any idea?

---

<div class="post-metadata">

**Author:** ![nickpeihl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nickpeihl/32/112622_2.png) [@nickpeihl](https://discuss.elastic.co/u/nickpeihl)\
**Post date:** [February 28, 2019, 6:01pm UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-reporting-collector/170308/2 "2019-02-28T18:01:41Z")

</div>

It looks like the lines of the Kibana error logs you copied from stdout are truncated. Can you copy and paste the full lines of the errors from the kibana log file? You may have to set the `logging.dest` parameter in your [`kibana.yml` file](https://www.elastic.co/guide/en/kibana/6.6/settings.html) to create the log file.

---

<div class="post-metadata">

**Author:** ![legolas\_bilbao](https://avatars.discourse-cdn.com/v4/letter/l/3da27b/32.png) [@legolas\_bilbao](https://discuss.elastic.co/u/legolas_bilbao)\
**Post date:** [March 1, 2019, 8:11am UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-reporting-collector/170308/3 "2019-03-01T08:11:20Z")

</div>

Configuration en kibana.yml

# Enables you specify a file where Kibana stores log output.

logging.dest: /home//kibana.txt

# Set the value of this setting to true to suppress all logging output.

#logging.silent: false

# Set the value of this setting to true to suppress all logging output other than error messages.

#logging.quiet: false

# Set the value of this setting to true to log all events, including system usage information

# and all requests.

logging.verbose: true

1. system kibana status after reboot

root@ganondorf:/home/jallende# service kibana status  
● kibana.service - Kibana  
Loaded: loaded (/etc/systemd/system/kibana.service; disabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Fri 2019-03-01 08:10:11 UTC; 2s ago  
Process: 2282 ExecStart=/usr/share/kibana/bin/kibana -c /etc/kibana/kibana.yml (code=exited, status=1/FAILURE)  
Main PID: 2282 (code=exited, status=1/FAILURE)

mar 01 08:10:11 ganondorf systemd[1]: kibana.service: Main process exited, code=exited, status=1/FAILURE  
mar 01 08:10:11 ganondorf systemd[1]: kibana.service: Failed with result 'exit-code'.  
mar 01 08:10:11 ganondorf systemd[1]: kibana.service: Service hold-off time over, scheduling restart.  
mar 01 08:10:11 ganondorf systemd[1]: kibana.service: Scheduled restart job, restart counter is at 3.  
mar 01 08:10:11 ganondorf systemd[1]: Stopped Kibana.  
mar 01 08:10:11 ganondorf systemd[1]: kibana.service: Start request repeated too quickly.  
mar 01 08:10:11 ganondorf systemd[1]: kibana.service: Failed with result 'exit-code'.  
mar 01 08:10:11 ganondorf systemd[1]: Failed to start Kibana.

I dont what is happening now ☹ and the file log is empty

---

<div class="post-metadata">

**Author:** ![nickpeihl](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/nickpeihl/32/112622_2.png) [@nickpeihl](https://discuss.elastic.co/u/nickpeihl)\
**Post date:** [March 1, 2019, 4:17pm UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-reporting-collector/170308/4 "2019-03-01T16:17:44Z")

</div>

Can you post the contents of your `/etc/kibana/kibana.yml` file?

---

<div class="post-metadata">

**Author:** ![legolas\_bilbao](https://avatars.discourse-cdn.com/v4/letter/l/3da27b/32.png) [@legolas\_bilbao](https://discuss.elastic.co/u/legolas_bilbao)\
**Post date:** [March 3, 2019, 6:20pm UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-reporting-collector/170308/5 "2019-03-03T18:20:46Z")

</div>

jallende@hostname:~$ sudo grep -v "#" /etc/kibana/kibana.yml

server.host: "localhost"

logging.dest: /home/path/kibana.txt

logging.verbose: true

---

<div class="post-metadata">

**Author:** ![legolas\_bilbao](https://avatars.discourse-cdn.com/v4/letter/l/3da27b/32.png) [@legolas\_bilbao](https://discuss.elastic.co/u/legolas_bilbao)\
**Post date:** [March 4, 2019, 2:44pm UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-reporting-collector/170308/6 "2019-03-04T14:44:40Z")

</div>

I solved the issue but i dont know why its works. Change the profile for the log from to root to kibana user and it works

regards

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [April 1, 2019, 2:44pm UTC](https://discuss.elastic.co/t/unable-to-fetch-data-from-reporting-collector/170308/7 "2019-04-01T14:44:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
