# Unable to get Elasticsearch console

**URL:** <https://discuss.elastic.co/t/unable-to-get-elasticsearch-console/318534>\
**Category:** Kibana\
**Created:** [November 9, 2022, 11:37am UTC](https://discuss.elastic.co/t/unable-to-get-elasticsearch-console/318534 "2022-11-09T11:37:13Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ravi\_Vishwakarma](https://avatars.discourse-cdn.com/v4/letter/r/58956e/32.png) [@Ravi\_Vishwakarma](https://discuss.elastic.co/u/Ravi_Vishwakarma)\
**Post date:** [November 9, 2022, 11:37am UTC](https://discuss.elastic.co/t/unable-to-get-elasticsearch-console/318534/1 "2022-11-09T11:37:13Z")

</div>

Hi,  
We are not able to get Elasticsearch web console even if we check [https://xxx.xxx.xx.xxx:9200](https://xxx.xxx.xx.xxx:9200) it shows nothing but all the services are running fine.

Please find below logs from Elasticsearch.

```auto
[2022-11-09T16:22:44,539][WARN][o.e.x.m.e.l.LocalExporter] [Prod-ELKPROD] unexpected error while indexing monitoring document
org.elasticsearch.xpack.monitoring.exporter.ExportException: ClusterBlockException[index [.monitoring-es-7-2022.11.09] blocked by: [TOO_MANY_REQUESTS/12/disk usage exceeded flood-stage watermark, index has read-only-allow-delete block];]
	at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.lambda$throwExportException$2(LocalBulk.java:135) ~[x-pack-monitoring-7.17.2.jar:7.17.2]
	at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:197) ~[?:?]
	at java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:179) ~[?:?]
	at java.util.Spliterators$ArraySpliterator.forEachRemaining(Spliterators.java:992) ~[?:?]
	at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:509) ~[?:?]
	at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:499) ~[?:?]
	at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:150) ~[?:?]
	at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:173) ~[?:?]
	at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) ~[?:?]
	at java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:596) ~[?:?]
	at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.throwExportException(LocalBulk.java:136) [x-pack-monitoring-7.17.2.jar:7.17.2]
	at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.lambda$doFlush$0(LocalBulk.java:117) [x-pack-monitoring-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.ActionListener$1.onResponse(ActionListener.java:136) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.support.ContextPreservingActionListener.onResponse(ContextPreservingActionListener.java:31) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.support.TransportAction$1.onResponse(TransportAction.java:88) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.support.TransportAction$1.onResponse(TransportAction.java:82) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.support.ContextPreservingActionListener.onResponse(ContextPreservingActionListener.java:31) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.xpack.security.action.filter.SecurityActionFilter.lambda$applyInternal$2(SecurityActionFilter.java:192) [x-pack-security-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.ActionListener$DelegatingFailureActionListener.onResponse(ActionListener.java:219) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.ActionListener$RunBeforeActionListener.onResponse(ActionListener.java:389) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.ActionListener$MappedActionListener.onResponse(ActionListener.java:101) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.bulk.TransportBulkAction$BulkOperation$1.finishHim(TransportBulkAction.java:625) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.bulk.TransportBulkAction$BulkOperation$1.onFailure(TransportBulkAction.java:620) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.support.TransportAction$1.onFailure(TransportAction.java:97) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.support.ContextPreservingActionListener.onFailure(ContextPreservingActionListener.java:38) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.ActionListener$Delegating.onFailure(ActionListener.java:66) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.support.replication.TransportReplicationAction$ReroutePhase.finishAsFailed(TransportReplicationAction.java:1041) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.support.replication.TransportReplicationAction$ReroutePhase.doRun(TransportReplicationAction.java:818) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:26) [elasticsearch-7.17.2.jar:7.17.2]
	at org.elasticsearch.action.support.replication.TransportReplicationAction.runRerouteP

```

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [November 9, 2022, 12:36pm UTC](https://discuss.elastic.co/t/unable-to-get-elasticsearch-console/318534/2 "2022-11-09T12:36:03Z")

</div>

> [@Ravi\_Vishwakarma](#):
>
> `TOO_MANY_REQUESTS/12/disk usage exceeded flood-stage watermark, index has read-only-allow-delete block`

How many nodes do you have? This log means that the disk in at least one of the nodes is full, you need to clean space by deleting some indices or other things in the server.

---

<div class="post-metadata">

**Author:** ![Ravi\_Vishwakarma](https://avatars.discourse-cdn.com/v4/letter/r/58956e/32.png) [@Ravi\_Vishwakarma](https://discuss.elastic.co/u/Ravi_Vishwakarma)\
**Post date:** [November 9, 2022, 1:46pm UTC](https://discuss.elastic.co/t/unable-to-get-elasticsearch-console/318534/3 "2022-11-09T13:46:38Z")

</div>

Hi,

We are having only one node. And regarding deleting the index can you please suggest me how i can delete the index because i am not able to get Elasticsearch web console. only i can access Elasticsearch server through putty.

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [November 9, 2022, 2:07pm UTC](https://discuss.elastic.co/t/unable-to-get-elasticsearch-console/318534/4 "2022-11-09T14:07:38Z")

</div>

You will need to make requests directly to Elasticsearch from the server or a machine that can access it.

Check the documentation on how to [list the indices](https://www.elastic.co/guide/en/elasticsearch/reference/current/cat-indices.html).

Example:

```auto
curl -X GET "localhost:9200/_cat/indices/my-index-*?v=true&s=index&pretty"

```

After you identify any index that you can delete, you can use the [DELETE API](https://www.elastic.co/guide/en/elasticsearch/reference/current/indices-delete-index.html).

Example:

```auto
curl -X DELETE "localhost:9200/my-index-000001?pretty"

```

---

<div class="post-metadata">

**Author:** ![Ravi\_Vishwakarma](https://avatars.discourse-cdn.com/v4/letter/r/58956e/32.png) [@Ravi\_Vishwakarma](https://discuss.elastic.co/u/Ravi_Vishwakarma)\
**Post date:** [November 10, 2022, 7:05am UTC](https://discuss.elastic.co/t/unable-to-get-elasticsearch-console/318534/5 "2022-11-10T07:05:48Z")

</div>

Hi,

Not able to run the above command it give below error.  
Please find below error snaps.

 ![TEST](https://us1.discourse-cdn.com/elastic/original/3X/c/e/ced4b83e1232ffc165d22da2a59bdf20543c6a08.jpeg)  
 ![TEST1](https://us1.discourse-cdn.com/elastic/original/3X/3/f/3f244cf90f755266c6357a135aa474571f8023cd.jpeg)

```auto

```

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [November 10, 2022, 12:59pm UTC](https://discuss.elastic.co/t/unable-to-get-elasticsearch-console/318534/6 "2022-11-10T12:59:13Z")

</div>

Hello,

Avoid sharing screenshots of text, share the plaintext using the preformatted option in the editor, the `</>`, use screenshots only for visual errors.

From what I was able to see in your screenshot, you didn't pass the credentials, you need to use curl with `-u`, not `-U`.

---

<div class="post-metadata">

**Author:** ![Ravi\_Vishwakarma](https://avatars.discourse-cdn.com/v4/letter/r/58956e/32.png) [@Ravi\_Vishwakarma](https://discuss.elastic.co/u/Ravi_Vishwakarma)\
**Post date:** [November 11, 2022, 5:40am UTC](https://discuss.elastic.co/t/unable-to-get-elasticsearch-console/318534/7 "2022-11-11T05:40:34Z")

</div>

Hi,

Also we are getting below error when we checked in Elasticsearch logs.

```auto
Caused by: org.elasticsearch.action.search.SearchPhaseExecutionExcetion: Search rejected due to missing shards [[.kibana_7.17.2_001][0]]. Consider using 'allow_partial
        at org.elasticsearch.action.search.AbstractSearchAsyncAction.run(AbstractSearchAsyncAction.java:227) ~[elasticsearch-7.17.2.jar:7.17.2]

```

Thanks

---

<div class="post-metadata">

**Author:** ![Ravi\_Vishwakarma](https://avatars.discourse-cdn.com/v4/letter/r/58956e/32.png) [@Ravi\_Vishwakarma](https://discuss.elastic.co/u/Ravi_Vishwakarma)\
**Post date:** [November 14, 2022, 2:08pm UTC](https://discuss.elastic.co/t/unable-to-get-elasticsearch-console/318534/8 "2022-11-14T14:08:49Z")

</div>

Hi,

we have created space on Elasticsearch server but still facing issue.  
we also checked for cluster allocation and found below output.

``{  
"note" : "No shard was specified in the explain API request, so this response explains a randomly chosen unassigned shard. There may be other unassigned shards in this cluster which cannot be assigned for different reasons. It may not be possible to assign this shard until one of the other shards is assigned correctly. To explain the allocation of other shards (whether assigned or unassigned) you must specify the target shard in the request to this API.",  
"index" : "logstash-2022.10.28-000283",  
"shard" : 0,  
"primary" : true,  
"current\_state" : "unassigned",  
"unassigned\_info" : {  
"reason" : " **ALLOCATION\_FAILED**",  
"at" : "2022-11-14T09:51:53.196Z",  
"failed\_allocation\_attempts" : 5,  
"details" : "failed shard on node [OGDf2uTBSrqMUgxwdNucSg]: failed recovery, failure RecoveryFailedException[[logstash-2022.10.28-000283][0]: Recovery failed on {Prod-ELKPROD}{OGDf2uTBSrqMUgxwdNucSg}{fjOvLonZR16OrB6yF58W6Q}{172.19.1.125}{172.19.1.125:9300}{cdfhilmrstw}{ml.machine\_memory=8139542528, xpack.installed=true, transform.node=true, ml.max\_open\_jobs=512, ml.max\_jvm\_size=4072669184}]; nested: IndexShardRecoveryException[failed recovery]; nested: TranslogCorruptedException[translog from source [/elk/elasticsearch/nodes/0/indices/FmuUNJTSTHuSiZ3QENg-rw/0/translog] is corrupted]; nested: NoSuchFileException[/elk/elasticsearch/nodes/0/indices/FmuUNJTSTHuSiZ3QENg-rw/0/translog/translog-6965.tlog]; ",  
"last\_allocation\_status" : "no"  
},  
"can\_allocate" : "yes",  
"allocate\_explanation" : "can allocate the shard",  
"target\_node" : {  
"id" : "OGDf2uTBSrqMUgxwdNucSg",  
"name" : "Prod-ELKPROD",  
"transport\_address" : "xxx.xxx.xx.xx:9300",  
"attributes" : {  
"ml.machine\_memory" : "8139542528",  
"xpack.installed" : "true",  
"transform.node" : "true",  
"ml.max\_open\_jobs" : "512",  
"ml.max\_jvm\_size" : "4072669184"  
}  
},  
"allocation\_id" : "KsHiCPXCTViZuslB\_y\_t3A",  
"node\_allocation\_decisions" : [  
{  
"node\_id" : "OGDf2uTBSrqMUgxwdNucSg",  
"node\_name" : "Prod-ELKPROD",  
"transport\_address" : "xxx.xxx.xx.xx:9300",  
"node\_attributes" : {  
"ml.machine\_memory" : "8139542528",  
"xpack.installed" : "true",  
"transform.node" : "true",  
"ml.max\_open\_jobs" : "512",  
"ml.max\_jvm\_size" : "4072669184"  
},  
"node\_decision" : "yes",  
"store" : {  
"in\_sync" : true,  
"allocation\_id" : "KsHiCPXCTViZuslB\_y\_t3A"  
}  
}  
]  
}`

```auto

Elasticsearch logs below.

```

[2022-11-09T16:22:44,539][WARN][o.e.x.m.e.l.LocalExporter] [Prod-ELKPROD] unexpected error while indexing monitoring document  
org.elasticsearch.xpack.monitoring.exporter.ExportException: ClusterBlockException[index [.monitoring-es-7-2022.11.09] blocked by: [TOO\_MANY\_REQUESTS/12/disk usage exceeded flood-stage watermark, index has read-only-allow-delete block];]  
at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.lambda$throwExportException$2(LocalBulk.java:135) ~[x-pack-monitoring-7.17.2.jar:7.17.2]  
at java.util.stream.ReferencePipeline$3$1.accept(ReferencePipeline.java:197) ~[?:?]  
at java.util.stream.ReferencePipeline$2$1.accept(ReferencePipeline.java:179) ~[?:?]  
at java.util.Spliterators$ArraySpliterator.forEachRemaining(Spliterators.java:992) ~[?:?]  
at java.util.stream.AbstractPipeline.copyInto(AbstractPipeline.java:509) ~[?:?]  
at java.util.stream.AbstractPipeline.wrapAndCopyInto(AbstractPipeline.java:499) ~[?:?]  
at java.util.stream.ForEachOps$ForEachOp.evaluateSequential(ForEachOps.java:150) ~[?:?]  
at java.util.stream.ForEachOps$ForEachOp$OfRef.evaluateSequential(ForEachOps.java:173) ~[?:?]  
at java.util.stream.AbstractPipeline.evaluate(AbstractPipeline.java:234) ~[?:?]  
at java.util.stream.ReferencePipeline.forEach(ReferencePipeline.java:596) ~[?:?]  
at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.throwExportException(LocalBulk.java:136) [x-pack-monitoring-7.17.2.jar:7.17.2]  
at org.elasticsearch.xpack.monitoring.exporter.local.LocalBulk.lambda$doFlush$0(LocalBulk.java:117) [x-pack-monitoring-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.ActionListener$1.onResponse(ActionListener.java:136) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.support.ContextPreservingActionListener.onResponse(ContextPreservingActionListener.java:31) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.support.TransportAction$1.onResponse(TransportAction.java:88) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.support.TransportAction$1.onResponse(TransportAction.java:82) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.support.ContextPreservingActionListener.onResponse(ContextPreservingActionListener.java:31) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.xpack.security.action.filter.SecurityActionFilter.lambda$applyInternal$2(SecurityActionFilter.java:192) [x-pack-security-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.ActionListener$DelegatingFailureActionListener.onResponse(ActionListener.java:219) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.ActionListener$RunBeforeActionListener.onResponse(ActionListener.java:389) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.ActionListener$MappedActionListener.onResponse(ActionListener.java:101) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.bulk.TransportBulkAction$BulkOperation$1.finishHim(TransportBulkAction.java:625) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.bulk.TransportBulkAction$BulkOperation$1.onFailure(TransportBulkAction.java:620) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.support.TransportAction$1.onFailure(TransportAction.java:97) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.support.ContextPreservingActionListener.onFailure(ContextPreservingActionListener.java:38) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.ActionListener$Delegating.onFailure(ActionListener.java:66) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.support.replication.TransportReplicationAction$ReroutePhase.finishAsFailed(TransportReplicationAction.java:1041) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.support.replication.TransportReplicationAction$ReroutePhase.doRun(TransportReplicationAction.java:818) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:26) [elasticsearch-7.17.2.jar:7.17.2]  
at org.elasticsearch.action.support.replication.TransportReplicationAction.runRerouteP

```auto
Let me know how i can resolve this issue because at moment my ELK stack is down not able to access the Elasticsearch web console .

Thanks.
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 12, 2022, 2:09pm UTC](https://discuss.elastic.co/t/unable-to-get-elasticsearch-console/318534/9 "2022-12-12T14:09:08Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
