# Unable to import metricbeat dashboard

**URL:** https://discuss.elastic.co/t/unable-to-import-metricbeat-dashboard/145083
**Category:** Beats
**Tags:** metricbeat
**Created:** [August 20, 2018, 5:00am UTC](https://discuss.elastic.co/t/unable-to-import-metricbeat-dashboard/145083 "2018-08-20T05:00:42Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Tek\_Chand](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tek_chand/32/34318_2.png) [@Tek\_Chand](https://discuss.elastic.co/u/Tek_Chand)
#### Post date: [August 20, 2018, 5:00am UTC](https://discuss.elastic.co/t/unable-to-import-metricbeat-dashboard/145083/1 "2018-08-20T05:00:42Z")

</div>

Hello All,

I am using metricbeat6.2.4. I want to export metricbeat dashboard in kibana. I have configured logstash output in my metricbeat.yml file instead of elasticsearch output. My Kibana dashboard is running on different server and i am using nginx webserver.

When is used the below command to import the dashboard i am getting below error:

```auto
$ /usr/share/metricbeat/bin/metricbeat setup -e -c /etc/metricbeat/metricbeat.yml

```

Error:

```auto
2018-08-20T07:32:00.477Z	INFO	instance/beat.go:468	Home path: [/usr/share/metricbeat/bin] Config path: [/usr/share/metricbeat/bin] Data path: [/usr/share/metricbeat/bin/data] Logs path: [/usr/share/metricbeat/bin/logs]
2018-08-20T07:32:00.478Z	INFO	instance/beat.go:475	Beat UUID: a62b67aa-61ec-44a1-abf0-5632a63ac46f
2018-08-20T07:32:00.478Z	INFO	instance/beat.go:213	Setup Beat: metricbeat; Version: 6.2.4
2018-08-20T07:32:00.480Z	INFO	pipeline/module.go:76	Beat name: orion4
2018-08-20T07:32:00.481Z	ERROR	instance/beat.go:667	Exiting: Template loading requested but the Elasticsearch output is not configured/enabled
Exiting: Template loading requested but the Elasticsearch output is not configured/enabled

```

Can you please help me how i can import metricbeat dashboard.

Any assistance will be appreciated.

Thanks in advance.

---

<div class="post-metadata">

### Author: ![ruflin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ruflin/32/3116_2.png) [@ruflin](https://discuss.elastic.co/u/ruflin)
#### Post date: [August 20, 2018, 12:24pm UTC](https://discuss.elastic.co/t/unable-to-import-metricbeat-dashboard/145083/2 "2018-08-20T12:24:12Z")

</div>

What version of Elasticsearch / Kibana are you using?

It seems the above error comes from the issue that when you run `setup` it also tries to load the template which it can't. Try adding `--dashboard` to only load the dashboard.

---

<div class="post-metadata">

### Author: ![Tek\_Chand](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tek_chand/32/34318_2.png) [@Tek\_Chand](https://discuss.elastic.co/u/Tek_Chand)
#### Post date: [August 20, 2018, 12:38pm UTC](https://discuss.elastic.co/t/unable-to-import-metricbeat-dashboard/145083/3 "2018-08-20T12:38:47Z")

</div>

Hello Ruflin,

Thanks for your response.

After making some changes in my configuration i am able to import the dashboards.

But now i am facing another issue. For some fields i am not getting data on metricbeat dashboard.

Please refer the below screenshot:

 ![Selection_010](https://us1.discourse-cdn.com/elastic/original/3X/f/b/fb88b50bbb87613b27b94f9903167445dcde06de.png)

I am talking about "The request for this panel failed"

I am getting the below log in my elasticsearch:

```auto
Caused by: java.lang.IllegalArgumentException: Fielddata is disabled on text fields by default. Set fielddata=true on [system.network.name] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead.

```

Note:- I am using ELK6.2.4 as well as Beat 6.2.4 version.

Please suggest.

Thanks.

---

<div class="post-metadata">

### Author: ![ruflin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ruflin/32/3116_2.png) [@ruflin](https://discuss.elastic.co/u/ruflin)
#### Post date: [August 21, 2018, 7:12am UTC](https://discuss.elastic.co/t/unable-to-import-metricbeat-dashboard/145083/4 "2018-08-21T07:12:42Z")

</div>

Did you load the metricbeat index template before you started ingesting data?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 18, 2018, 7:12am UTC](https://discuss.elastic.co/t/unable-to-import-metricbeat-dashboard/145083/5 "2018-09-18T07:12:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
