# Unable to initialize Fleet as i get internal server error in kibana logs and on GUI "Default policy could not be added. system is not installed, add system to \`xpack.fleet.packages\` or remove it from system-1" i'm using 3 nodes cluster for elasticsearch

**URL:** https://discuss.elastic.co/t/unable-to-initialize-fleet-as-i-get-internal-server-error-in-kibana-logs-and-on-gui-default-policy-could-not-be-added-system-is-not-installed-add-system-to-xpack-fleet-packages-or-remove-it-from-system-1-im-using-3-nodes-cluster-for-elasticsearch/291555
**Category:** Beats
**Created:** [December 12, 2021, 6:12pm UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-as-i-get-internal-server-error-in-kibana-logs-and-on-gui-default-policy-could-not-be-added-system-is-not-installed-add-system-to-xpack-fleet-packages-or-remove-it-from-system-1-im-using-3-nodes-cluster-for-elasticsearch/291555 "2021-12-12T18:12:18Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![amr\_hamdy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amr_hamdy/32/70904_2.png) [@amr\_hamdy](https://discuss.elastic.co/u/amr_hamdy)
#### Post date: [December 12, 2021, 6:12pm UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-as-i-get-internal-server-error-in-kibana-logs-and-on-gui-default-policy-could-not-be-added-system-is-not-installed-add-system-to-xpack-fleet-packages-or-remove-it-from-system-1-im-using-3-nodes-cluster-for-elasticsearch/291555/1 "2021-12-12T18:12:19Z")

</div>

![fleet](https://us1.discourse-cdn.com/elastic/original/3X/8/1/8192ac9e3dcc5bcc5a38d03ceca8a40a53085013.png)

---

<div class="post-metadata">

### Author: ![amr\_hamdy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amr_hamdy/32/70904_2.png) [@amr\_hamdy](https://discuss.elastic.co/u/amr_hamdy)
#### Post date: [December 15, 2021, 12:47pm UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-as-i-get-internal-server-error-in-kibana-logs-and-on-gui-default-policy-could-not-be-added-system-is-not-installed-add-system-to-xpack-fleet-packages-or-remove-it-from-system-1-im-using-3-nodes-cluster-for-elasticsearch/291555/2 "2021-12-15T12:47:39Z")

</div>

this problem was because of machine was offline when it is online fleet server installed and working

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [January 12, 2022, 12:48pm UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-as-i-get-internal-server-error-in-kibana-logs-and-on-gui-default-policy-could-not-be-added-system-is-not-installed-add-system-to-xpack-fleet-packages-or-remove-it-from-system-1-im-using-3-nodes-cluster-for-elasticsearch/291555/3 "2022-01-12T12:48:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
