# Unable to initialize Fleet in v8.0.0

**URL:** https://discuss.elastic.co/t/unable-to-initialize-fleet-in-v8-0-0/296968
**Category:** Kibana
**Tags:** fleet
**Created:** [February 11, 2022, 11:34am UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-in-v8-0-0/296968 "2022-02-11T11:34:03Z")
**Posts on this page:** 9
**Page:** 1

<div class="post-metadata">

### Author: ![vvlad](https://avatars.discourse-cdn.com/v4/letter/v/77aa72/32.png) [@vvlad](https://discuss.elastic.co/u/vvlad)
#### Post date: [February 11, 2022, 11:34am UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-in-v8-0-0/296968/1 "2022-02-11T11:34:03Z")

</div>

I've just update a cluster from 7.17 to 8.0.0 and the Fleet app in Kibana doesn't work anymore.

I'm running OnPrem on Linux/aarch64.

Is this a known issue?

Logs below:

```auto
{"ecs":{"version":"8.0.0"},"@timestamp":"2022-02-11T11:34:08.907+01:00","message":"There is already an integration policy with the same name","log":{"level":"ERROR","logger":"plugins.fleet"},"process":{"pid":3542038}}
{"ecs":{"version":"8.0.0"},"@timestamp":"2022-02-11T11:34:09.211+01:00","message":"Fleet setup failed","log":{"level":"WARN","logger":"plugins.fleet"},"process":{"pid":3542038}}
{"ecs":{"version":"8.0.0"},"@timestamp":"2022-02-11T11:34:09.212+01:00","message":"elasticsearch not found","error":{"message":"elasticsearch not found","type":"PackageNotFoundError","stack_trace":"PackageNotFoundError: elasticsearch not found\n at Object.fetchFindLatestPackage (/usr/share/kibana/x-pack/plugins/fleet/server/services/epm/registry/index.js:86:11)\n at runMicrotasks (<anonymous>)\n at processTicksAndRejections (node:internal/process/task_queues:96:5)\n at async Promise.all (index 1)\n at getPackageInfo (/usr/share/kibana/x-pack/plugins/fleet/server/services/epm/packages/get.js:167:40)\n at upgradeManagedPackagePolicies (/usr/share/kibana/x-pack/plugins/fleet/server/services/managed_package_policies.js:41:25)\n at ensurePreconfiguredPackagesAndPolicies (/usr/share/kibana/x-pack/plugins/fleet/server/services/preconfiguration.js:339:39)\n at createSetupSideEffects (/usr/share/kibana/x-pack/plugins/fleet/server/services/setup.js:88:7)\n at awaitIfPending (/usr/share/kibana/x-pack/plugins/fleet/server/services/setup_utils.js:38:20)\n at /usr/share/kibana/x-pack/plugins/fleet/server/plugin.js:243:9"},"log":{"level":"WARN","logger":"plugins.fleet"},"process":{"pid":3542038}}

```

---

<div class="post-metadata">

### Author: ![Amine27](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amine27/32/101734_2.png) [@Amine27](https://discuss.elastic.co/u/Amine27)
#### Post date: [February 11, 2022, 6:08pm UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-in-v8-0-0/296968/2 "2022-02-11T18:08:25Z")

</div>

I am having the same problem but with docker integration.  
It seems that some integrations are not yet ready for 8.0.0, and Kibana just can't setup Fleet server! Any way to uninstall non-updated integrations?

Logs:

```auto
[2022-02-11T18:06:22.508+00:00][INFO][plugins.fleet] Beginning fleet setup  
[2022-02-11T18:06:25.724+00:00][ERROR][plugins.fleet] docker not found

```

---

<div class="post-metadata">

### Author: ![zx8086](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zx8086/32/94917_2.png) [@zx8086](https://discuss.elastic.co/u/zx8086)
#### Post date: [February 11, 2022, 10:17pm UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-in-v8-0-0/296968/3 "2022-02-11T22:17:55Z")

</div>

Same issue ....

Upgraded from 7.17 to 8.0 and Fleet cannot initialize

```auto
[2022-02-11T23:00:49.934+01:00] [WARN] [plugins.fleet] [] Fleet setup failed
[2022-02-11T23:00:49.935+01:00] [WARN] [plugins.fleet] [] PackageNotFoundError: elasticsearch not found
    at Object.fetchFindLatestPackage (/usr/share/kibana/x-pack/plugins/fleet/server/services/epm/registry/index.js:86:11)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at async Promise.all (index 1)
    at getPackageInfo (/usr/share/kibana/x-pack/plugins/fleet/server/services/epm/packages/get.js:167:40)
    at upgradeManagedPackagePolicies (/usr/share/kibana/x-pack/plugins/fleet/server/services/managed_package_policies.js:41:25)
    at ensurePreconfiguredPackagesAndPolicies (/usr/share/kibana/x-pack/plugins/fleet/server/services/preconfiguration.js:339:39)
    at createSetupSideEffects (/usr/share/kibana/x-pack/plugins/fleet/server/services/setup.js:88:7)
    at awaitIfPending (/usr/share/kibana/x-pack/plugins/fleet/server/services/setup_utils.js:38:20)
    at /usr/share/kibana/x-pack/plugins/fleet/server/plugin.js:243:9
[2022-02-11T23:00:49.941+01:00] [INFO] [plugins.securitySolution] [] Dependent plugin setup complete - Starting ManifestTask
[2022-02-11T23:00:50.438+01:00] [INFO] [status] [] Kibana is now degraded
[2022-02-11T23:00:59.003+01:00] [INFO] [status] [] Kibana is now available (was degraded)
[2022-02-11T23:02:42.412+01:00] [INFO] [plugins.security.routes] [] Logging in with provider "basic" (basic)
[2022-02-11T23:02:45.318+01:00] [INFO] [plugins.fleet] [] Beginning fleet setup
[2022-02-11T23:02:45.450+01:00] [ERROR] [plugins.fleet] [] elasticsearch not found
[2022-02-11T23:02:55.907+01:00] [INFO] [plugins.fleet] [] Beginning fleet setup
[2022-02-11T23:02:56.193+01:00] [ERROR] [plugins.fleet] [] elasticsearch not found
[2022-02-11T23:07:09.809+01:00] [ERROR] [plugins.fleet] [] elasticsearch not found
[2022-02-11T23:12:00.212+01:00] [ERROR] [plugins.fleet] [] kibana not found

```

 ![Screen Shot 2022-02-11 at 11.17.22 PM](https://us1.discourse-cdn.com/elastic/original/3X/9/6/96da464c4445049d97b638cfea6343f961b122e1.png)

---

<div class="post-metadata">

### Author: ![zx8086](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zx8086/32/94917_2.png) [@zx8086](https://discuss.elastic.co/u/zx8086)
#### Post date: [February 11, 2022, 11:01pm UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-in-v8-0-0/296968/4 "2022-02-11T23:01:09Z")

</div>

@Amine27 , @vvlad

Resolved it by finding out the Packages ID's for Elasticsearch, Logstash and Kibana... the ones at fault and then deleting them, checking if they existed in other policies by checking the stat to be 100% sure those integrations were deleted.

[http://192.168.0.156:5601/api/fleet/package\_policies](http://192.168.0.156:5601/api/fleet/package_policies) -\> get the policy id's

 ![Screen Shot 2022-02-12 at 12.01.59 AM](https://us1.discourse-cdn.com/elastic/original/3X/3/4/34ced9fcd174ed0be3d561956eb4f8211e595f0c.jpeg)

 ![Screen Shot 2022-02-11 at 11.56.38 PM](https://us1.discourse-cdn.com/elastic/original/3X/c/e/ce34afbfe47950a78ba03dc7459dcfb069cb3c77.png)  
 ![Screen Shot 2022-02-11 at 11.56.57 PM](https://us1.discourse-cdn.com/elastic/original/3X/1/b/1ba05ee61fb3ced7f57e6a65f8fe811efaaf4ff7.png)  
 ![Screen Shot 2022-02-11 at 11.57.16 PM](https://us1.discourse-cdn.com/elastic/original/3X/4/3/43bab52f8ffdc72eeb71af0e4f921c33c7b3a220.png)

---

<div class="post-metadata">

### Author: ![Amine27](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/amine27/32/101734_2.png) [@Amine27](https://discuss.elastic.co/u/Amine27)
#### Post date: [February 12, 2022, 7:03am UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-in-v8-0-0/296968/5 "2022-02-12T07:03:01Z")

</div>

@zx8086 Good.  
For me, docker integration just get updated to v8.0.0 today, and Fleet setup complete successfully.

---

<div class="post-metadata">

### Author: ![vvlad](https://avatars.discourse-cdn.com/v4/letter/v/77aa72/32.png) [@vvlad](https://discuss.elastic.co/u/vvlad)
#### Post date: [February 12, 2022, 10:04am UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-in-v8-0-0/296968/6 "2022-02-12T10:04:34Z")

</div>

It's likely they haven't released all the updated integrations.

[The local registry](https://www.elastic.co/guide/en/fleet/8.0/air-gapped.html) isn't available either:

```nohighlight
» docker pull docker.elastic.co/package-registry/distribution:8.0.0

Trying to pull docker.elastic.co/package-registry/distribution:8.0.0...
Error: initializing source docker://docker.elastic.co/package-registry/distribution:8.0.0: reading manifest 8.0.0 in docker.elastic.co/package-registry/distribution: manifest unknown: manifest unknown

```

---

<div class="post-metadata">

### Author: ![zx8086](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zx8086/32/94917_2.png) [@zx8086](https://discuss.elastic.co/u/zx8086)
#### Post date: [February 12, 2022, 1:08pm UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-in-v8-0-0/296968/7 "2022-02-12T13:08:09Z")

</div>

Always seems to be the case with new releases, seen this happen too often, an integration or build for a particular platform architecture coming days or weeks after, which break an previously working environment.

---

<div class="post-metadata">

### Author: ![joshdover](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/joshdover/32/42020_2.png) [@joshdover](https://discuss.elastic.co/u/joshdover)
#### Post date: [February 14, 2022, 3:59pm UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-in-v8-0-0/296968/8 "2022-02-14T15:59:42Z")

</div>

Hi all,

Thanks for being such early adopters of the 8.0 major version!

We did have an issue with some packages not being released in time, and I want to give an update here for clarity:

- The `docker` package was not released for 8.0 until late on Friday, Feb 11. If you were seeing errors like `docker not found` try again and things should be working now.
- Some other packages have not been released for 8.0 and this is intentional. Some were deprecated or still experimental and we decided to not yet release those. Examples are `cyberark`, `microsoft` (been replaced by more discrete packages), `elasticsearch` and `logstash`. To get around the issue with these packages you'd need to use our API (see [zx8086's post](https://discuss.elastic.co/t/unable-to-initialize-fleet-in-v8-0-0/296968/4)) to delete any package policies that reference them and then delete the package. Alternatively, [we're working on a fix](https://github.com/elastic/kibana/issues/125409) that we'll try to get into a patch release here shortly.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [March 14, 2022, 3:59pm UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-in-v8-0-0/296968/9 "2022-03-14T15:59:55Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
