# Unable to initialize Fleet on Kibana in Ubuntu 22.04

**URL:** <https://discuss.elastic.co/t/unable-to-initialize-fleet-on-kibana-in-ubuntu-22-04/334618>\
**Category:** Kibana\
**Tags:** painless, fleet\
**Created:** [May 29, 2023, 8:45pm UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-on-kibana-in-ubuntu-22-04/334618 "2023-05-29T20:45:35Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![Calvy93](https://avatars.discourse-cdn.com/v4/letter/c/82dd89/32.png) [@Calvy93](https://discuss.elastic.co/u/Calvy93)\
**Post date:** [June 1, 2023, 10:25am UTC](https://discuss.elastic.co/t/unable-to-initialize-fleet-on-kibana-in-ubuntu-22-04/334618/3 "2023-06-01T10:25:07Z")

</div>

Hi, thank you for your reply.

> Is that from `/var/log/kibana/kibana/log`?

Yes, respectively from /var/log/kibana/kibana.log.

> That should be `127.0.0.1:9200` as Kibana uses the API and not the transport protocol.

That distinction really confuses me. I'm not sure whether I understood the answer in [this thread](https://discuss.elastic.co/t/elasticsearch-port-9200-or-9300/72080/2) correctly, but 9300 seemed to be the obligatory port to set and 9200 only an optional one. But maybe I got it the wrong way around.  
Now that I've set the port to 9200 in the kibana.yml, the "systemctl status kibana" command reveals a running kibana service but also an error ECONNREFUSED. When I test the connection with curl, the command with port 9300 returns a valid answer, but the command with port 9200 only returns a "connection refused" error. How do I proceed from here to get the connection through?

---

_[View the full topic](https://discuss.elastic.co/t/unable-to-initialize-fleet-on-kibana-in-ubuntu-22-04/334618)._
