# Unable to install and start the elasticsearch in RHEL 7 due to polkit error

**URL:** <https://discuss.elastic.co/t/unable-to-install-and-start-the-elasticsearch-in-rhel-7-due-to-polkit-error/249847>\
**Category:** Elasticsearch\
**Created:** [September 24, 2020, 3:18pm UTC](https://discuss.elastic.co/t/unable-to-install-and-start-the-elasticsearch-in-rhel-7-due-to-polkit-error/249847 "2020-09-24T15:18:58Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![aknraj](https://avatars.discourse-cdn.com/v4/letter/a/b4bc9f/32.png) [@aknraj](https://discuss.elastic.co/u/aknraj)\
**Post date:** [September 24, 2020, 3:18pm UTC](https://discuss.elastic.co/t/unable-to-install-and-start-the-elasticsearch-in-rhel-7-due-to-polkit-error/249847/1 "2020-09-24T15:18:58Z")

</div>

I am unable to start hte elasticsearch after the installation due to the below error. I have tried multiple options as recommended in other topics like reinstalling, enusing right java\_home, giving full permissions, but it didn't help. Please share solution if you have implemented any specific changes to resolve this. it would be helpful for me

## Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: fatal error in thread [main], exiting Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: java.lang.NoClassDefFoundError: Could not initialize class c Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at org.elasticsearch.systemd.Libsystemd.lambda$static$0(Libs Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at java.security.AccessController.doPrivileged(Native Method Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at org.elasticsearch.systemd.Libsystemd.(Libsystemd. Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at org.elasticsearch.systemd.SystemdPlugin.sd\_notify(Systemd Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at org.elasticsearch.systemd.SystemdPlugin.onNodeStarted(Sys Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at java.util.ArrayList.forEach(ArrayList.java:1259) Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at org.elasticsearch.node.Node.start(Node.java:868) Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.jav Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsea Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elastic Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(Env Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Co Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at org.elasticsearch.cli.Command.main(Command.java:90) Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsea Sep 24 10:30:50 lfltst001x systemd-entrypoint[16005]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsea Sep 24 10:30:50 lfltst001x systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE Sep 24 10:30:50 lfltst001x systemd[1]: Failed to start Elasticsearch. -- Subject: Unit elasticsearch.service has failed -- Defined-By: systemd -- Support: [http://lists.freedesktop.org/mailman/listinfo/systemd-devel](http://lists.freedesktop.org/mailman/listinfo/systemd-devel)

## -- Unit elasticsearch.service has failed.

-- The result is failed.  
Sep 24 10:30:50 lfltst001x systemd[1]: Unit elasticsearch.service entered failed state.  
Sep 24 10:30:50 lfltst001x systemd[1]: elasticsearch.service failed.  
Sep 24 10:30:50 lfltst001x polkitd[1010]: Unregistered Authentication Agent for unix-process:15998:366323193 (syst  
lines 2021-2050/2050 (END)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 28, 2020, 3:51am UTC](https://discuss.elastic.co/t/unable-to-install-and-start-the-elasticsearch-in-rhel-7-due-to-polkit-error/249847/2 "2020-09-28T03:51:15Z")

</div>

Let's continue the discussion in your other thread - [Unable to install elasticsearch in RHEL 7 due to polkit error](https://discuss.elastic.co/t/unable-to-install-elasticsearch-in-rhel-7-due-to-polkit-error/249845) 🙂

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 28, 2020, 3:51am UTC](https://discuss.elastic.co/t/unable-to-install-and-start-the-elasticsearch-in-rhel-7-due-to-polkit-error/249847/3 "2020-09-28T03:51:18Z")

</div>


