# Unable to install elasticsearch 5.5.1 ,facing issues

**URL:** <https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5-1-facing-issues/95281>\
**Category:** Elasticsearch\
**Created:** [August 1, 2017, 5:37am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5-1-facing-issues/95281 "2017-08-01T05:37:06Z")\
**Posts on this page:** 8\
**Page:** 1

<div class="post-metadata">

**Author:** ![vijjun123](https://avatars.discourse-cdn.com/v4/letter/v/cab0a1/32.png) [@vijjun123](https://discuss.elastic.co/u/vijjun123)\
**Post date:** [August 1, 2017, 5:37am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5-1-facing-issues/95281/1 "2017-08-01T05:37:06Z")

</div>

Hi All,

Unable to install elasticsearch 5.5.1 and facing the below error.  
Could you please help me for further

ERROR: [2] bootstrap checks failed  
[1]: max file descriptors [4096] for elasticsearch process is too low, increase to at least [65536]  
[2]: memory locking requested for elasticsearch process but memory is not locked

Error :

bin]$ ./elasticsearch  
[2017-08-01T05:35:39,427][WARN][o.e.b.JNANatives] Unable to lock JVM Memory: error=12, reason=Cannot allocate memory  
[2017-08-01T05:35:39,429][WARN][o.e.b.JNANatives] This can result in part of the JVM being swapped out.  
[2017-08-01T05:35:39,429][WARN][o.e.b.JNANatives] Increase RLIMIT\_MEMLOCK, soft limit: 65536, hard limit: 65536  
[2017-08-01T05:35:39,429][WARN][o.e.b.JNANatives] These can be adjusted by modifying /etc/security/limits.conf, for example:  
# allow user 'ec2-user' mlockall  
ec2-user soft memlock unlimited  
ec2-user hard memlock unlimited  
[2017-08-01T05:35:39,430][WARN][o.e.b.JNANatives] If you are logged in interactively, you will have to re-login for the new limits to take effect.  
[2017-08-01T05:35:39,544][INFO][o.e.n.Node] [] initializing ...  
[2017-08-01T05:35:39,606][INFO][o.e.e.NodeEnvironment] [Ih\_X-z-] using [1] data paths, mounts [[/ (/dev/xvda1)]], net usable\_space [95.8gb], net total\_space [98.3gb], spins? [no], types [ext4]  
[2017-08-01T05:35:39,606][INFO][o.e.e.NodeEnvironment] [Ih\_X-z-] heap size [1.9gb], compressed ordinary object pointers [true]  
[2017-08-01T05:35:39,607][INFO][o.e.n.Node] node name [Ih\_X-z-] derived from node ID [Ih\_X-z-cT4ain1knIbRuEw]; set [[node.name](http://node.name)] to override  
[2017-08-01T05:35:39,607][INFO][o.e.n.Node] version[5.5.1], pid[16527], build[19c13d0/2017-07-18T20:44:24.823Z], OS[Linux/4.9.38-16.33.amzn1.x86\_64/amd64], JVM[Oracle Corporation/Java HotSpot(TM) 64-Bit Server VM/1.8.0\_141/25.141-b15]  
[2017-08-01T05:35:39,607][INFO][o.e.n.Node] JVM arguments [-Xms2g, -Xmx2g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -Djdk.io.permissionsUseCanonicalPath=true, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Dlog4j.skipJansi=true, -XX:+HeapDumpOnOutOfMemoryError, -Des.path.home=/home/ec2-user/elasticsearch-5.5.1]  
[2017-08-01T05:35:40,430][INFO][o.e.p.PluginsService] [Ih\_X-z-] loaded module [aggs-matrix-stats]  
[2017-08-01T05:35:40,431][INFO][o.e.p.PluginsService] [Ih\_X-z-] loaded module [ingest-common]  
[2017-08-01T05:35:40,431][INFO][o.e.p.PluginsService] [Ih\_X-z-] loaded module [lang-expression]  
[2017-08-01T05:35:40,431][INFO][o.e.p.PluginsService] [Ih\_X-z-] loaded module [lang-groovy]  
[2017-08-01T05:35:40,431][INFO][o.e.p.PluginsService] [Ih\_X-z-] loaded module [lang-mustache]  
[2017-08-01T05:35:40,431][INFO][o.e.p.PluginsService] [Ih\_X-z-] loaded module [lang-painless]  
[2017-08-01T05:35:40,432][INFO][o.e.p.PluginsService] [Ih\_X-z-] loaded module [parent-join]  
[2017-08-01T05:35:40,432][INFO][o.e.p.PluginsService] [Ih\_X-z-] loaded module [percolator]  
[2017-08-01T05:35:40,432][INFO][o.e.p.PluginsService] [Ih\_X-z-] loaded module [reindex]  
[2017-08-01T05:35:40,432][INFO][o.e.p.PluginsService] [Ih\_X-z-] loaded module [transport-netty3]  
[2017-08-01T05:35:40,432][INFO][o.e.p.PluginsService] [Ih\_X-z-] loaded module [transport-netty4]  
[2017-08-01T05:35:40,433][INFO][o.e.p.PluginsService] [Ih\_X-z-] no plugins loaded  
[2017-08-01T05:35:41,923][INFO][o.e.d.DiscoveryModule] [Ih\_X-z-] using discovery type [zen]  
[2017-08-01T05:35:42,572][INFO][o.e.n.Node] initialized  
[2017-08-01T05:35:42,572][INFO][o.e.n.Node] [Ih\_X-z-] starting ...  
[2017-08-01T05:35:42,700][INFO][o.e.t.TransportService] [Ih\_X-z-] publish\_address {172.18.7.177:9300}, bound\_addresses {172.18.7.177:9300}  
[2017-08-01T05:35:42,713][INFO][o.e.b.BootstrapChecks] [Ih\_X-z-] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks  
ERROR: [2] bootstrap checks failed  
[1]: max file descriptors [4096] for elasticsearch process is too low, increase to at least [65536]  
[2]: memory locking requested for elasticsearch process but memory is not locked  
[2017-08-01T05:35:42,725][INFO][o.e.n.Node] [Ih\_X-z-] stopping ...  
[2017-08-01T05:35:42,740][INFO][o.e.n.Node] [Ih\_X-z-] stopped  
[2017-08-01T05:35:42,740][INFO][o.e.n.Node] [Ih\_X-z-] closing ...  
[2017-08-01T05:35:42,752][INFO][o.e.n.Node] [Ih\_X-z-] closed

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 1, 2017, 6:00am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5-1-facing-issues/95281/2 "2017-08-01T06:00:12Z")

</div>

Please read [https://www.elastic.co/guide/en/elasticsearch/reference/5.5/bootstrap-checks.html](https://www.elastic.co/guide/en/elasticsearch/reference/5.5/bootstrap-checks.html)

---

<div class="post-metadata">

**Author:** ![vijjun123](https://avatars.discourse-cdn.com/v4/letter/v/cab0a1/32.png) [@vijjun123](https://discuss.elastic.co/u/vijjun123)\
**Post date:** [August 1, 2017, 6:31am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5-1-facing-issues/95281/3 "2017-08-01T06:31:44Z")

</div>

Hi Thansk for the update,

I have done the changes but still got the below error.

$ ./elasticsearch  
[2017-08-01T06:30:58,365][WARN][o.e.b.JNANatives] Unable to lock JVM Memory: error=12, reason=Cannot allocate memory  
[2017-08-01T06:30:58,375][WARN][o.e.b.JNANatives] This can result in part of the JVM being swapped out.  
[2017-08-01T06:30:58,376][WARN][o.e.b.JNANatives] Increase RLIMIT\_MEMLOCK, soft limit: 65536, hard limit: 65536  
[2017-08-01T06:30:58,376][WARN][o.e.b.JNANatives] These can be adjusted by modifying /etc/security/limits.conf, for example:  
# allow user 'ec2-user' mlockall  
ec2-user soft memlock unlimited  
ec2-user hard memlock unlimited  
[2017-08-01T06:30:58,379][WARN][o.e.b.JNANatives] If you are logged in interactively, you will have to re-login for the new limits to take effect.  
[2017-08-01T06:30:58,700][INFO][o.e.n.Node] [node-1] initializing ...  
[2017-08-01T06:30:59,081][INFO][o.e.e.NodeEnvironment] [node-1] using [1] data paths, mounts [[/ (/dev/xvda1)]], net usable\_space [95.8gb], net total\_space [98.3gb], spins? [no], types [ext4]  
[2017-08-01T06:30:59,081][INFO][o.e.e.NodeEnvironment] [node-1] heap size [1.9gb], compressed ordinary object pointers [true]  
[2017-08-01T06:30:59,082][INFO][o.e.n.Node] [node-1] node name [node-1], node ID [Ih\_X-z-cT4ain1knIbRuEw]  
[2017-08-01T06:30:59,082][INFO][o.e.n.Node] [node-1] version[5.5.1], pid[3441], build[19c13d0/2017-07-18T20:44:24.823Z], OS[Linux/4.9.38-16.33.amzn1.x86\_64/amd64], JVM[Oracle Corporation/Java HotSpot(TM) 64-Bit Server VM/1.8.0\_141/25.141-b15]  
[2017-08-01T06:30:59,082][INFO][o.e.n.Node] [node-1] JVM arguments [-Xms2g, -Xmx2g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:+UseCMSInitiatingOccupancyOnly, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -Djdk.io.permissionsUseCanonicalPath=true, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=true, -Dlog4j.skipJansi=true, -XX:+HeapDumpOnOutOfMemoryError, -Des.path.home=/home/ec2-user/elasticsearch-5.5.1]  
[2017-08-01T06:31:02,089][INFO][o.e.p.PluginsService] [node-1] loaded module [aggs-matrix-stats]  
[2017-08-01T06:31:02,090][INFO][o.e.p.PluginsService] [node-1] loaded module [ingest-common]  
[2017-08-01T06:31:02,090][INFO][o.e.p.PluginsService] [node-1] loaded module [lang-expression]  
[2017-08-01T06:31:02,090][INFO][o.e.p.PluginsService] [node-1] loaded module [lang-groovy]  
[2017-08-01T06:31:02,090][INFO][o.e.p.PluginsService] [node-1] loaded module [lang-mustache]  
[2017-08-01T06:31:02,090][INFO][o.e.p.PluginsService] [node-1] loaded module [lang-painless]  
[2017-08-01T06:31:02,090][INFO][o.e.p.PluginsService] [node-1] loaded module [parent-join]  
[2017-08-01T06:31:02,090][INFO][o.e.p.PluginsService] [node-1] loaded module [percolator]  
[2017-08-01T06:31:02,092][INFO][o.e.p.PluginsService] [node-1] loaded module [reindex]  
[2017-08-01T06:31:02,092][INFO][o.e.p.PluginsService] [node-1] loaded module [transport-netty3]  
[2017-08-01T06:31:02,093][INFO][o.e.p.PluginsService] [node-1] loaded module [transport-netty4]  
[2017-08-01T06:31:02,093][INFO][o.e.p.PluginsService] [node-1] no plugins loaded  
[2017-08-01T06:31:07,722][INFO][o.e.d.DiscoveryModule] [node-1] using discovery type [zen]  
[2017-08-01T06:31:08,572][INFO][o.e.n.Node] [node-1] initialized  
[2017-08-01T06:31:08,572][INFO][o.e.n.Node] [node-1] starting ...  
[2017-08-01T06:31:09,017][INFO][o.e.t.TransportService] [node-1] publish\_address {172.18.7.177:9300}, bound\_addresses {172.18.7.177:9300}  
[2017-08-01T06:31:09,026][INFO][o.e.b.BootstrapChecks] [node-1] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks  
ERROR: [3] bootstrap checks failed  
[1]: max file descriptors [4096] for elasticsearch process is too low, increase to at least [65536]  
[2]: memory locking requested for elasticsearch process but memory is not locked  
[3]: max virtual memory areas vm.max\_map\_count [65530] is too low, increase to at least [262144]  
[2017-08-01T06:31:09,041][INFO][o.e.n.Node] [node-1] stopping ...  
[2017-08-01T06:31:09,098][INFO][o.e.n.Node] [node-1] stopped  
[2017-08-01T06:31:09,098][INFO][o.e.n.Node] [node-1] closing ...  
[2017-08-01T06:31:09,116][INFO][o.e.n.Node] [node-1] closed

ERROR: [3] bootstrap checks failed  
[1]: max file descriptors [4096] for elasticsearch process is too low, increase to at least [65536]  
[2]: memory locking requested for elasticsearch process but memory is not locked  
[3]: max virtual memory areas vm.max\_map\_count [65530] is too low, increase to at least [262144]

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [August 1, 2017, 6:33am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5-1-facing-issues/95281/4 "2017-08-01T06:33:02Z")

</div>

> [@vijjun123](#):
>
> ERROR: [3] bootstrap checks failed  
> [1]: max file descriptors [4096] for elasticsearch process is too low, increase to at least [65536]  
> [2]: memory locking requested for elasticsearch process but memory is not locked  
> [3]: max virtual memory areas vm.max\_map\_count [65530] is too low, increase to at least [262144]

Looks like you have missed some?

---

<div class="post-metadata">

**Author:** ![pjanzen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pjanzen/32/13756_2.png) [@pjanzen](https://discuss.elastic.co/u/pjanzen)\
**Post date:** [August 1, 2017, 7:44am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5-1-facing-issues/95281/5 "2017-08-01T07:44:13Z")

</div>

When I applied those settings I reboot the box, that solved my issue when I faced this.

---

<div class="post-metadata">

**Author:** ![vijjun123](https://avatars.discourse-cdn.com/v4/letter/v/cab0a1/32.png) [@vijjun123](https://discuss.elastic.co/u/vijjun123)\
**Post date:** [August 1, 2017, 8:04am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5-1-facing-issues/95281/6 "2017-08-01T08:04:36Z")

</div>

i have rebooted the box but still facing the below error.

Error [1] bootstrap checks failed  
[1]: max virtual memory areas vm.max\_map\_count [65530] is too low, increase to at least [262144]

[2017-08-01T07:54:41,043][INFO][o.e.p.PluginsService] [node-1] no plugins loaded  
[2017-08-01T07:54:42,730][INFO][o.e.d.DiscoveryModule] [node-1] using discovery type [zen]  
[2017-08-01T07:54:43,278][INFO][o.e.n.Node] [node-1] initialized  
[2017-08-01T07:54:43,278][INFO][o.e.n.Node] [node-1] starting ...  
[2017-08-01T07:54:43,405][INFO][o.e.t.TransportService] [node-1] publish\_address {172.18.7.177:9300}, bound\_addresses {172.18.7.177:9300}  
[2017-08-01T07:54:43,415][INFO][o.e.b.BootstrapChecks] [node-1] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks  
[2017-08-01T07:54:46,470][INFO][o.e.c.s.ClusterService] [node-1] new\_master {node-1}{Ih\_X-z-cT4ain1knIbRuEw}{OvgW8m1sRHatpvM7BEAQQA}{172.18.7.177}{172.18.7.177:9300}, reason: zen-disco-elected-as-master ([0] nodes joined)  
[2017-08-01T07:54:46,497][INFO][o.e.h.n.Netty4HttpServerTransport] [node-1] publish\_address {172.18.7.177:9200}, bound\_addresses {172.18.7.177:9200}  
[2017-08-01T07:54:46,497][INFO][o.e.n.Node] [node-1] started  
[2017-08-01T07:54:46,501][INFO][o.e.g.GatewayService] [node-1] recovered [0] indices into cluster\_state  
^C  
[ec2-user@ip-172-18-7-177 logs]$ less DemoAug1.log  
[2017-08-01T07:11:19,207][INFO][o.e.n.Node] [node-1] initializing ...  
[2017-08-01T07:11:19,271][INFO][o.e.e.NodeEnvironment] [node-1] using [1] data paths, mounts [[/ (/dev/xvda1)]], net usable\_space [89.5gb], net total\_space [98.3gb  
], spins? [no], types [ext4]  
[2017-08-01T07:11:19,271][INFO][o.e.e.NodeEnvironment] [node-1] heap size [1.9gb], compressed ordinary object pointers [true]  
[2017-08-01T07:11:19,272][INFO][o.e.n.Node] [node-1] node name [node-1], node ID [Ih\_X-z-cT4ain1knIbRuEw]  
[2017-08-01T07:11:19,273][INFO][o.e.n.Node] [node-1] version[5.5.1], pid[3024], build[19c13d0/2017-07-18T20:44:24.823Z], OS[Linux/4.9.38-16.33.amzn1.x86  
\_64/amd64], JVM[Oracle Corporation/Java HotSpot(TM) 64-Bit Server VM/1.8.0\_141/25.141-b15]  
[2017-08-01T07:11:19,273][INFO][o.e.n.Node] [node-1] JVM arguments [-Xms2g, -Xmx2g, -XX:+UseConcMarkSweepGC, -XX:CMSInitiatingOccupancyFraction=75, -XX:  
+UseCMSInitiatingOccupancyOnly, -XX:+AlwaysPreTouch, -Xss1m, -Djava.awt.headless=true, -Dfile.encoding=UTF-8, -Djna.nosys=true, -Djdk.io.permissionsUseCanonicalPath=tru  
e, -Dio.netty.noUnsafe=true, -Dio.netty.noKeySetOptimization=true, -Dio.netty.recycler.maxCapacityPerThread=0, -Dlog4j.shutdownHookEnabled=false, -Dlog4j2.disable.jmx=t  
rue, -Dlog4j.skipJansi=true, -XX:+HeapDumpOnOutOfMemoryError, -Des.path.home=/home/ec2-user/elasticsearch-5.5.1]  
[2017-08-01T07:11:20,201][INFO][o.e.p.PluginsService] [node-1] loaded module [aggs-matrix-stats]  
[2017-08-01T07:11:20,202][INFO][o.e.p.PluginsService] [node-1] loaded module [ingest-common]  
[2017-08-01T07:11:20,202][INFO][o.e.p.PluginsService] [node-1] loaded module [lang-expression]  
[2017-08-01T07:11:20,202][INFO][o.e.p.PluginsService] [node-1] loaded module [lang-groovy]  
[2017-08-01T07:11:20,202][INFO][o.e.p.PluginsService] [node-1] loaded module [lang-mustache]  
[2017-08-01T07:11:20,202][INFO][o.e.p.PluginsService] [node-1] loaded module [lang-painless]  
[2017-08-01T07:11:20,203][INFO][o.e.p.PluginsService] [node-1] loaded module [parent-join]  
[2017-08-01T07:11:20,203][INFO][o.e.p.PluginsService] [node-1] loaded module [percolator]  
[2017-08-01T07:11:20,203][INFO][o.e.p.PluginsService] [node-1] loaded module [reindex]  
[2017-08-01T07:11:20,203][INFO][o.e.p.PluginsService] [node-1] loaded module [transport-netty3]  
[2017-08-01T07:11:20,204][INFO][o.e.p.PluginsService] [node-1] loaded module [transport-netty4]  
[2017-08-01T07:11:20,204][INFO][o.e.p.PluginsService] [node-1] no plugins loaded  
[2017-08-01T07:11:22,147][INFO][o.e.d.DiscoveryModule] [node-1] using discovery type [zen]  
[2017-08-01T07:11:22,695][INFO][o.e.n.Node] [node-1] initialized  
[2017-08-01T07:11:22,695][INFO][o.e.n.Node] [node-1] starting ...  
[2017-08-01T07:11:22,900][INFO][o.e.t.TransportService] [node-1] publish\_address {172.18.7.177:9300}, bound\_addresses {172.18.7.177:9300}  
[2017-08-01T07:11:22,909][INFO][o.e.b.BootstrapChecks] [node-1] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks  
[2017-08-01T07:11:22,914][ERROR][o.e.b.Bootstrap] [node-1] node validation exception  
[1] bootstrap checks failed  
[1]: max virtual memory areas vm.max\_map\_count [65530] is too low, increase to at least [262144]  
[2017-08-01T07:11:22,916][INFO][o.e.n.Node] [node-1] stopping ...  
[2017-08-01T07:11:22,950][INFO][o.e.n.Node] [node-1] stopped  
[2017-08-01T07:11:22,951][INFO][o.e.n.Node] [node-1] closing ...  
[2017-08-01T07:11:22,963][INFO][o.e.n.Node] [node-1] closed

---

<div class="post-metadata">

**Author:** ![pjanzen](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/pjanzen/32/13756_2.png) [@pjanzen](https://discuss.elastic.co/u/pjanzen)\
**Post date:** [August 1, 2017, 12:15pm UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5-1-facing-issues/95281/7 "2017-08-01T12:15:13Z")

</div>

On what type of hardware / container are you installing this? if you do this on a container with a shared kernel you need to set the sysctl setting on the container host, not on the container it self.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 29, 2017, 12:15pm UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5-1-facing-issues/95281/8 "2017-08-29T12:15:16Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
