# Unable to install elasticsearch 5.5

**URL:** https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5/94452
**Category:** Elasticsearch
**Created:** [July 25, 2017, 9:36am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5/94452 "2017-07-25T09:36:00Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![vijjun123](https://avatars.discourse-cdn.com/v4/letter/v/cab0a1/32.png) [@vijjun123](https://discuss.elastic.co/u/vijjun123)
#### Post date: [July 25, 2017, 9:36am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5/94452/1 "2017-07-25T09:36:00Z")

</div>

Unable to install elasticsearch 5.5  
While executing ./elasticsearch got the below error  
Could you please guide the further

$ ./elasticsearch  
2017-07-25 09:28:57,277 main ERROR Could not register mbeans java.security.AccessControlException: access denied ("javax.management.MBeanTrustPermission" "register")  
at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472)  
at java.lang.SecurityManager.checkPermission(SecurityManager.java:585)  
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.checkMBeanTrustPermission(DefaultMBeanServerInterceptor.java:1848)  
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(DefaultMBeanServerInterceptor.java:322)  
at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(JmxMBeanServer.java:522)  
at org.apache.logging.log4j.core.jmx.Server.register(Server.java:389)  
at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:167)  
at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:140)  
at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:556)  
at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:261)  
at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:206)  
at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:221)  
at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:197)  
at org.elasticsearch.common.logging.LogConfigurator.configureStatusLogger(LogConfigurator.java:175)  
at org.elasticsearch.common.logging.LogConfigurator.configureWithoutConfig(LogConfigurator.java:99)  
at org.elasticsearch.cli.Command.main(Command.java:85)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84)

Exception in thread "main" SettingsException[Failed to load settings from /opt/elasticsearch-5.5.0/config/elasticsearch.yml]; nested: AccessDeniedException[/opt/elasticsearch-5.5.0/config/elasticsearch.yml];  
at org.elasticsearch.node.InternalSettingsPreparer.prepareEnvironment(InternalSettingsPreparer.java:102)  
at org.elasticsearch.cli.EnvironmentAwareCommand.createEnv(EnvironmentAwareCommand.java:72)  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67)  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122)  
at org.elasticsearch.cli.Command.main(Command.java:88)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84)  
Caused by: java.nio.file.AccessDeniedException: /opt/elasticsearch-5.5.0/config/elasticsearch.yml  
at sun.nio.fs.UnixException.translateToIOException(UnixException.java:84)  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:102)  
at sun.nio.fs.UnixException.rethrowAsIOException(UnixException.java:107)  
at sun.nio.fs.UnixFileSystemProvider.newByteChannel(UnixFileSystemProvider.java:214)  
at java.nio.file.Files.newByteChannel(Files.java:361)  
at java.nio.file.Files.newByteChannel(Files.java:407)  
at java.nio.file.spi.FileSystemProvider.newInputStream(FileSystemProvider.java:384)  
at java.nio.file.Files.newInputStream(Files.java:152)  
at org.elasticsearch.common.settings.Settings$Builder.loadFromPath(Settings.java:1033)  
at org.elasticsearch.node.InternalSettingsPreparer.prepareEnvironment(InternalSettingsPreparer.java:100)  
... 6 more

---

<div class="post-metadata">

### Author: ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)
#### Post date: [July 25, 2017, 9:51am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5/94452/2 "2017-07-25T09:51:09Z")

</div>

How did you install it?  
With which user you are trying to run it?

Sounds like a read permission issue on `/opt/elasticsearch-5.5.0/config/elasticsearch.yml`

---

<div class="post-metadata">

### Author: ![zqc0512](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zqc0512/32/32141_2.png) [@zqc0512](https://discuss.elastic.co/u/zqc0512)
#### Post date: [July 26, 2017, 1:49am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5/94452/3 "2017-07-26T01:49:37Z")

</div>

see the user about elasticsearch.yml file this don't about running user.

---

<div class="post-metadata">

### Author: ![vijjun123](https://avatars.discourse-cdn.com/v4/letter/v/cab0a1/32.png) [@vijjun123](https://discuss.elastic.co/u/vijjun123)
#### Post date: [July 26, 2017, 4:09am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5/94452/4 "2017-07-26T04:09:04Z")

</div>

Thanks for the update but still facing same issue.could you please check  
Please refer the details below.

[ec2-user@config]$ pwd  
/opt/elasticsearch-5.5.0/config  
[ec2-user@config]$ ls -lrt  
total 16  
-rw-rw---- 1 root root 4456 Jun 30 23:14 log4j2.properties  
-rw-rw---- 1 root root 3117 Jun 30 23:14 jvm.options  
-rwxrwxrwx 1 ec2-user ec2-user 2854 Jul 26 04:04 elasticsearch.yml

[ec2-user@bin]$ ./elasticsearch  
2017-07-26 04:05:58,244 main ERROR Could not register mbeans java.security.AccessControlException: access denied ("javax.management.MBeanTrustPermission" "register")  
at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472)  
at java.lang.SecurityManager.checkPermission(SecurityManager.java:585)  
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.checkMBeanTrustPermission(DefaultMBeanServerInterceptor.java:1848)  
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(DefaultMBeanServerInterceptor.java:322)  
at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(JmxMBeanServer.java:522)  
at org.apache.logging.log4j.core.jmx.Server.register(Server.java:389)  
at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:167)  
at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:140)  
at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:556)  
at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:261)  
at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:206)  
at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:221)  
at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:197)  
at org.elasticsearch.common.logging.LogConfigurator.configureStatusLogger(LogConfigurator.java:175)  
at org.elasticsearch.common.logging.LogConfigurator.configureWithoutConfig(LogConfigurator.java:99)  
at org.elasticsearch.cli.Command.main(Command.java:85)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84)

Exception in thread "main" java.lang.IllegalStateException: status logger logged an error before logging was configured  
at org.elasticsearch.common.logging.LogConfigurator.checkErrorListener(LogConfigurator.java:128)  
at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:117)  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:316)  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123)  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114)  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67)  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122)  
at org.elasticsearch.cli.Command.main(Command.java:88)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84)  
Refer to the log for complete error details.

---

<div class="post-metadata">

### Author: ![zqc0512](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zqc0512/32/32141_2.png) [@zqc0512](https://discuss.elastic.co/u/zqc0512)
#### Post date: [July 26, 2017, 4:26am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5/94452/5 "2017-07-26T04:26:47Z")

</div>

your must change the directory to ec2-user  
chown -R ec2-user:ec2-user where the es install directory  
ie:chown -R ec2-user:ec2-user /opt/elasticsearch

---

<div class="post-metadata">

### Author: ![vijjun123](https://avatars.discourse-cdn.com/v4/letter/v/cab0a1/32.png) [@vijjun123](https://discuss.elastic.co/u/vijjun123)
#### Post date: [July 26, 2017, 4:36am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5/94452/6 "2017-07-26T04:36:32Z")

</div>

changed the permission but still same issue

[ec2-user@opt]$ ls -rlt  
total 213884  
drwxr-xr-x 5 root root 4096 Jun 23 23:17 aws  
drwxr-xr-x 8 uucp 143 4096 Jul 12 11:41 jdk1.8.0\_141  
-rw-r--r-- 1 root root 185516505 Jul 13 05:13 jdk-8u141-linux-x64.tar.gz  
-rw-r--r-- 1 ec2-user ec2-user 33480586 Jul 25 07:48 elasticsearch-5.5.0.tar.gz  
drwxr-xr-x 8 ec2-user ec2-user 4096 Jul 25 08:20 elasticsearch-5.5.0

[ec2-user@bin]$ ./elasticsearch  
2017-07-26 04:34:53,614 main ERROR Could not register mbeans java.security.AccessControlException: access denied ("javax.management.MBeanTrustPermission" "register")  
at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472)  
at java.lang.SecurityManager.checkPermission(SecurityManager.java:585)  
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.checkMBeanTrustPermission(DefaultMBeanServerInterceptor.java:1848)  
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.registerMBean(DefaultMBeanServerInterceptor.java:322)  
at com.sun.jmx.mbeanserver.JmxMBeanServer.registerMBean(JmxMBeanServer.java:522)  
at org.apache.logging.log4j.core.jmx.Server.register(Server.java:389)  
at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:167)  
at org.apache.logging.log4j.core.jmx.Server.reregisterMBeansAfterReconfigure(Server.java:140)  
at org.apache.logging.log4j.core.LoggerContext.setConfiguration(LoggerContext.java:556)  
at org.apache.logging.log4j.core.LoggerContext.start(LoggerContext.java:261)  
at org.apache.logging.log4j.core.impl.Log4jContextFactory.getContext(Log4jContextFactory.java:206)  
at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:221)  
at org.apache.logging.log4j.core.config.Configurator.initialize(Configurator.java:197)  
at org.elasticsearch.common.logging.LogConfigurator.configureStatusLogger(LogConfigurator.java:175)  
at org.elasticsearch.common.logging.LogConfigurator.configureWithoutConfig(LogConfigurator.java:99)  
at org.elasticsearch.cli.Command.main(Command.java:85)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84)

Exception in thread "main" java.lang.IllegalStateException: status logger logged an error before logging was configured  
at org.elasticsearch.common.logging.LogConfigurator.checkErrorListener(LogConfigurator.java:128)  
at org.elasticsearch.common.logging.LogConfigurator.configure(LogConfigurator.java:117)  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:316)  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:123)  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:114)  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:67)  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:122)  
at org.elasticsearch.cli.Command.main(Command.java:88)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91)  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84)  
Refer to the log for complete error details.

---

<div class="post-metadata">

### Author: ![zqc0512](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zqc0512/32/32141_2.png) [@zqc0512](https://discuss.elastic.co/u/zqc0512)
#### Post date: [July 26, 2017, 4:47am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5/94452/7 "2017-07-26T04:47:07Z")

</div>

your java directory jdk1.8.0\_141 user and group not ok?  
es-user $ java -version

---

<div class="post-metadata">

### Author: ![vijjun123](https://avatars.discourse-cdn.com/v4/letter/v/cab0a1/32.png) [@vijjun123](https://discuss.elastic.co/u/vijjun123)
#### Post date: [July 26, 2017, 4:47am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5/94452/8 "2017-07-26T04:47:52Z")

</div>

do you want me to change the group as root?

---

<div class="post-metadata">

### Author: ![zqc0512](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/zqc0512/32/32141_2.png) [@zqc0512](https://discuss.elastic.co/u/zqc0512)
#### Post date: [July 26, 2017, 4:50am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5/94452/9 "2017-07-26T04:50:38Z")

</div>

chown -R ec2-user:ec2-user /opt/elasticsearch  
chmod -R 755 /opt/elasticsearch

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [August 23, 2017, 4:50am UTC](https://discuss.elastic.co/t/unable-to-install-elasticsearch-5-5/94452/10 "2017-08-23T04:50:47Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
