# Unable to Install Filebeat . Need some help in fixing installation issue

**URL:** <https://discuss.elastic.co/t/unable-to-install-filebeat-need-some-help-in-fixing-installation-issue/272574>\
**Category:** Beats\
**Tags:** filebeat\
**Created:** [May 10, 2021, 11:42am UTC](https://discuss.elastic.co/t/unable-to-install-filebeat-need-some-help-in-fixing-installation-issue/272574 "2021-05-10T11:42:15Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![vishnu\_rao](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vishnu_rao/32/88518_2.png) [@vishnu\_rao](https://discuss.elastic.co/u/vishnu_rao)\
**Post date:** [May 10, 2021, 11:42am UTC](https://discuss.elastic.co/t/unable-to-install-filebeat-need-some-help-in-fixing-installation-issue/272574/1 "2021-05-10T11:42:15Z")

</div>

I am trying to install filebeat on IBM Clould Kubernetes Service , but the demonset does not start for the filebeat.. seeing below error. Request you to help fixing the issue.

Warning FailedCreate DaemonSet Error creating: pods "filebeat-xx-xx-filebeat-" is forbidden: unable to validate against any pod security policy: [spec.volumes[2]: Invalid value: "hostPath": hostPath volumes are not allowed to be used spec.volumes[3]: Invalid value: "hostPath": hostPath volumes are not allowed to be used spec.volumes[4]: Invalid value: "hostPath": hostPath volumes are not allowed to be used spec.volumes[5]: Invalid value: "hostPath": hostPath volumes are not allowed to be used spec.volumes[6]: Invalid value: "hostPath": hostPath volumes are not allowed to be used]

$oc get all - status is below.

NAME DESIRED CURRENT READY UP-TO-DATE AVAILABLE NODE SELECTOR AGE  
daemonset.apps/filebeat-xx-xx-xxfilebeat 0 0 0 0 0 42m

---

<div class="post-metadata">

**Author:** ![legoguy1000](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/legoguy1000/32/54301_2.png) [@legoguy1000](https://discuss.elastic.co/u/legoguy1000)\
**Post date:** [May 12, 2021, 4:57am UTC](https://discuss.elastic.co/t/unable-to-install-filebeat-need-some-help-in-fixing-installation-issue/272574/2 "2021-05-12T04:57:39Z")

</div>

> [@vishnu\_rao](#):
>
> Invalid value: "hostPath": hostPath volumes are not allowed to be used spec.volumes[3]

U have to replace the `hostpath`s from the resource definitions

---

<div class="post-metadata">

**Author:** ![vishnu\_rao](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/vishnu_rao/32/88518_2.png) [@vishnu\_rao](https://discuss.elastic.co/u/vishnu_rao)\
**Post date:** [May 12, 2021, 6:20am UTC](https://discuss.elastic.co/t/unable-to-install-filebeat-need-some-help-in-fixing-installation-issue/272574/3 "2021-05-12T06:20:50Z")

</div>

can you pls help me with your inputs from where I can get resource definitions pls ?

---

<div class="post-metadata">

**Author:** ![legoguy1000](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/legoguy1000/32/54301_2.png) [@legoguy1000](https://discuss.elastic.co/u/legoguy1000)\
**Post date:** [May 12, 2021, 11:53am UTC](https://discuss.elastic.co/t/unable-to-install-filebeat-need-some-help-in-fixing-installation-issue/272574/4 "2021-05-12T11:53:38Z")

</div>

The resource definitions are the yaml files u used to deploy filebeat to kubernetes

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 9, 2021, 1:53pm UTC](https://discuss.elastic.co/t/unable-to-install-filebeat-need-some-help-in-fixing-installation-issue/272574/5 "2021-06-09T13:53:54Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
