# Unable to install logstash-input-azureblob with logstash 7.16.2

**URL:** <https://discuss.elastic.co/t/unable-to-install-logstash-input-azureblob-with-logstash-7-16-2/293504>\
**Category:** Logstash\
**Tags:** docker\
**Created:** [January 5, 2022, 8:20am UTC](https://discuss.elastic.co/t/unable-to-install-logstash-input-azureblob-with-logstash-7-16-2/293504 "2022-01-05T08:20:29Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Natarajan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/natarajan/32/46943_2.png) [@Natarajan](https://discuss.elastic.co/u/Natarajan)\
**Post date:** [January 5, 2022, 8:20am UTC](https://discuss.elastic.co/t/unable-to-install-logstash-input-azureblob-with-logstash-7-16-2/293504/1 "2022-01-05T08:20:29Z")

</div>

I am trying to install logstash-input-azureblob with logstash 7.16.2. But getting the below error. I am running the logstash as docker.

ERROR: Installation Aborted, message: Bundler could not find compatible versions for gem "faraday":  
In snapshot (Gemfile.lock):  
faraday (= 1.8.0)

In Gemfile:  
logstash-input-azureblob was resolved to 0.9.7, which depends on  
azure (~\> 0.7.1) was resolved to 0.7.10, which depends on  
faraday (~\> 0.9)

```
logstash-core was resolved to 7.16.2, which depends on
  elasticsearch (~> 7) was resolved to 7.15.0, which depends on
    elasticsearch-transport (= 7.15.0) was resolved to 7.15.0, which depends on
      faraday (~> 1)
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 2, 2022, 8:20am UTC](https://discuss.elastic.co/t/unable-to-install-logstash-input-azureblob-with-logstash-7-16-2/293504/2 "2022-02-02T08:20:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
