# Unable to install logstash plugin offline

**URL:** <https://discuss.elastic.co/t/unable-to-install-logstash-plugin-offline/75676>\
**Category:** Logstash\
**Created:** [February 20, 2017, 6:44am UTC](https://discuss.elastic.co/t/unable-to-install-logstash-plugin-offline/75676 "2017-02-20T06:44:51Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![TinTin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tintin/32/15679_2.png) [@TinTin](https://discuss.elastic.co/u/TinTin)\
**Post date:** [February 20, 2017, 6:44am UTC](https://discuss.elastic.co/t/unable-to-install-logstash-plugin-offline/75676/1 "2017-02-20T06:44:51Z")

</div>

Hi,  
I have built a logstash-output-custom plugin, which I can install offline in my local logstash setup.

But, if I try to install the same when trying to create a docker image, it fails with the following error:

t-m01:log-collector t$ docker build --no-cache -t logstash-image .  
Sending build context to Docker daemon 37.89 kB  
Step 1/2 : FROM logstash:2.4  
---\> a6faa574daef

Step 2/2 : RUN /opt/logstash/bin/logstash-plugin install --no-verify logstash-output-custom-0.1.12.gem --local  
---\> Running in a0a5337c6b72  
ERROR: Mixed source of plugins, you can't mix local `.gem` and remote gems  
See: 'bin/logstash-plugin install --help'  
The command '/bin/sh -c /opt/logstash/bin/logstash-plugin install --local logstash-output-custom-0.1.12.gem --no-verify' returned a non-zero code: 1

Any ideas ?

---

<div class="post-metadata">

**Author:** ![TinTin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/tintin/32/15679_2.png) [@TinTin](https://discuss.elastic.co/u/TinTin)\
**Post date:** [February 21, 2017, 7:08pm UTC](https://discuss.elastic.co/t/unable-to-install-logstash-plugin-offline/75676/2 "2017-02-21T19:08:41Z")

</div>

I figured out the issue.  
The gem was not visible to the docker container.  
I had to first copy it and than use it in the Dockerfile.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 21, 2017, 7:09pm UTC](https://discuss.elastic.co/t/unable-to-install-logstash-plugin-offline/75676/3 "2017-03-21T19:09:02Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
