# Unable to join to my new cluster

**URL:** <https://discuss.elastic.co/t/unable-to-join-to-my-new-cluster/240321>\
**Category:** Elasticsearch\
**Created:** [July 8, 2020, 10:23am UTC](https://discuss.elastic.co/t/unable-to-join-to-my-new-cluster/240321 "2020-07-08T10:23:14Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![hgpit](https://avatars.discourse-cdn.com/v4/letter/h/f1d935/32.png) [@hgpit](https://discuss.elastic.co/u/hgpit)\
**Post date:** [July 8, 2020, 10:23am UTC](https://discuss.elastic.co/t/unable-to-join-to-my-new-cluster/240321/1 "2020-07-08T10:23:14Z")

</div>

Hello,

We are very inexperienced with ES, so we imagine we are just overlooking something simple.

We have built two machines, running ES (OSS) 7.8.

1. Hostname: [g000057.domain.com](http://g000057.domain.com), IP: 10.40.1.62, Node name: g000057
2. Hostname: [g000059.domain.com](http://g000059.domain.com), IP: 10.40.1.192, Node name: g000059

g000057 works fine standalone, we have data coming in from logstash and filebeat and can view/search the data in Kibana.

We want to add server 2 for high availability and generally experimenting with.

The problem is that we see this is server 1's log:

```auto
[g000057] failed to validate incoming join request from node [{g000059}{p5NnwKJ7TRykGI2wHEUgoA}{rfQBBSF1Sj-48n4idaoIPA}{10.40.1.192}{10.40.1.192:9300}{dimr}]

```

And this is server 2's log:

```auto
[2020-07-08T10:51:27,730][INFO][o.e.c.c.JoinHelper] [g000059] failed to join {g000057}{1KWcemjuQQW9u3Im7Ha7qQ}{bExQ55uESI65Bif8b_qlnA}{10.40.1.62}{1org.elasticsearch.transport.RemoteTransportException: [g000057][10.40.1.62:9300][internal:cluster/coordination/join]
Caused by: java.lang.IllegalStateException: failure when sending a validation request to node

```

Server 1's config:

```auto
cluster.name: "es-cluster"
node.name: "g000057"
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
network.host: 10.40.1.62
http.port: 9200
discovery.seed_hosts: 
        - 10.40.1.62
        - g000059.domain.com
cluster.initial_master_nodes: 
        - g000057

```

Server 2's config:

```auto
cluster.name: "es-cluster"
node.name: "g000059"
path.data: /var/lib/elasticsearch
path.logs: /var/log/elasticsearch
network.host: 10.40.1.192
http.port: 9200
discovery.seed_hosts:
    - g000057.domain.com
    - 10.40.1.192
cluster.initial_master_nodes: ["g000057"]

```

Can someone advise what's wrong with the configuration please?

Thank you!

---

<div class="post-metadata">

**Author:** ![pdeelman](https://avatars.discourse-cdn.com/v4/letter/p/b5a626/32.png) [@pdeelman](https://discuss.elastic.co/u/pdeelman)\
**Post date:** [July 30, 2020, 1:03pm UTC](https://discuss.elastic.co/t/unable-to-join-to-my-new-cluster/240321/2 "2020-07-30T13:03:39Z")

</div>

Do you have IPv6 enabled but not configured? Try turning it off, that worked for me last time (ES 7.6). Don't know if it's a current issue anymore.

edit: to be more precise. My cloudprovider runs their networks by default using IPv4, which is fine for most usecases anyway. But this means their virtual networks don't support IPv6 unless specifically configured. However every linux distro has IPv6 enabled by default. So for some reason elasticsearch wanted to use IPv6, even if I specified network.host: 0.0.0.0

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 27, 2020, 1:03pm UTC](https://discuss.elastic.co/t/unable-to-join-to-my-new-cluster/240321/3 "2020-08-27T13:03:44Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
