# Unable to load csv file through logstash

**URL:** <https://discuss.elastic.co/t/unable-to-load-csv-file-through-logstash/146853>\
**Category:** Logstash\
**Created:** [August 31, 2018, 11:10am UTC](https://discuss.elastic.co/t/unable-to-load-csv-file-through-logstash/146853 "2018-08-31T11:10:03Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Prabhakaran\_D](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/prabhakaran_d/32/35020_2.png) [@Prabhakaran\_D](https://discuss.elastic.co/u/Prabhakaran_D)\
**Post date:** [August 31, 2018, 11:10am UTC](https://discuss.elastic.co/t/unable-to-load-csv-file-through-logstash/146853/1 "2018-08-31T11:10:03Z")

</div>

I am trying to load an csv file through logstash.

Please find the config file below

```
input {
    file {
        path => "D:\summer.csv"
        start_position => "beginning"
        sincedb_path => "nul"
    }
}
filter {
    csv {
        separator => ","
        columns => ["Name","Sex","Games","Year","City"]
    }
}
output {
    elasticsearch {
        hosts => "localhost"
        index => "summer"
    }
    stdout { }
}

```

i saved the above code in logstash\_olym.conf under bin folder  
When i run logstash using logstash -f logstash\_olym.conf

i get below message (No errors), but it doesn't accept any keys and i dont have any option other that terminating it using Ctrl+C

D:\Prabhakaran\AINADEL\Softwares\logstash-6.4.0\logstash-6.4.0\bin\>logstash -f logstash\_olym.conf  
Sending Logstash logs to D:/Prabhakaran/AINADEL/Softwares/logstash-6.4.0/logstash-6.4.0/logs which is now configured via log4j2.properties  
[2018-08-31T16:34:06,182][WARN][logstash.config.source.multilocal] Ignoring the 'pipelines.yml' file because modules or command line options are specified  
[2018-08-31T16:34:07,395][INFO][logstash.runner] Starting Logstash {"logstash.version"=\>"6.4.0"}  
[2018-08-31T16:34:14,610][INFO][logstash.pipeline] Starting pipeline {:pipeline\_id=\>"main", "pipeline.workers"=\>2, "pipeline.batch.size"=\>125, "pipeline.batch.delay"=\>50}  
[2018-08-31T16:34:15,581][INFO][logstash.outputs.elasticsearch] Elasticsearch pool URLs updated {:changes=\>{:removed=\>[], :added=\>[[http://localhost:9200/](http://localhost:9200/)]}}  
[2018-08-31T16:34:15,613][INFO][logstash.outputs.elasticsearch] Running health check to see if an Elasticsearch connection is working {:healthcheck\_url=\>[http://localhost:9200/](http://localhost:9200/), :path=\>"/"}  
[2018-08-31T16:34:16,122][WARN][logstash.outputs.elasticsearch] Restored connection to ES instance {:url=\>"[http://localhost:9200/](http://localhost:9200/)"}  
[2018-08-31T16:34:16,248][INFO][logstash.outputs.elasticsearch] ES Output version determined {:es\_version=\>6}  
[2018-08-31T16:34:16,260][WARN][logstash.outputs.elasticsearch] Detected a 6.x and above cluster: the `type` event field won't be used to determine the document \_type {:es\_version=\>6}  
[2018-08-31T16:34:16,319][INFO][logstash.outputs.elasticsearch] New Elasticsearch output {:class=\>"LogStash::Outputs::ElasticSearch", :hosts=\>["[//localhost](https://localhost)"]}  
[2018-08-31T16:34:16,354][INFO][logstash.outputs.elasticsearch] Using mapping template from {:path=\>nil}  
[2018-08-31T16:34:16,458][INFO][logstash.outputs.elasticsearch] Attempting to install template {:manage\_template=\>{"template"=\>"logstash-_", "version"=\>60001, "settings"=\>{"index.refresh\_interval"=\>"5s"}, "mappings"=\>{"default"=\>{"dynamic\_templates"=\>[{"message\_field"=\>{"path\_match"=\>"message", "match\_mapping\_type"=\>"string", "mapping"=\>{"type"=\>"text", "norms"=\>false}}}, {"string\_fields"=\>{"match"=\>"_", "match\_mapping\_type"=\>"string", "mapping"=\>{"type"=\>"text", "norms"=\>false, "fields"=\>{"keyword"=\>{"type"=\>"keyword", "ignore\_above"=\>256}}}}}], "properties"=\>{"@timestamp"=\>{"type"=\>"date"}, "@version"=\>{"type"=\>"keyword"}, "geoip"=\>{"dynamic"=\>true, "properties"=\>{"ip"=\>{"type"=\>"ip"}, "location"=\>{"type"=\>"geo\_point"}, "latitude"=\>{"type"=\>"half\_float"}, "longitude"=\>{"type"=\>"half\_float"}}}}}}}}  
[2018-08-31T16:34:17,575][INFO][logstash.pipeline] Pipeline started successfully {:pipeline\_id=\>"main", :thread=\>"#\<Thread:0x1a9a2368 run\>"}  
[2018-08-31T16:34:17,828][INFO][logstash.agent] Pipelines running {:count=\>1, :running\_pipelines=\>[:main], :non\_running\_pipelines=\>[]}  
[2018-08-31T16:34:17,854][INFO][filewatch.observingtail] START, creating Discoverer, Watch with file and sincedb collections  
[2018-08-31T16:34:18,696][INFO][logstash.agent] Successfully started Logstash API endpoint {:port=\>9600}

After running this when i check in [http://localhost:9200/\_cat/indices?v](http://localhost:9200/_cat/indices?v)

it gives me below result

health status index uuid pri rep docs.count docs.deleted store.size pri.store.size  
green open kibana\_sample\_data\_flights 8ALyDNdcTEmGWH4S8GlrPg 1 0 13059 0 6.6mb 6.6mb  
green open .kibana 435xwaPbS4W0LPv4FVP1dw 1 0 22 0 48.1kb 48.1kb

which has only 2 index that doesn't have the index "summer" which i mentioned in the conf file. I am a newbie to ELK stack. Please guide me to process further.

---

<div class="post-metadata">

**Author:** ![sandeepursks](https://avatars.discourse-cdn.com/v4/letter/s/c2a13f/32.png) [@sandeepursks](https://discuss.elastic.co/u/sandeepursks)\
**Post date:** [September 1, 2018, 5:01pm UTC](https://discuss.elastic.co/t/unable-to-load-csv-file-through-logstash/146853/2 "2018-09-01T17:01:44Z")

</div>

Hi,  
Even i am unable to load csv file...  
as observed from logsttach log file i received 2 error as below  
1.Explicit value for 'scheme' was declared logstash  
2.no implicit conversion from nil to integer logstash  
am using logstash 6.4

---

<div class="post-metadata">

**Author:** ![Prabhakaran\_D](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/prabhakaran_d/32/35020_2.png) [@Prabhakaran\_D](https://discuss.elastic.co/u/Prabhakaran_D)\
**Post date:** [September 3, 2018, 2:15pm UTC](https://discuss.elastic.co/t/unable-to-load-csv-file-through-logstash/146853/5 "2018-09-03T14:15:15Z")

</div>

Thanks @sandeepursks

As i checked the logs using --debug command. I found below errors.  
1 --\>  
[2018-09-03T19:33:44,527][DEBUG][io.netty.util.internal.NativeLibraryLoader] Unable to load the library 'netty\_tcnative\_windows\_x86\_64', trying other loading mechanism.

java.lang.UnsatisfiedLinkError: no netty\_tcnative\_windows\_x86\_64 in java.library.path

2 --\>  
[2018-09-03T19:33:44,560][DEBUG][io.netty.util.internal.NativeLibraryLoader] netty\_tcnative\_windows\_x86\_64 cannot be loaded from java.libary.path, now trying export to -Dio.netty.native.workdir: C:\Users\prabhakaran.d\AppData\Local\Temp

java.lang.UnsatisfiedLinkError: no netty\_tcnative\_windows\_x86\_64 in java.library.path  
.  
.  
.  
.  
Suppressed: java.lang.UnsatisfiedLinkError: no netty\_tcnative\_windows\_x86\_64 in java.library.path

Please guide me.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 1, 2018, 2:24pm UTC](https://discuss.elastic.co/t/unable-to-load-csv-file-through-logstash/146853/6 "2018-10-01T14:24:00Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
