# Unable to load Elastic-APM ServiceMap

**URL:** <https://discuss.elastic.co/t/unable-to-load-elastic-apm-servicemap/246380>\
**Category:** APM\
**Tags:** java, ui\
**Created:** [August 26, 2020, 3:54am UTC](https://discuss.elastic.co/t/unable-to-load-elastic-apm-servicemap/246380 "2020-08-26T03:54:57Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![vishakh](https://avatars.discourse-cdn.com/v4/letter/v/c89c15/32.png) [@vishakh](https://discuss.elastic.co/u/vishakh)\
**Post date:** [August 26, 2020, 3:54am UTC](https://discuss.elastic.co/t/unable-to-load-elastic-apm-servicemap/246380/1 "2020-08-26T03:54:57Z")

</div>

**Kibana version** : 7.8.0

**Elasticsearch version** : 7.8.0

**APM Server version** : 7.8.0

**APM Agent language and version** : Java  
**OS Platform** : Amazon Linux  
**Tomcat Version** :  
Server version: Apache Tomcat/8.5.57  
Server built: Jul 16 2020 22:38:29 UTC  
Server number: 8.5.57.0  
OS Name: Linux  
OS Version: 4.14.114-83.126.amzn1.x86\_64  
Architecture: amd64  
JVM Version: 1.8.0\_252-b09  
JVM Vendor: Oracle Corporation

Unable to load APM Service-Map and getting the below HTTP-500 error as below

 ![Screen_Shot_2020-08-25_at_11_50_17_PM](https://us1.discourse-cdn.com/elastic/original/3X/1/e/1ef59d413791bae876da0e68341312232ba1d48d.png)

---

<div class="post-metadata">

**Author:** ![axw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/axw/32/28197_2.png) [@axw](https://discuss.elastic.co/u/axw)\
**Post date:** [August 26, 2020, 5:41am UTC](https://discuss.elastic.co/t/unable-to-load-elastic-apm-servicemap/246380/2 "2020-08-26T05:41:25Z")

</div>

Hi @vishakh. This is a known issue with service maps in 7.8.0 ([https://github.com/elastic/kibana/issues/69987](https://github.com/elastic/kibana/issues/69987)). Please upgrade to 7.8.1 or newer.

---

<div class="post-metadata">

**Author:** ![stephenb](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/stephenb/32/40856_2.png) [@stephenb](https://discuss.elastic.co/u/stephenb)\
**Post date:** [August 26, 2020, 5:41am UTC](https://discuss.elastic.co/t/unable-to-load-elastic-apm-servicemap/246380/3 "2020-08-26T05:41:49Z")

</div>

I believe this was an issue that was fixed in 7.8.1. I believe the work around was to enable anomaly detection on one of the services.

Best way forward is to upgrade to 7.8.1

> <https://github.com/elastic/kibana/issues/69987>
>
> cluster:monitor/xpack/ml/job/get is needed to load service maps:
> server log \[17:35:02.583\] \[error\]\[http\] { Error: \[security\_exception\] action \[cluster:monitor/xpack/ml/job/get\] is unauthorized for user \[apm\_read\_user\]
> at...

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 16, 2020, 1:42am UTC](https://discuss.elastic.co/t/unable-to-load-elastic-apm-servicemap/246380/4 "2020-09-16T01:42:09Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
