# Unable to Load Kibana objects (Failed to parse)

**URL:** <https://discuss.elastic.co/t/unable-to-load-kibana-objects-failed-to-parse/161520>\
**Category:** APM\
**Created:** [December 19, 2018, 1:09pm UTC](https://discuss.elastic.co/t/unable-to-load-kibana-objects-failed-to-parse/161520 "2018-12-19T13:09:32Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![jcalonso](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jcalonso/32/18912_2.png) [@jcalonso](https://discuss.elastic.co/u/jcalonso)\
**Post date:** [December 19, 2018, 1:09pm UTC](https://discuss.elastic.co/t/unable-to-load-kibana-objects-failed-to-parse/161520/1 "2018-12-19T13:09:32Z")

</div>

Hello, I'm trying to setup APN from Kibana. I have the APN server communicating with Elastic and My app sending metrics. In the last step "Load Kibana Objects" I get the following error:

```auto
Unable to add 1 of 16 kibana objects, Error: failed to parse

```

 ![2018-12-19_13-02](https://us1.discourse-cdn.com/elastic/original/3X/b/0/b0cf74fffc83c22a35e0524a270e34f7280ed38b.png)

If I go into the APM server and run `apm-server setup`, I get:

```auto
Loaded index template
Loading dashboards (Kibana must be running and reachable)
Exiting: Failed to import index-pattern: Failed to load directory /usr/share/apm-server/kibana/6/index-pattern:
  error loading /usr/share/apm-server/kibana/6/index-pattern/apmserver.json: failed to parse. Response: {"objects":[{"id":"apm-*","type":"index-pattern","error":{"message":"failed to parse"}}]}

```

I also noticed this happens when running `apm-server setup --dashboard` but not with `apm-server setup --template`

```auto
 apm-server setup --template
Loaded index template

 apm-server setup --dashboards
Loading dashboards (Kibana must be running and reachable)
Exiting: Failed to import index-pattern: Failed to load directory /usr/share/apm-server/kibana/6/index-pattern:
  error loading /usr/share/apm-server/kibana/6/index-pattern/apmserver.json: failed to parse. Response: {"objects":[{"id":"apm-*","type":"index-pattern","error":{"message":"failed to parse"}}]}

```

Why its loading the index-pattern when I specify the dashboard?

Thanks!

Edit:  
I'm using Elastic stack 6.5.3

---

<div class="post-metadata">

**Author:** ![simitt](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/simitt/32/106406_2.png) [@simitt](https://discuss.elastic.co/u/simitt)\
**Post date:** [December 19, 2018, 2:14pm UTC](https://discuss.elastic.co/t/unable-to-load-kibana-objects-failed-to-parse/161520/2 "2018-12-19T14:14:40Z")

</div>

Hi Juan,

have you updated from a previous version or did you do a fresh install for 6.5.3 and how did you install it?

Have you changed anything related to the dashboards or the Kibana index pattern, or are you using default values? I cannot reproduce the issue with default settings.

The dashboards depend on the kibana index pattern, that is why it is imported when you run `apm-server setup --dashboards`.

---

<div class="post-metadata">

**Author:** ![jcalonso](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jcalonso/32/18912_2.png) [@jcalonso](https://discuss.elastic.co/u/jcalonso)\
**Post date:** [December 19, 2018, 2:49pm UTC](https://discuss.elastic.co/t/unable-to-load-kibana-objects-failed-to-parse/161520/3 "2018-12-19T14:49:16Z")

</div>

Hi Silvia,  
Yeah I been upgrading ES and Kibana since version 6.0 (via ppa). Apm was a new install a few hours ago.

Happy to help debugging it.

Thanks

---

<div class="post-metadata">

**Author:** ![jcalonso](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/jcalonso/32/18912_2.png) [@jcalonso](https://discuss.elastic.co/u/jcalonso)\
**Post date:** [December 19, 2018, 5:10pm UTC](https://discuss.elastic.co/t/unable-to-load-kibana-objects-failed-to-parse/161520/4 "2018-12-19T17:10:17Z")

</div>

This issue was unrelated to APN Server, my ES instance was having issues.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 9, 2019, 1:10pm UTC](https://discuss.elastic.co/t/unable-to-load-kibana-objects-failed-to-parse/161520/5 "2019-01-09T13:10:21Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
