# Unable to load the kibana logs due to error in Script field

**URL:** <https://discuss.elastic.co/t/unable-to-load-the-kibana-logs-due-to-error-in-script-field/204649>\
**Category:** Kibana\
**Created:** [October 22, 2019, 12:55pm UTC](https://discuss.elastic.co/t/unable-to-load-the-kibana-logs-due-to-error-in-script-field/204649 "2019-10-22T12:55:48Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Rajukumbala](https://avatars.discourse-cdn.com/v4/letter/r/858c86/32.png) [@Rajukumbala](https://discuss.elastic.co/u/Rajukumbala)\
**Post date:** [October 22, 2019, 12:55pm UTC](https://discuss.elastic.co/t/unable-to-load-the-kibana-logs-due-to-error-in-script-field/204649/1 "2019-10-22T12:55:48Z")

</div>

We are using kibana 5.5 version. We are getting the following exception from 1st October, 2019 to till date while loading the kibana.

Shard Failures  
The following shard failures ocurred:

_Index: default-2019.10 Shard: 0 Reason: {"type":"script\_exception","reason":"link error","script\_stack":["doc['ClmAmount'].value","^---- HERE"],"script":"doc['TransSuccess'].value \* doc['ClmAmount'].value","lang":"expression","caused\_by":{"type":"illegal\_argument\_exception","reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [ClmAmount] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."}}_

**We did not edit any existing scripts. We also did not add any new scripts. With the same script fileds it is working fine till 30th September 2019. So, do we have an option to see whether Kibana can work without removing the above script field(s)?**

---

<div class="post-metadata">

**Author:** ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)\
**Post date:** [October 22, 2019, 1:38pm UTC](https://discuss.elastic.co/t/unable-to-load-the-kibana-logs-due-to-error-in-script-field/204649/2 "2019-10-22T13:38:15Z")

</div>

Hello,

Can you please look at your kibana logs to see if anything changed?

Here are our docs on field data: [https://www.elastic.co/guide/en/elasticsearch/reference/current/fielddata.html](https://www.elastic.co/guide/en/elasticsearch/reference/current/fielddata.html)

Its possible that your data mapping is changed?

Thanks,  
Bhavya

---

<div class="post-metadata">

**Author:** ![Rajukumbala](https://avatars.discourse-cdn.com/v4/letter/r/858c86/32.png) [@Rajukumbala](https://discuss.elastic.co/u/Rajukumbala)\
**Post date:** [October 24, 2019, 11:51am UTC](https://discuss.elastic.co/t/unable-to-load-the-kibana-logs-due-to-error-in-script-field/204649/3 "2019-10-24T11:51:42Z")

</div>

Logs side nothing has been changed. Its giving the the following error.

Index: default-2019.10 Shard: 0 Reason: {"type":"script\_exception","reason":"link error","script\_stack":["doc['ClmAmount'].value","^---- HERE"],"script":"doc['TransSuccess'].value \* doc['ClmAmount'].value","lang":"expression","caused\_by":{"type":"illegal\_argument\_exception","reason":"Fielddata is disabled on text fields by default. Set fielddata=true on [ClmAmount] in order to load fielddata in memory by uninverting the inverted index. Note that this can however use significant memory. Alternatively use a keyword field instead."}}

But we are able to get the logs till September 30, 2019

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 21, 2019, 11:51am UTC](https://discuss.elastic.co/t/unable-to-load-the-kibana-logs-due-to-error-in-script-field/204649/4 "2019-11-21T11:51:51Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
