# Unable to load Winlogbeat Dashboards

**URL:** <https://discuss.elastic.co/t/unable-to-load-winlogbeat-dashboards/113617>\
**Category:** Beats\
**Tags:** winlogbeat\
**Created:** [December 29, 2017, 9:49pm UTC](https://discuss.elastic.co/t/unable-to-load-winlogbeat-dashboards/113617 "2017-12-29T21:49:25Z")\
**Posts on this page:** 9\
**Page:** 1

<div class="post-metadata">

**Author:** ![Chris\_Bosman](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chris_bosman/32/26103_2.png) [@Chris\_Bosman](https://discuss.elastic.co/u/Chris_Bosman)\
**Post date:** [December 29, 2017, 9:49pm UTC](https://discuss.elastic.co/t/unable-to-load-winlogbeat-dashboards/113617/1 "2017-12-29T21:49:26Z")

</div>

I am setting up the ELK stack in a test environment. My ELK server is running CentOS 7. I am running version 6.1.1 of all ELK stack components. I am using nginx as a reverse proxy to server the page to my test environment. I am using a Windows 10 machine as the test machine for WinLogBeat. When I attempt to setup the Kibana dashboards, I receive the following error message in Powershell:

"Exiting: Error importing Kibana dashboards: fail to create the Kibana loader: Error creating Kibana client: fail to get the Kibana version:HTTP GET request to /api/status fails: fail to execute the HTTP GET request: Get http://[FQDN]:5601/api/status: dial tcp 172.19.10.51:5601: connectex: No connection could be made because the target machine actively refused it.. Response: ."

I can provide any/all logs upon request. Thank you.

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [January 2, 2018, 3:29pm UTC](https://discuss.elastic.co/t/unable-to-load-winlogbeat-dashboards/113617/2 "2018-01-02T15:29:51Z")

</div>

Did you expose the Kibana endpoints through nginx?

---

<div class="post-metadata">

**Author:** ![Chris\_Bosman](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chris_bosman/32/26103_2.png) [@Chris\_Bosman](https://discuss.elastic.co/u/Chris_Bosman)\
**Post date:** [January 2, 2018, 3:32pm UTC](https://discuss.elastic.co/t/unable-to-load-winlogbeat-dashboards/113617/3 "2018-01-02T15:32:59Z")

</div>

Yes. I can reach the actual Kibana site through the FQDN I assigned, and I can receive a response from the page at :5601, but the response is "Connection Refused".

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [January 2, 2018, 3:50pm UTC](https://discuss.elastic.co/t/unable-to-load-winlogbeat-dashboards/113617/4 "2018-01-02T15:50:28Z")

</div>

Is it a connection refused response from nginx or from the upstream service (Kibana)?

---

<div class="post-metadata">

**Author:** ![Chris\_Bosman](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chris_bosman/32/26103_2.png) [@Chris\_Bosman](https://discuss.elastic.co/u/Chris_Bosman)\
**Post date:** [January 2, 2018, 4:13pm UTC](https://discuss.elastic.co/t/unable-to-load-winlogbeat-dashboards/113617/5 "2018-01-02T16:13:24Z")

</div>

Nginx error logs seem to indicate it's from the upstream Kibana service. Here is the error in full:

"[error] 45651#0: \*77 connect() failed (111: Connection refused) while connecting to upstream, client: [IP ADDRESS], server: [FQDN], request: "GET /plugins/timelion/icon.svg HTTP/1.1", upstream: "http://[::1]:5601/plugins/timelion/icon.svg", host: "[FQDN]", referrer: "http://[FQDN]/app/kibana"

Note that the "/plugins/timelion/icon.svg" is not the only element called in these errors. There are identical errors in the log except the element is different each time. For example, "http://[::1]:5601/kibana/bundlescommons.style.css?v=16350", and "http://[::1]:5601/bundles/kibana.style.css?v=16350". I'm assuming these are the dashboard elements.

It seems to be a permissions error (?), but even when I explicitly pass the Kibana credentials I created using setup.kibana.username and setup.kibana.password, I get the same response.

---

<div class="post-metadata">

**Author:** ![Chris\_Bosman](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chris_bosman/32/26103_2.png) [@Chris\_Bosman](https://discuss.elastic.co/u/Chris_Bosman)\
**Post date:** [January 3, 2018, 2:54pm UTC](https://discuss.elastic.co/t/unable-to-load-winlogbeat-dashboards/113617/6 "2018-01-03T14:54:07Z")

</div>

Any additional ideas, Andrew? Any further information I can provide to help with this? Thanks.

---

<div class="post-metadata">

**Author:** ![andrewkroh](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/andrewkroh/32/3784_2.png) [@andrewkroh](https://discuss.elastic.co/u/andrewkroh)\
**Post date:** [January 3, 2018, 3:29pm UTC](https://discuss.elastic.co/t/unable-to-load-winlogbeat-dashboards/113617/7 "2018-01-03T15:29:19Z")

</div>

By default Kibana listens on localhost:5601 only. If your proxy is not running on the same host as Kibana then you will need to set the `server.host` to make Kibana listen on an appropriate interface (e.g. `server.host: 0.0.0.0`).

---

<div class="post-metadata">

**Author:** ![Chris\_Bosman](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/chris_bosman/32/26103_2.png) [@Chris\_Bosman](https://discuss.elastic.co/u/Chris_Bosman)\
**Post date:** [January 3, 2018, 5:12pm UTC](https://discuss.elastic.co/t/unable-to-load-winlogbeat-dashboards/113617/8 "2018-01-03T17:12:23Z")

</div>

Got it working, thanks. Nginx was running on the same host as Kibana, but was only proxying port 80, not port 5601. By changing server.host from "localhost" to my FQDN, it allowed me to properly load the dashboards. Thank you.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 31, 2018, 5:12pm UTC](https://discuss.elastic.co/t/unable-to-load-winlogbeat-dashboards/113617/9 "2018-01-31T17:12:28Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
