# Unable to parse Date

**URL:** <https://discuss.elastic.co/t/unable-to-parse-date/41604>\
**Category:** Elasticsearch\
**Created:** [February 12, 2016, 11:04am UTC](https://discuss.elastic.co/t/unable-to-parse-date/41604 "2016-02-12T11:04:36Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Nouha](https://avatars.discourse-cdn.com/v4/letter/n/f4b2a3/32.png) [@Nouha](https://discuss.elastic.co/u/Nouha)\
**Post date:** [February 12, 2016, 11:04am UTC](https://discuss.elastic.co/t/unable-to-parse-date/41604/1 "2016-02-12T11:04:36Z")

</div>

Hello Folks !

I have encoutered an exception when indexing data field : "org.elasticsearch.index.mapper.MapperParsingException: failed to parse date field [], tried both date format [dd/MM/yyyy], and timestamp number with locale []"

I tried to add "null" instead of "" but it doesn't resolve the problem ! The issue is that data input for field date can be written in different ways, so It's impossible to add "format" : "MM-dd-YYYY" to the mapping.

I check if there is an old template that exists when indexing but nothing found 😕

PS : I set up a cluster of 3 nodes

Any idea?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:16pm UTC](https://discuss.elastic.co/t/unable-to-parse-date/41604/2 "2017-07-05T23:16:54Z")

</div>


