# Unable to pull Image from fleet-server docker

**URL:** <https://discuss.elastic.co/t/unable-to-pull-image-from-fleet-server-docker/335634>\
**Category:** Kibana\
**Tags:** docker, fleet\
**Created:** [June 9, 2023, 12:45pm UTC](https://discuss.elastic.co/t/unable-to-pull-image-from-fleet-server-docker/335634 "2023-06-09T12:45:39Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![bhavya2810](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavya2810/32/122037_2.png) [@bhavya2810](https://discuss.elastic.co/u/bhavya2810)\
**Post date:** [June 9, 2023, 12:45pm UTC](https://discuss.elastic.co/t/unable-to-pull-image-from-fleet-server-docker/335634/1 "2023-06-09T12:45:39Z")

</div>

I ran this command for setup of fleet server.

```auto
docker run -it --rm \
  -e ELASTICSEARCH_HOSTS="https://elasticsearch:9200" \
  -e ELASTICSEARCH_SERVICE_TOKEN="someservicetoken" \
  -e ELASTICSEARCH_CA_TRUSTED_FINGERPRINT="somefingerprint" \
  docker.elastic.co/fleet-server/fleet-server:8.8.0

```

But I am getting this error

```auto
Unable to find image 'docker.elastic.co/fleet-server/fleet-server:8.8.0' locally
docker: Error response from daemon: pull access denied for docker.elastic.co/fleet-server/fleet-server, repository does not exist or may require 'docker login': denied: requested access to the resource is denied.
See 'docker run --help'.

```

Is this restricted or not available ?

---

<div class="post-metadata">

**Author:** ![eMitch](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/emitch/32/93607_2.png) [@eMitch](https://discuss.elastic.co/u/eMitch)\
**Post date:** [June 12, 2023, 1:10pm UTC](https://discuss.elastic.co/t/unable-to-pull-image-from-fleet-server-docker/335634/2 "2023-06-12T13:10:47Z")

</div>

Hi @bhavya2810 - Fleet Server is run as an Agent.

Take a look at these [Fleet Server on-prem docs](https://www.elastic.co/guide/en/fleet/current/add-fleet-server-on-prem.html) as well as the [Agent as a container docs.](https://www.elastic.co/guide/en/fleet/master/elastic-agent-container.html#elastic-agent-container)

---

<div class="post-metadata">

**Author:** ![MichelLaterman](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/michellaterman/32/110221_2.png) [@MichelLaterman](https://discuss.elastic.co/u/MichelLaterman)\
**Post date:** [June 12, 2023, 3:56pm UTC](https://discuss.elastic.co/t/unable-to-pull-image-from-fleet-server-docker/335634/3 "2023-06-12T15:56:03Z")

</div>

@eMitch is correct.  
Currently we only officially support running fleet-server as part of the elastic-agent image.

I think you're getting the docker image from you original post from [our repo](https://github.com/elastic/fleet-server/blob/main/Makefile#L43) where we are trying to develop a stand-alone image.  
This stand-alone image is not supported for customer deployments.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 10, 2023, 3:56pm UTC](https://discuss.elastic.co/t/unable-to-pull-image-from-fleet-server-docker/335634/4 "2023-07-10T15:56:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
