# Unable to recover after upgrading from 0.16.0 to 0.16.1

**URL:** <https://discuss.elastic.co/t/unable-to-recover-after-upgrading-from-0-16-0-to-0-16-1/4478>\
**Category:** Elasticsearch\
**Created:** [May 26, 2011, 4:17am UTC](https://discuss.elastic.co/t/unable-to-recover-after-upgrading-from-0-16-0-to-0-16-1/4478 "2011-05-26T04:17:25Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![ppearcy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ppearcy/32/980_2.png) [@ppearcy](https://discuss.elastic.co/u/ppearcy)\
**Post date:** [May 26, 2011, 4:17am UTC](https://discuss.elastic.co/t/unable-to-recover-after-upgrading-from-0-16-0-to-0-16-1/4478/1 "2011-05-26T04:17:25Z")

</div>

FYI, I've tried three different instances and they all fail to  
initialize shards after upgrading from 0.16.0 to 0.16.1.

Re-indexing isn't a huge deal, but the upgrade notes did mention there  
should not be any upgrade steps necessary. I had pinged the ES chat  
room and another user had mentioned they had the same issue.

I figured it was worth it to post, since I'd expect others to run into  
this, as well.

Thanks!  
Paul

---

<div class="post-metadata">

**Author:** ![ppearcy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ppearcy/32/980_2.png) [@ppearcy](https://discuss.elastic.co/u/ppearcy)\
**Post date:** [May 26, 2011, 4:56am UTC](https://discuss.elastic.co/t/unable-to-recover-after-upgrading-from-0-16-0-to-0-16-1/4478/2 "2011-05-26T04:56:14Z")

</div>

Mostly another FYI... hit the porterStem vs porter\_stem issue  
mentioned in another thread and had an exception when creating an  
index for the first time:

com.wsod.dm.Internal.DMStatusException: Error updating index  
configuration. Index: idol-reports-shared1  
at  
com.wsod.dm.IndexSchema.createIndexWithFields(IndexSchema.java:350)  
at com.wsod.dm.IndexSchema.updateIndexes(IndexSchema.java:553)  
at com.wsod.dm.ESIndexer.main(ESIndexer.java:264)  
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)  
at  
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:  
39)  
at  
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:  
25)  
at java.lang.reflect.Method.invoke(Method.java:597)  
at  
org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:  
272)  
at java.lang.Thread.run(Thread.java:619)  
Caused by: org.elasticsearch.indices.IndexMissingException: [idol-  
reports-shared1] missing  
at  
org.elasticsearch.cluster.metadata.MetaData.concreteIndices(MetaData.java:  
165)  
at  
org.elasticsearch.cluster.metadata.MetaData.concreteIndices(MetaData.java:  
132)  
at  
org.elasticsearch.action.admin.indices.mapping.put.TransportPutMappingAction.doExecute(TransportPutMappingAction.java:  
71)  
at  
org.elasticsearch.action.admin.indices.mapping.put.TransportPutMappingAction.doExecute(TransportPutMappingAction.java:  
44)  
at  
org.elasticsearch.action.support.BaseAction.execute(BaseAction.java:  
61)  
at  
org.elasticsearch.client.node.NodeIndicesAdminClient.putMapping(NodeIndicesAdminClient.java:  
223)  
at  
org.elasticsearch.client.action.admin.indices.mapping.put.PutMappingRequestBuilder.doExecute(PutMappingRequestBuilder.java:  
116)  
at  
org.elasticsearch.client.action.admin.indices.support.BaseIndicesRequestBuilder.execute(BaseIndicesRequestBuilder.java:  
52)  
at  
org.elasticsearch.client.action.admin.indices.support.BaseIndicesRequestBuilder.execute(BaseIndicesRequestBuilder.java:  
47)  
at  
com.wsod.dm.IndexSchema.createIndexWithFields(IndexSchema.java:337)  
... 8 more

The first attempt failed, but the next succeeded.

On May 25, 10:17 pm, Paul [ppea...@gmail.com](mailto:ppea...@gmail.com) wrote:

> FYI, I've tried three different instances and they all fail to  
> initialize shards after upgrading from 0.16.0 to 0.16.1.
> 
> Re-indexing isn't a huge deal, but the upgrade notes did mention there  
> should not be any upgrade steps necessary. I had pinged the ES chat  
> room and another user had mentioned they had the same issue.
> 
> I figured it was worth it to post, since I'd expect others to run into  
> this, as well.
> 
> Thanks!  
> Paul

---

<div class="post-metadata">

**Author:** ![ppearcy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ppearcy/32/980_2.png) [@ppearcy](https://discuss.elastic.co/u/ppearcy)\
**Post date:** [May 26, 2011, 5:29am UTC](https://discuss.elastic.co/t/unable-to-recover-after-upgrading-from-0-16-0-to-0-16-1/4478/3 "2011-05-26T05:29:43Z")

</div>

Ah... Appears that shards where unable to recover because of the  
porterStem vs porter\_stem with one of the analyzers. Once I updated my  
config file the upgrade was able to continue without a problem.

It'd be good to note this in the release notes for 16.1.

Thanks!

On May 25, 10:56 pm, Paul [ppea...@gmail.com](mailto:ppea...@gmail.com) wrote:

> Mostly another FYI... hit the porterStem vs porter\_stem issue  
> mentioned in another thread and had an exception when creating an  
> index for the first time:
> 
> com.wsod.dm.Internal.DMStatusException: Error updating index  
> configuration. Index: idol-reports-shared1  
> at  
> com.wsod.dm.IndexSchema.createIndexWithFields(IndexSchema.java:350)  
> at com.wsod.dm.IndexSchema.updateIndexes(IndexSchema.java:553)  
> at com.wsod.dm.ESIndexer.main(ESIndexer.java:264)  
> at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)  
> at  
> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:  
> 39)  
> at  
> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImp l.java:  
> 25)  
> at java.lang.reflect.Method.invoke(Method.java:597)  
> at  
> org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:  
> 272)  
> at java.lang.Thread.run(Thread.java:619)  
> Caused by: org.elasticsearch.indices.IndexMissingException: [idol-  
> reports-shared1] missing  
> at  
> org.elasticsearch.cluster.metadata.MetaData.concreteIndices(MetaData.java:  
> 165)  
> at  
> org.elasticsearch.cluster.metadata.MetaData.concreteIndices(MetaData.java:  
> 132)  
> at  
> org.elasticsearch.action.admin.indices.mapping.put.TransportPutMappingActio n.doExecute(TransportPutMappingAction.java:  
> 71)  
> at  
> org.elasticsearch.action.admin.indices.mapping.put.TransportPutMappingActio n.doExecute(TransportPutMappingAction.java:  
> 44)  
> at  
> org.elasticsearch.action.support.BaseAction.execute(BaseAction.java:  
> 61)  
> at  
> org.elasticsearch.client.node.NodeIndicesAdminClient.putMapping(NodeIndices AdminClient.java:  
> 223)  
> at  
> org.elasticsearch.client.action.admin.indices.mapping.put.PutMappingRequest Builder.doExecute(PutMappingRequestBuilder.java:  
> 116)  
> at  
> org.elasticsearch.client.action.admin.indices.support.BaseIndicesRequestBui lder.execute(BaseIndicesRequestBuilder.java:  
> 52)  
> at  
> org.elasticsearch.client.action.admin.indices.support.BaseIndicesRequestBui lder.execute(BaseIndicesRequestBuilder.java:  
> 47)  
> at  
> com.wsod.dm.IndexSchema.createIndexWithFields(IndexSchema.java:337)  
> ... 8 more
> 
> The first attempt failed, but the next succeeded.
> 
> On May 25, 10:17 pm, Paul [ppea...@gmail.com](mailto:ppea...@gmail.com) wrote:
> 
> > FYI, I've tried three different instances and they all fail to  
> > initialize shards after upgrading from 0.16.0 to 0.16.1.
> 
> > Re-indexing isn't a huge deal, but the upgrade notes did mention there  
> > should not be any upgrade steps necessary. I had pinged the ES chat  
> > room and another user had mentioned they had the same issue.
> 
> > I figured it was worth it to post, since I'd expect others to run into  
> > this, as well.
> 
> > Thanks!  
> > Paul

---

<div class="post-metadata">

**Author:** ![kimchy](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kimchy/32/44952_2.png) [@kimchy](https://discuss.elastic.co/u/kimchy)\
**Post date:** [May 26, 2011, 7:10am UTC](https://discuss.elastic.co/t/unable-to-recover-after-upgrading-from-0-16-0-to-0-16-1/4478/4 "2011-05-26T07:10:40Z")

</div>

Heya,

Yea, annoying bug! and nasty regression on my part. I will update the release notes to reflect it... . 0.16.2 will be out next week (with tons of memory improvements).

-shay.banon  
On Thursday, May 26, 2011 at 8:29 AM, Paul wrote:  
Ah... Appears that shards where unable to recover because of the

> porterStem vs porter\_stem with one of the analyzers. Once I updated my  
> config file the upgrade was able to continue without a problem.
> 
> It'd be good to note this in the release notes for 16.1.
> 
> Thanks!
> 
> On May 25, 10:56 pm, Paul [ppea...@gmail.com](mailto:ppea...@gmail.com) wrote:
> 
> > Mostly another FYI... hit the porterStem vs porter\_stem issue  
> > mentioned in another thread and had an exception when creating an  
> > index for the first time:
> > 
> > com.wsod.dm.Internal.DMStatusException: Error updating index  
> > configuration. Index: idol-reports-shared1  
> > at  
> > com.wsod.dm.IndexSchema.createIndexWithFields(IndexSchema.java:350)  
> > at com.wsod.dm.IndexSchema.updateIndexes(IndexSchema.java:553)  
> > at com.wsod.dm.ESIndexer.main(ESIndexer.java:264)  
> > at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)  
> > at  
> > sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:  
> > 39)  
> > at  
> > sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImp l.java:  
> > 25)  
> > at java.lang.reflect.Method.invoke(Method.java:597)  
> > at  
> > org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:  
> > 272)  
> > at java.lang.Thread.run(Thread.java:619)  
> > Caused by: org.elasticsearch.indices.IndexMissingException: [idol-  
> > reports-shared1] missing  
> > at  
> > org.elasticsearch.cluster.metadata.MetaData.concreteIndices(MetaData.java:  
> > 165)  
> > at  
> > org.elasticsearch.cluster.metadata.MetaData.concreteIndices(MetaData.java:  
> > 132)  
> > at  
> > org.elasticsearch.action.admin.indices.mapping.put.TransportPutMappingActio n.doExecute(TransportPutMappingAction.java:  
> > 71)  
> > at  
> > org.elasticsearch.action.admin.indices.mapping.put.TransportPutMappingActio n.doExecute(TransportPutMappingAction.java:  
> > 44)  
> > at  
> > org.elasticsearch.action.support.BaseAction.execute(BaseAction.java:  
> > 61)  
> > at  
> > org.elasticsearch.client.node.NodeIndicesAdminClient.putMapping(NodeIndices AdminClient.java:  
> > 223)  
> > at  
> > org.elasticsearch.client.action.admin.indices.mapping.put.PutMappingRequest Builder.doExecute(PutMappingRequestBuilder.java:  
> > 116)  
> > at  
> > org.elasticsearch.client.action.admin.indices.support.BaseIndicesRequestBui lder.execute(BaseIndicesRequestBuilder.java:  
> > 52)  
> > at  
> > org.elasticsearch.client.action.admin.indices.support.BaseIndicesRequestBui lder.execute(BaseIndicesRequestBuilder.java:  
> > 47)  
> > at  
> > com.wsod.dm.IndexSchema.createIndexWithFields(IndexSchema.java:337)  
> > ... 8 more
> > 
> > The first attempt failed, but the next succeeded.
> > 
> > On May 25, 10:17 pm, Paul [ppea...@gmail.com](mailto:ppea...@gmail.com) wrote:
> > 
> > > FYI, I've tried three different instances and they all fail to  
> > > initialize shards after upgrading from 0.16.0 to 0.16.1.
> > 
> > > Re-indexing isn't a huge deal, but the upgrade notes did mention there  
> > > should not be any upgrade steps necessary. I had pinged the ES chat  
> > > room and another user had mentioned they had the same issue.
> > 
> > > I figured it was worth it to post, since I'd expect others to run into  
> > > this, as well.
> > 
> > > Thanks!  
> > > Paul

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 6, 2017, 4:05am UTC](https://discuss.elastic.co/t/unable-to-recover-after-upgrading-from-0-16-0-to-0-16-1/4478/5 "2017-07-06T04:05:19Z")

</div>


