# Unable to reindex after field changes

**URL:** https://discuss.elastic.co/t/unable-to-reindex-after-field-changes/243867
**Category:** Kibana
**Created:** [August 5, 2020, 1:00pm UTC](https://discuss.elastic.co/t/unable-to-reindex-after-field-changes/243867 "2020-08-05T13:00:15Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Gavin\_Clark](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gavin_clark/32/47826_2.png) [@Gavin\_Clark](https://discuss.elastic.co/u/Gavin_Clark)
#### Post date: [August 5, 2020, 1:00pm UTC](https://discuss.elastic.co/t/unable-to-reindex-after-field-changes/243867/1 "2020-08-05T13:00:16Z")

</div>

At the end of each month to keep index and shard counts low, we reindex all of our daily indices into a larger monthly index. We do this by manually running a reindex job on each of our larger index groups by running the following command in DevTools in Kibana:

```auto
    POST _reindex
{
  "source": {
    "index": ["daily-index_2020-07-06",
    "daily-index_2020-07-23",
    "daily-index_2020-07-27",
    "daily-index_2020-07-31"
]
  },
  "dest": {
    "index": "monthly-index_2020-07-reindex"
  }
}

```

Recently, the devs had to make some changes to certain fields for analytics reasons. Now upon reindexing I'm given the following error:

```auto
"cause" : {
        "type" : "mapper_parsing_exception",
        "reason" : "object mapping for [responseVisual] tried to parse field [responseVisual] as object, but found a concrete value"
      },
      "status" : 400

```

**How can I either fix this so I can reindex again or ignore these errors(assuming they still show up in Kibana correctly).**

We're looking into Curator and Index Lifecycle policies to automate this in the future, but we aren't there yet.

Thank you.

---

<div class="post-metadata">

### Author: ![bhavyarm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/bhavyarm/32/22392_2.png) [@bhavyarm](https://discuss.elastic.co/u/bhavyarm)
#### Post date: [August 5, 2020, 8:21pm UTC](https://discuss.elastic.co/t/unable-to-reindex-after-field-changes/243867/2 "2020-08-05T20:21:36Z")

</div>

@cjcenizal thanks 🙂

---

<div class="post-metadata">

### Author: ![cjcenizal](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/cjcenizal/32/11216_2.png) [@cjcenizal](https://discuss.elastic.co/u/cjcenizal)
#### Post date: [August 20, 2020, 11:01pm UTC](https://discuss.elastic.co/t/unable-to-reindex-after-field-changes/243867/3 "2020-08-20T23:01:39Z")

</div>

Hi Gavin, this sounds similar to this StackOverflow question: [https://stackoverflow.com/questions/30454108/how-to-solve-mapperparsingexception-object-mapping-for-test-tried-to-parse-as](https://stackoverflow.com/questions/30454108/how-to-solve-mapperparsingexception-object-mapping-for-test-tried-to-parse-as)

The error is saying that one of your indices has `responseVisual` mapped as an object, and another has it mapped as a non-object value. These are incompatible mapping types. I suggest you either only reindex indices that have compatible mappings, or reindex using an ingest node pipeline to normalize your data in different indices to the same type. There is a section in the [reindex docs](https://www.elastic.co/guide/en/elasticsearch/reference/current/docs-reindex.html) that mentions this. You can learn more about ingest node pipelines [here](https://www.elastic.co/guide/en/elasticsearch/reference/current/pipeline.html). Does this help?

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [September 17, 2020, 11:01pm UTC](https://discuss.elastic.co/t/unable-to-reindex-after-field-changes/243867/4 "2020-09-17T23:01:42Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
