# Unable to restart a node - index.mapper.dynamic was removed after version 6.0.0

**URL:** <https://discuss.elastic.co/t/unable-to-restart-a-node-index-mapper-dynamic-was-removed-after-version-6-0-0/320506>\
**Category:** Elasticsearch\
**Created:** [December 5, 2022, 10:10pm UTC](https://discuss.elastic.co/t/unable-to-restart-a-node-index-mapper-dynamic-was-removed-after-version-6-0-0/320506 "2022-12-05T22:10:38Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![newkidtopc](https://avatars.discourse-cdn.com/v4/letter/n/6bbea6/32.png) [@newkidtopc](https://discuss.elastic.co/u/newkidtopc)\
**Post date:** [December 5, 2022, 10:10pm UTC](https://discuss.elastic.co/t/unable-to-restart-a-node-index-mapper-dynamic-was-removed-after-version-6-0-0/320506/1 "2022-12-05T22:10:38Z")

</div>

We have been running our ES cluster (ES Version 7.16.3) for a few months now. This cluster was built using the data from earlier ES version (ES 6.8) and the cluster has been running smoothly after the upgrade.

We run on AWS EKS and have been through successful reboots of entire cluster without any issue. However, recently, during one such attempted reboot of the cluster, one of the data nodes for the cluster refuses to come up and run successfully.

The specific error encountered is

```auto
java.lang.IllegalStateException: Failed to parse mappings for index [[index name]]
Likely root cause: java.lang.IllegalArgumentException: Setting index.mapper.dynamic was removed after version 6.0.0

```

We are unable to remove the dynamic mapper setting because we run into the following error

{"error":{"root\_cause":[{"type":"illegal\_argument\_exception","reason":"Setting index.mapper.dynamic was removed after version 6.0.0"}]

Is there any good way to revive the node and the cluster without the need for re-indexing the data?

Thank you.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 6, 2022, 5:26am UTC](https://discuss.elastic.co/t/unable-to-restart-a-node-index-mapper-dynamic-was-removed-after-version-6-0-0/320506/2 "2022-12-06T05:26:07Z")

</div>

> [@newkidtopc](#):
>
> `Failed to parse mappings for index [[index name]]`

Is that setting in the actual index (that looks redacted?)?

---

<div class="post-metadata">

**Author:** ![newkidtopc](https://avatars.discourse-cdn.com/v4/letter/n/6bbea6/32.png) [@newkidtopc](https://discuss.elastic.co/u/newkidtopc)\
**Post date:** [December 6, 2022, 6:32am UTC](https://discuss.elastic.co/t/unable-to-restart-a-node-index-mapper-dynamic-was-removed-after-version-6-0-0/320506/3 "2022-12-06T06:32:08Z")

</div>

Yes. I can see the setting when I call settings API on the index.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [January 3, 2023, 6:32am UTC](https://discuss.elastic.co/t/unable-to-restart-a-node-index-mapper-dynamic-was-removed-after-version-6-0-0/320506/4 "2023-01-03T06:32:25Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
