# Unable to restore snaphost

**URL:** https://discuss.elastic.co/t/unable-to-restore-snaphost/127249
**Category:** Elasticsearch
**Created:** [April 9, 2018, 6:02am UTC](https://discuss.elastic.co/t/unable-to-restore-snaphost/127249 "2018-04-09T06:02:12Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![baskar](https://avatars.discourse-cdn.com/v4/letter/b/c5a1d2/32.png) [@baskar](https://discuss.elastic.co/u/baskar)
#### Post date: [April 9, 2018, 6:02am UTC](https://discuss.elastic.co/t/unable-to-restore-snaphost/127249/1 "2018-04-09T06:02:13Z")

</div>

HI ,Please help on this issue ... unable restore  
\<  
hduser@HMCOHWPC0218:~/Scripts$ curl -XPOST "192.168.XX.XX:9200/\_snapshot/my\_backup/20180405-000501/\_restore?wait\_for\_completion=true"

{"snapshot":{"snapshot":"20180405-000501","indices":["graylog\_0"],"shards":{"total":4,"failed":4,"successful":0}}}hduser@HMCOHWPC0218:~/Scripts$ /\>

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [April 9, 2018, 7:57am UTC](https://discuss.elastic.co/t/unable-to-restore-snaphost/127249/2 "2018-04-09T07:57:05Z")

</div>

please take the time to properly describe your problem. include full requests and especially full responses, your configuration, and what you except to happen within this context. This tidbit of information is not helpful. There is no error message and all you claim is you are not able to restore.

If you need help it is super important to provide as much information as possible, so others can chime in.

Thank you!

--Alex

---

<div class="post-metadata">

### Author: ![baskar](https://avatars.discourse-cdn.com/v4/letter/b/c5a1d2/32.png) [@baskar](https://discuss.elastic.co/u/baskar)
#### Post date: [April 9, 2018, 9:21am UTC](https://discuss.elastic.co/t/unable-to-restore-snaphost/127249/3 "2018-04-09T09:21:21Z")

</div>

> [@baskar](#):
>
> curl -XPOST "192.168.XX.XX:9200/\_snapshot/my\_backup/20180405-000501/\_restore?wait\_for\_completion=true"

HI Alex , Thanks for your prompt reply ...  
Am trying to restore my snapshot backup which is 20180405-000501 using the below command  
**curl -XPOST "192.168.XX.XX:9200/\_snapshot/my\_backup/20180405-000501/\_restore?wait\_for\_completion=true"**

finally i got this response  
**{"snapshot":{"snapshot":"20180405-000501","indices":["graylog\_0"],"shards":{"total":4,"failed":4,"successful":0}}}**

failed :4 and successful:0 ... Were is restored failed..  
Request you to please advice me How to restore my snapshot backup

---

<div class="post-metadata">

### Author: ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)
#### Post date: [April 9, 2018, 12:05pm UTC](https://discuss.elastic.co/t/unable-to-restore-snaphost/127249/4 "2018-04-09T12:05:14Z")

</div>

is there anything in the logfiles? Have you made sure the `graylog_0` index does not exist before restoring? How long does that restore operation take? And how big is that snapshot?

---

<div class="post-metadata">

### Author: ![baskar](https://avatars.discourse-cdn.com/v4/letter/b/c5a1d2/32.png) [@baskar](https://discuss.elastic.co/u/baskar)
#### Post date: [April 9, 2018, 12:08pm UTC](https://discuss.elastic.co/t/unable-to-restore-snaphost/127249/5 "2018-04-09T12:08:59Z")

</div>

Hi ... issue has been resolved ..due to my indices set as 1 ..Now i have increased 4 indices  
It's getting restored fine Thanks for your reply 😄

Snapshot siz:12GB

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [May 7, 2018, 12:09pm UTC](https://discuss.elastic.co/t/unable-to-restore-snaphost/127249/6 "2018-05-07T12:09:25Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
