# Unable to retrieve data from Oracle sample table using Logstash

**URL:** <https://discuss.elastic.co/t/unable-to-retrieve-data-from-oracle-sample-table-using-logstash/363811>\
**Category:** Logstash\
**Created:** [July 25, 2024, 8:47pm UTC](https://discuss.elastic.co/t/unable-to-retrieve-data-from-oracle-sample-table-using-logstash/363811 "2024-07-25T20:47:53Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![sundarcdm1](https://avatars.discourse-cdn.com/v4/letter/s/8e8cbc/32.png) [@sundarcdm1](https://discuss.elastic.co/u/sundarcdm1)\
**Post date:** [July 25, 2024, 8:47pm UTC](https://discuss.elastic.co/t/unable-to-retrieve-data-from-oracle-sample-table-using-logstash/363811/1 "2024-07-25T20:47:53Z")

</div>

```auto

Hi All, I am very new to Elastic . i was following a blog and video which describes step by step of how to configure create a simple db table and to retrieve values from table using logstash and to display in kibana portal. 

All in windows environment

1. I have configured a employee_config.conf file
input {
    jdbc {
     clean_run => true
        jdbc_driver_library => "C:\Tools\ojdbc8-19.3.0.0.jar"
        jdbc_driver_class => "oracle.jdbc.driver.OracleDriver"
        jdbc_connection_string => "jdbc:oracle:thin:@xxxx:xxxx:xxx"
        jdbc_user => "KIBANA"
        jdbc_password => "xxxxxxxx"
        #schedule => "* * * * *"
        statement => "select * from EMPLOYEE"
        use_column_value => true
        #tracking_column => "category"
        tracking_column => "LAST_NAME"
    }
}
filter {
  mutate {
    remove_field => ["@version"]
  }
}
output{
    elasticsearch { 
        hosts => ["http://localhost:9200/"]
        index => "employee_idx"
        user => "elastic"
        password => "xxxxxxx"
        ssl => false
        ssl_certificate_verification => false
    }
    
}

2. Already there are few rows in the oracle table.

3. Then I tried to start the elasticsearch but then i m getting this below error

ERROR][o.e.i.g.GeoIpDownloader]exception during geoip databases updatejavax.net.ssl.SSLHandshakeException:
 PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException:
 unable to find valid certification path to requested target

But i can able to get the json sample resposne from the default URL(http://localhost:9200)

5. I have started Kibana and there are no issues in the portal.

6. I tried to execute the command logstash and i dont see any error either.

7.When i try to log to kibana portal under management-->dev tools--> and then i just want to execute GET employee_idx/_search inorder to get the response from Employee table as a json.

But i am getting the result as below

{
  "error": {
    "root_cause": [
      {
        "type": "index_not_found_exception",
        "reason": "no such index [employee_idx]",
        "resource.type": "index_or_alias",
        "resource.id": "employee_idx",
        "index_uuid": "_na_",
        "index": "employee_idx"
      }
    ],
    "type": "index_not_found_exception",
    "reason": "no such index [employee_idx]",
    "resource.type": "index_or_alias",
    "resource.id": "employee_idx",
    "index_uuid": "_na_",
    "index": "employee_idx"
  },
  "status": 404
}

Is there anything that i have missed or need to add. Please see i am new to this topic and following some blogs and video which are organised for a begineer.

Please guide/help.

Best Regards,
Ram 

```

---

<div class="post-metadata">

**Author:** ![ashishtiwari1993](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ashishtiwari1993/32/135241_2.png) [@ashishtiwari1993](https://discuss.elastic.co/u/ashishtiwari1993)\
**Post date:** [August 1, 2024, 7:34am UTC](https://discuss.elastic.co/t/unable-to-retrieve-data-from-oracle-sample-table-using-logstash/363811/2 "2024-08-01T07:34:42Z")

</div>

Hi @sundarcdm1, Welcome to the Elastic community.

1. Which version of Elasticsearch you are running ? Is it setup with certificate ? If [https://localhost:9200](https://localhost:9200) giving response, which means it is disabled.
2. `index_not_found_exception`: As mentioned there is no such index. you need to first solve Elasticsearch error.
