# Unable to retrieve version information from Elasticsearch nodes

**URL:** <https://discuss.elastic.co/t/unable-to-retrieve-version-information-from-elasticsearch-nodes/317200>\
**Category:** Kibana\
**Tags:** elastic-stack-security\
**Created:** [October 21, 2022, 12:57pm UTC](https://discuss.elastic.co/t/unable-to-retrieve-version-information-from-elasticsearch-nodes/317200 "2022-10-21T12:57:37Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![diegz](https://avatars.discourse-cdn.com/v4/letter/d/d07c76/32.png) [@diegz](https://discuss.elastic.co/u/diegz)\
**Post date:** [October 21, 2022, 12:57pm UTC](https://discuss.elastic.co/t/unable-to-retrieve-version-information-from-elasticsearch-nodes/317200/1 "2022-10-21T12:57:37Z")

</div>

Hello,

I have this error when I start kibana :

```auto
kibana1.lab.fr kibana[2294]: [2022-10-21T14:42:03.355+02:00][ERROR][elasticsearch-service] Unable to retrieve version information from Elasticsearch nodes. socket hang up - Local: 192.168.1.80:41720, Remote: 192.168.1.10:9200
oct. 21 14:42:04 kibana1.lab.fr kibana[2294]: [2022-10-21T14:42:04.650+02:00][INFO][plugins.screenshotting.chromium] Browser executable: /usr/share/kibana/x-pack/plugins/screenshotting/chromium/headless_shell-linux_x64/headless_shell
oct. 21 14:42:05 kibana1.lab.fr kibana[2294]: [2022-10-21T14:42:05.929+02:00][ERROR][elasticsearch-service] Unable to retrieve version information from Elasticsearch nodes. socket hang up - Local: 192.168.1.80:34066, Remote: 192.168.1.20:9200
oct. 21 14:42:08 kibana1.lab.fr kibana[2294]: [2022-10-21T14:42:08.444+02:00][ERROR][elasticsearch-service] Unable to retrieve version information from Elasticsearch nodes. socket hang up - Local: 192.168.1.80:52746, Remote: 192.168.1.40:9200
oct. 21 14:42:10 kibana1.lab.fr kibana[2294]: [2022-10-21T14:42:10.889+02:00][ERROR][elasticsearch-service] Unable to retrieve version information from Elasticsearch nodes. socket hang up - Local: 192.168.1.80:41800, Remote: 192.168.1.10:9200
oct. 21 14:42:13 kibana1.lab.fr kibana[2294]: [2022-10-21T14:42:13.443+02:00][ERROR][elasticsearch-service] Unable to retrieve version information from Elasticsearch nodes. socket hang up - Local: 192.168.1.80:35878, Remote: 192.168.1.30:9200
oct. 21 14:42:15 kibana1.lab.fr kibana[2294]: [2022-10-21T14:42:15.949+02:00][ERROR][elasticsearch-service] Unable to retrieve version information from Elasticsearch nodes. socket hang up - Local: 192.168.1.80:35702, Remote: 192.168.1.50:9200
oct. 21 14:42:18 kibana1.lab.fr kibana[2294]: [2022-10-21T14:42:18.463+02:00][ERROR][elasticsearch-service] Unable to retrieve version information from Elasticsearch nodes. socket hang up - Local: 192.168.1.80:34186, Remote: 192.168.1.20:9200

```

an example of the configuration of one of the cluster nodes :

```auto
# Enable encryption for HTTP API client connections, such as Kibana, Logstash, and Agents
xpack.security.http.ssl:
  enabled: true
  keystore.path: /etc/elasticsearch/new/http.p12
  truststore.path: /etc/elasticsearch/new/http.p12
  client_authentication: required
  verification_mode: full
# Enable encryption and mutual authentication between cluster node
xpack.security.transport.ssl:
  enabled: true
  verification_mode: full
  client_authentication: required
  keystore.path: /etc/elasticsearch/new/node-1.p12
  truststore.path: /etc/elasticsearch/new/node-1.p12

```

Kibana config:

```auto

server.ssl.enabled: true
server.ssl.keystore.path: "/etc/kibana/certs/kibana1.p12"
server.ssl.truststore.path: "/etc/kibana/certs/kibana1.p12"
#server.ssl.clientAuthentication: required

# =================== System: Elasticsearch ===================
# The URLs of the Elasticsearch instances to use for all your queries.
elasticsearch.hosts: ["https://192.168.1.10:9200", "https://192.168.1.20:9200","https://192.168.1.30:9200", "https://192.168.1.40:9200", "https://192.168.1.50:9200"]
elasticsearch.ssl.certificateAuthorities: ["/etc/kibana/certs/elasticsearch-ca.pem"]

```

I think it's the kibana authentication on the cluster nodes that isn't working.  
How to fix it?

Thanks in advance for your help

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [October 23, 2022, 11:08pm UTC](https://discuss.elastic.co/t/unable-to-retrieve-version-information-from-elasticsearch-nodes/317200/2 "2022-10-23T23:08:11Z")

</div>

Is that all that is in the Kibana logs?  
Is there anything in the Elasticsearch logs?

---

<div class="post-metadata">

**Author:** ![diegz](https://avatars.discourse-cdn.com/v4/letter/d/d07c76/32.png) [@diegz](https://discuss.elastic.co/u/diegz)\
**Post date:** [October 26, 2022, 12:38pm UTC](https://discuss.elastic.co/t/unable-to-retrieve-version-information-from-elasticsearch-nodes/317200/3 "2022-10-26T12:38:46Z")

</div>

Thanks @warkolm for your answer.  
I solved the problem on another ticket previously opened.  
Thanks

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 23, 2022, 12:39pm UTC](https://discuss.elastic.co/t/unable-to-retrieve-version-information-from-elasticsearch-nodes/317200/4 "2022-11-23T12:39:46Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
