# Unable to revive connection

**URL:** <https://discuss.elastic.co/t/unable-to-revive-connection/71645>\
**Category:** Kibana\
**Created:** [January 15, 2017, 1:12pm UTC](https://discuss.elastic.co/t/unable-to-revive-connection/71645 "2017-01-15T13:12:35Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [January 15, 2017, 1:12pm UTC](https://discuss.elastic.co/t/unable-to-revive-connection/71645/1 "2017-01-15T13:12:36Z")

</div>

Whenever starting Kibana I am getting the following errors in endless loop:

```
{"type":"log","@timestamp":"2017-01-15T13:01:28Z","tags":["warning","elasticsearch"],"pid":65037,"message":"No living connections"}
{"type":"log","@timestamp":"2017-01-15T13:01:31Z","tags":["warning","elasticsearch"],"pid":65037,"message":"Unable to revive connection: https://localhost:9200/"}
{"type":"log","@timestamp":"2017-01-15T13:01:31Z","tags":["warning","elasticsearch"],"pid":65037,"message":"No living connections"}
{"type":"log","@timestamp":"2017-01-15T13:01:33Z","tags":["warning","elasticsearch"],"pid":65037,"message":"Unable to revive connection: https://localhost:9200/"}
{"type":"log","@timestamp":"2017-01-15T13:01:33Z","tags":["warning","elasticsearch"],"pid":65037,"message":"No living connections"}
{"type":"log","@timestamp":"2017-01-15T13:01:36Z","tags":["warning","elasticsearch"],"pid":65037,"message":"Unable to revive connection: https://localhost:9200/"}
{"type":

```

or

```
{"type":"log","@timestamp":"2017-01-15T13:02:28Z","tags":["warning","elasticsearch"],"pid":65082,"message":"Unable to revive connection: http://localhost:9200/"}
{"type":"log","@timestamp":"2017-01-15T13:02:28Z","tags":["warning","elasticsearch"],"pid":65082,"message":"No living connections"}
{"type":"log","@timestamp":"2017-01-15T13:02:31Z","tags":["warning","elasticsearch"],"pid":65082,"message":"Unable to revive connection: http://localhost:9200/"}
{"type":"log","@timestamp":"2017-01-15T13:02:31Z","tags":["warning","elasticsearch"],"pid":65082,"message":"No living connections"}

```

What is the issue? I can't find it.

Thanks  
Sharon.

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [January 15, 2017, 11:57pm UTC](https://discuss.elastic.co/t/unable-to-revive-connection/71645/2 "2017-01-15T23:57:22Z")

</div>

Is ES ok?

---

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [January 16, 2017, 8:24am UTC](https://discuss.elastic.co/t/unable-to-revive-connection/71645/3 "2017-01-16T08:24:02Z")

</div>

Yes it is

---

<div class="post-metadata">

**Author:** ![spalger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spalger/32/14092_2.png) [@spalger](https://discuss.elastic.co/u/spalger)\
**Post date:** [January 16, 2017, 11:58pm UTC](https://discuss.elastic.co/t/unable-to-revive-connection/71645/4 "2017-01-16T23:58:12Z")

</div>

This happens when Kibana can't communicate with elasticsearch. Can you try pinging elasticsearch with curl from the box that kibana is running on?

```auto
curl -i http://localhost:9200

```

---

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [January 18, 2017, 9:12am UTC](https://discuss.elastic.co/t/unable-to-revive-connection/71645/5 "2017-01-18T09:12:46Z")

</div>

Below you can see the answer from curl command :

```
 mpswrk1@eaasrt!MPS:/etc/elasticsearch> curl --cacert /etc/elasticsearch/x-pack/elasticsearchcrt/elasticsearchcrt.crt https://localhost:9200
    curl: (60) Peer's Certificate issuer is not recognized.

```

What is wrong here?

Thanks  
Sharon.

---

<div class="post-metadata">

**Author:** ![spalger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spalger/32/14092_2.png) [@spalger](https://discuss.elastic.co/u/spalger)\
**Post date:** [January 18, 2017, 5:09pm UTC](https://discuss.elastic.co/t/unable-to-revive-connection/71645/6 "2017-01-18T17:09:09Z")

</div>

Not sure about that curl error. Have you googled it? If you resolve that error I bet Kibana will start working again

---

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [January 19, 2017, 7:28pm UTC](https://discuss.elastic.co/t/unable-to-revive-connection/71645/7 "2017-01-19T19:28:22Z")

</div>

I tried to find anywhere how to solve it but can't

---

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [January 19, 2017, 7:33pm UTC](https://discuss.elastic.co/t/unable-to-revive-connection/71645/8 "2017-01-19T19:33:16Z")

</div>

mpswrk1@eaasrt!MPS:/etc/elasticsearch/x-pack\> `sudo curl -XPUT -u elastic:elastic 'https://eaasrt:9200/_xpack/license' -d @/etc/elasticsearch/x-pack/license.json`  
curl: (60) **Peer's Certificate issuer is not recognized.**

Why my peer certificate issuer isn't recognized?

I used the elastic certgen command to generate the certificated.

Also When I did it with RSA I got the same error.

Something is problematic here but I can't put my hand on it.

Any idea?

---

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [January 19, 2017, 10:06pm UTC](https://discuss.elastic.co/t/unable-to-revive-connection/71645/9 "2017-01-19T22:06:38Z")

</div>

Now, I think my elastic is working, but still I can't open my browser for kibana

```
mpswrk1@eaasrt!MPS:/etc/elasticsearch> sudo curl --cacert /etc/elasticsearch/x-pack/localhost.cert -XGET -u elastic:myelasticpass 'https://eaasrt:9200'
{
  "name" : "mps",
  "cluster_name" : "valuePack",
  "cluster_uuid" : "eM_Y1uAxQF-SE859iFL7jQ",
  "version" : {
    "number" : "5.0.1",
    "build_hash" : "080bb47",
    "build_date" : "2016-11-11T22:08:49.812Z",
    "build_snapshot" : false,
    "lucene_version" : "6.2.1"
  },
  "tagline" : "You Know, for Search"
}
```

---

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [January 19, 2017, 10:07pm UTC](https://discuss.elastic.co/t/unable-to-revive-connection/71645/10 "2017-01-19T22:07:00Z")

</div>

If someone can assist here!!!

---

<div class="post-metadata">

**Author:** ![ssasporta](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ssasporta/32/13695_2.png) [@ssasporta](https://discuss.elastic.co/u/ssasporta)\
**Post date:** [February 5, 2017, 8:25am UTC](https://discuss.elastic.co/t/unable-to-revive-connection/71645/11 "2017-02-05T08:25:26Z")

</div>

solved

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 5, 2017, 8:26am UTC](https://discuss.elastic.co/t/unable-to-revive-connection/71645/12 "2017-03-05T08:26:04Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
