# Unable to RUN bulk API client from different server -- NoNodeAvailableException

**URL:** <https://discuss.elastic.co/t/unable-to-run-bulk-api-client-from-different-server-nonodeavailableexception/42743>\
**Category:** Elasticsearch\
**Created:** [February 25, 2016, 4:38pm UTC](https://discuss.elastic.co/t/unable-to-run-bulk-api-client-from-different-server-nonodeavailableexception/42743 "2016-02-25T16:38:56Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![tirupathi](https://avatars.discourse-cdn.com/v4/letter/t/ba9def/32.png) [@tirupathi](https://discuss.elastic.co/u/tirupathi)\
**Post date:** [February 25, 2016, 4:38pm UTC](https://discuss.elastic.co/t/unable-to-run-bulk-api-client-from-different-server-nonodeavailableexception/42743/1 "2016-02-25T16:38:57Z")

</div>

I am doing a POC using Elastic Search, when I ran a Bulkload Client on Same server where Elastic Search is running it is working fine, where I moved the BlukLoad client to another batch server I started getting this error. (to confirm network connectivity I verified from another server by executing curl, curl it is working fine )  
To resolve this error I had to downgrade Elastic Search to 1.7.5.  
I am using java version "1.8.0\_71"  
Elastic Search 2.2.0 (Where I got the error ) I also tried (2.1.2 same error ).

NoNodeAvailableException[None of the configured nodes are available: [{#transport#-1}{xxx.xx.xx.xx}{hostName/xxx.xx.xx.xx:9300}]]  
at org.elasticsearch.client.transport.TransportClientNodesService.ensureNodesAreAvailable(TransportClientNodesService.java:290)  
at org.elasticsearch.client.transport.TransportClientNodesService.execute(TransportClientNodesService.java:207)  
at org.elasticsearch.client.transport.support.TransportProxyClient.execute(TransportProxyClient.java:55)  
at org.elasticsearch.client.transport.TransportClient.doExecute(TransportClient.java:286)  
at org.elasticsearch.client.support.AbstractClient.execute(AbstractClient.java:351)  
at org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:85)  
at org.elasticsearch.action.ActionRequestBuilder.execute(ActionRequestBuilder.java:59)  
at com.citi.code.es.TCBulkRequester.loadFromFile(TCBulkRequester.java:115)  
at com.citi.code.es.BulkLoader.main(BulkLoader.java:30)

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [February 26, 2016, 12:36am UTC](https://discuss.elastic.co/t/unable-to-run-bulk-api-client-from-different-server-nonodeavailableexception/42743/2 "2016-02-26T00:36:03Z")

</div>

Did you tell ES to listen on a non-loopback address?

See [Connectivity issues with a new/upgraded 2.X cluster? Read here first :)](https://discuss.elastic.co/t/connectivity-issues-with-a-new-upgraded-2-x-cluster-read-here-first/35699/8)

---

<div class="post-metadata">

**Author:** ![tirupathi](https://avatars.discourse-cdn.com/v4/letter/t/ba9def/32.png) [@tirupathi](https://discuss.elastic.co/u/tirupathi)\
**Post date:** [March 16, 2016, 3:38pm UTC](https://discuss.elastic.co/t/unable-to-run-bulk-api-client-from-different-server-nonodeavailableexception/42743/3 "2016-03-16T15:38:06Z")

</div>

Yes I did configured non-loopback address by mentioning below in config  
network.host: xxx.xx.xxx.xx

To be specific, this is happening only for bluk API, using JAVA API search is working fine.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [July 5, 2017, 11:07pm UTC](https://discuss.elastic.co/t/unable-to-run-bulk-api-client-from-different-server-nonodeavailableexception/42743/4 "2017-07-05T23:07:53Z")

</div>


