# Unable to run Elastic search from ubuntu

**URL:** <https://discuss.elastic.co/t/unable-to-run-elastic-search-from-ubuntu/182231>\
**Category:** Elasticsearch\
**Created:** [May 22, 2019, 1:08pm UTC](https://discuss.elastic.co/t/unable-to-run-elastic-search-from-ubuntu/182231 "2019-05-22T13:08:45Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Manohar1](https://avatars.discourse-cdn.com/v4/letter/m/51bf81/32.png) [@Manohar1](https://discuss.elastic.co/u/Manohar1)\
**Post date:** [May 22, 2019, 1:08pm UTC](https://discuss.elastic.co/t/unable-to-run-elastic-search-from-ubuntu/182231/1 "2019-05-22T13:08:45Z")

</div>

Hi All,

i am trying to run elastic search latest version from ubuntu 18.4 but i am no luck . I am getting below error. can you some please suggest how to fix this error and how to make my elk should up. Thanks in advance.

```auto
root@ip-172-31-31-85:/# service elasticsearch status
● elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vendor preset: enabled)
   Active: failed (Result: exit-code) since Wed 2019-05-22 13:01:56 UTC; 7s ago
     Docs: http://www.elastic.co
  Process: 5375 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)
 Main PID: 5375 (code=exited, status=1/FAILURE)

May 22 13:01:56 ip-172-31-31-85 elasticsearch[5375]: in 'reader', line 33, column 1:
May 22 13:01:56 ip-172-31-31-85 elasticsearch[5375]: path.data: /var/lib/elasticsearch
May 22 13:01:56 ip-172-31-31-85 elasticsearch[5375]: ^
May 22 13:01:56 ip-172-31-31-85 elasticsearch[5375]: at org.yaml.snakeyaml.parser.ParserImpl$ParseDocumentStart.produce(ParserImpl.java:224)
May 22 13:01:56 ip-172-31-31-85 elasticsearch[5375]: at org.yaml.snakeyaml.parser.ParserImpl.peekEvent(ParserImpl.java:157)
May 22 13:01:56 ip-172-31-31-85 elasticsearch[5375]: at org.yaml.snakeyaml.parser.ParserImpl.getEvent(ParserImpl.java:167)
May 22 13:01:56 ip-172-31-31-85 elasticsearch[5375]: at com.fasterxml.jackson.dataformat.yaml.YAMLParser.nextToken(YAMLParser.java:340)
May 22 13:01:56 ip-172-31-31-85 elasticsearch[5375]: ... 12 more
May 22 13:01:56 ip-172-31-31-85 systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
May 22 13:01:56 ip-172-31-31-85 systemd[1]: elasticsearch.service: Failed with result 'exit-code'.

```

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [May 22, 2019, 1:30pm UTC](https://discuss.elastic.co/t/unable-to-run-elastic-search-from-ubuntu/182231/2 "2019-05-22T13:30:44Z")

</div>

looks like your `elasticsearch.yml` has been modified and is broken.

If you want to share it with us, please format it using `</>` icon as explained in [this guide](https://discuss.elastic.co/t/about-the-elasticsearch-category/21) and not the citation button. It will make your post more readable.

Or use markdown style like:

````
```
CODE
```

````

This is the icon to use if you are not using markdown format:

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/7/e/7e6e239431ec2d71cbf1beef741f2e93e7cc762c.jpg)

There's a live preview panel for exactly this reasons.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [June 19, 2019, 1:30pm UTC](https://discuss.elastic.co/t/unable-to-run-elastic-search-from-ubuntu/182231/3 "2019-06-19T13:30:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
