# Unable to run Elasticsearch 7.2 on Windows

**URL:** <https://discuss.elastic.co/t/unable-to-run-elasticsearch-7-2-on-windows/188284>\
**Category:** Elasticsearch\
**Created:** [July 1, 2019, 10:20am UTC](https://discuss.elastic.co/t/unable-to-run-elasticsearch-7-2-on-windows/188284 "2019-07-01T10:20:10Z")\
**Posts on this page:** 1\
**Showing post:** 3

<div class="post-metadata">

**Author:** ![kmohd](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/kmohd/32/49090_2.png) [@kmohd](https://discuss.elastic.co/u/kmohd)\
**Post date:** [July 1, 2019, 11:11am UTC](https://discuss.elastic.co/t/unable-to-run-elasticsearch-7-2-on-windows/188284/3 "2019-07-01T11:11:13Z")

</div>

issue fixed After adding 'xpack.ml.enabled: false' in elasticsearch.yml and adding a custom path for **java.io.tmpdir** in jvm options.

referred to [Linux OS : Failed to create native process factories for Machine Learning](https://discuss.elastic.co/t/linux-os-failed-to-create-native-process-factories-for-machine-learning/134758/2)

---

_[View the full topic](https://discuss.elastic.co/t/unable-to-run-elasticsearch-7-2-on-windows/188284)._
