# Unable to run elasticsearch rally in docker

**URL:** <https://discuss.elastic.co/t/unable-to-run-elasticsearch-rally-in-docker/354174>\
**Category:** Elasticsearch\
**Tags:** docker, rally\
**Created:** [February 27, 2024, 4:43am UTC](https://discuss.elastic.co/t/unable-to-run-elasticsearch-rally-in-docker/354174 "2024-02-27T04:43:10Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![uttamkrpanda](https://avatars.discourse-cdn.com/v4/letter/u/3da27b/32.png) [@uttamkrpanda](https://discuss.elastic.co/u/uttamkrpanda)\
**Post date:** [February 27, 2024, 4:43am UTC](https://discuss.elastic.co/t/unable-to-run-elasticsearch-rally-in-docker/354174/1 "2024-02-27T04:43:10Z")

</div>

I am unable to run elasticsearch rally with docker its getting "No such file or directory" error .

How can i fix this ?

```auto
docker run elastic/rally race --track=nyc_taxis --test-mode --pipeline=benchmark-only --target-hosts=https://localhost:9200 --client-optio="timeout:60,use_ssl:true,verify_certs:true,ca_certs:'/home/cloud-user/es-key.pem'"

```

getting below error

```auto
ERROR] Cannot race. Traceback (most recent call last): File "/usr/local/lib/python3.8/site-packages/esrally/actor.py", line 92, in guard return f(self, msg, sender) File "/usr/local/lib/python3.8/site-packages/esrally/racecontrol.py", line 111, in receiveMsg_Setup self.coordinator.setup(sources=msg.sources) File "/usr/local/lib/python3.8/site-packages/esrally/racecontrol.py", line 194, in setup ) = client.factory.cluster_distribution_version(hosts, client_options) File "/usr/local/lib/python3.8/site-packages/esrally/client/factory.py", line 345, in cluster_distribution_version es = client_factory(hosts, client_options).create() File "/usr/local/lib/python3.8/site-packages/esrally/client/factory.py", line 66, in __init__ self.ssl_context = ssl.create_default_context( File "/usr/local/lib/python3.8/ssl.py", line 745, in create_default_context context.load_verify_locations(cafile, capath, cadata) FileNotFoundError: [Errno 2] No such file or directory

```

---

<div class="post-metadata">

**Author:** ![gbanasiak](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/gbanasiak/32/121454_2.png) [@gbanasiak](https://discuss.elastic.co/u/gbanasiak)\
**Post date:** [February 27, 2024, 8:16am UTC](https://discuss.elastic.co/t/unable-to-run-elasticsearch-rally-in-docker/354174/2 "2024-02-27T08:16:30Z")

</div>

It looks like `/home/cloud-user/es-key.pem` is not available to Docker container. Please try using a [bind mount](https://docs.docker.com/storage/bind-mounts/).

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [March 26, 2024, 8:17am UTC](https://discuss.elastic.co/t/unable-to-run-elasticsearch-rally-in-docker/354174/3 "2024-03-26T08:17:03Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
