# Unable to run Kibana-7.2 on ScientificLinux-6

**URL:** <https://discuss.elastic.co/t/unable-to-run-kibana-7-2-on-scientificlinux-6/190984>\
**Category:** Kibana\
**Created:** [July 17, 2019, 12:08pm UTC](https://discuss.elastic.co/t/unable-to-run-kibana-7-2-on-scientificlinux-6/190984 "2019-07-17T12:08:06Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Dheeraj\_Gupta](https://avatars.discourse-cdn.com/v4/letter/d/49beb7/32.png) [@Dheeraj\_Gupta](https://discuss.elastic.co/u/Dheeraj_Gupta)\
**Post date:** [July 17, 2019, 12:08pm UTC](https://discuss.elastic.co/t/unable-to-run-kibana-7-2-on-scientificlinux-6/190984/1 "2019-07-17T12:08:06Z")

</div>

Hi,

I have been running kibana on an SL-6 system (derivative of Redhat-6). Kibana till 7.1.1 ran perfectly fine but on installing 7.2.0, I get an error

`FATAL Error: /lib64/libc.so.6: version 'GLIBC_2.14' not found (required by /usr/share/kibana/node_modules/@elastic/nodegit/build/Release/nodegit.node)`

I think this is because kibana-7.2 bundles new version of node.js that requires glibc\>2.12 (one bundled with Redhat6). I tried to manually install glibc-2.14 and glibc-2.17 in a custom location. The install worked correctly but I can't tell node to pick those libraries

`# LD_LIBRARY_PATH=/opt/glibc-2.14/lib/ /usr/share/kibana/node/bin/node --no-warnings --max-http-header-size=65536 "/usr/share/kibana/src/cli" --allow-root`

```
  log [11:50:20.627] [fatal][root] Error: /usr/share/kibana/node_modules/@elastic/nodegit/build/Release/nodegit.node: cannot enable executable stack as shared object requires: Operation not permitted

```

Clearing the executable stack bit

`# execstack -c /usr/share/kibana/node_modules/\@elastic/nodegit/build/Release/nodegit.node`

and re-running gives a segmentation fault

Using 2.17, gives a different error

```
# LD_LIBRARY_PATH=/opt/glibc-2.17/lib/ /usr/share/kibana/node/bin/node --no-warnings --max-http-header-size=65536 "/usr/share/kibana/src/cli" --allow-root
/usr/share/kibana/node/bin/node: error while loading shared libraries: __vdso_time: invalid mode for dlopen(): Invalid argument

```

Is Redhat-6 no longer officially supported? Or does anyone have pointers on how to get this to work?

Thanks,  
Dheeraj

---

<div class="post-metadata">

**Author:** ![Marius\_Dragomir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marius_dragomir/32/42087_2.png) [@Marius\_Dragomir](https://discuss.elastic.co/u/Marius_Dragomir)\
**Post date:** [July 18, 2019, 4:50pm UTC](https://discuss.elastic.co/t/unable-to-run-kibana-7-2-on-scientificlinux-6/190984/2 "2019-07-18T16:50:28Z")

</div>

There was an issue in the nodegit dependency that stops it from loading in 7.2.0. There is a fix out for 7.2.1 which should be coming out soon (a week or so).

---

<div class="post-metadata">

**Author:** ![Ilia](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ilia/32/60042_2.png) [@Ilia](https://discuss.elastic.co/u/Ilia)\
**Post date:** [July 20, 2019, 12:59pm UTC](https://discuss.elastic.co/t/unable-to-run-kibana-7-2-on-scientificlinux-6/190984/3 "2019-07-20T12:59:40Z")

</div>

Is there any workaround to get rid of this problem before releasing 7.2.1?  
A thing like [this](https://github.com/elastic/kibana/issues/40388#issuecomment-511237316) for another bug in 7.2.0

---

<div class="post-metadata">

**Author:** ![Marius\_Dragomir](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/marius_dragomir/32/42087_2.png) [@Marius\_Dragomir](https://discuss.elastic.co/u/Marius_Dragomir)\
**Post date:** [July 22, 2019, 3:27pm UTC](https://discuss.elastic.co/t/unable-to-run-kibana-7-2-on-scientificlinux-6/190984/4 "2019-07-22T15:27:14Z")

</div>

Yep, the one that you linked would be the workaround.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 19, 2019, 3:27pm UTC](https://discuss.elastic.co/t/unable-to-run-kibana-7-2-on-scientificlinux-6/190984/5 "2019-08-19T15:27:15Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
