# Unable to run logstash 6.2.3 as a service

**URL:** <https://discuss.elastic.co/t/unable-to-run-logstash-6-2-3-as-a-service/128058>\
**Category:** Logstash\
**Created:** [April 14, 2018, 10:28pm UTC](https://discuss.elastic.co/t/unable-to-run-logstash-6-2-3-as-a-service/128058 "2018-04-14T22:28:48Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ghari](https://avatars.discourse-cdn.com/v4/letter/g/ac8455/32.png) [@Ghari](https://discuss.elastic.co/u/Ghari)\
**Post date:** [April 14, 2018, 10:28pm UTC](https://discuss.elastic.co/t/unable-to-run-logstash-6-2-3-as-a-service/128058/1 "2018-04-14T22:28:48Z")

</div>

@ubuntu:~$ logstash -V  
logstash 6.2.3

* * *

@ubuntu:~$ groups logstash  
logstash : logstash adm

* * *

@ubuntu:~$ cat /etc/logstash/conf.d/01-rsyslog.conf

input {  
tcp {  
port =\> 12345  
codec =\> json  
}  
}

## output { stdout { codec =\> rubydebug } }

## sudo /usr/share/logstash/bin/logstash --debug --path.settings /etc/logstash -f /etc/logstash/conf.d/01-rsyslog.conf

@ubuntu:~$ sudo netstat -paunt | grep 12345

tcp6 0 0 :::12345 :::\* LISTEN 9065/java

* * *

@ubuntu:~$ telnet 192.168.1.107 12345  
Trying 192.168.1.107...  
Connected to 192.168.1.107.  
Escape character is '^]'.  
test 1  
test 2

* * *

@ubuntu:~$ sudo systemctl start logstash.service

@ubuntu:~$ sudo systemctl status logstash.service  
● logstash.service - logstash  
Loaded: loaded (/etc/systemd/system/logstash.service; enabled; vendor preset: enabled)  
Active: active (running) since sam. 2018-04-14 23:52:43 CEST; 7s ago  
Main PID: 9498 (java)  
Tasks: 14  
Memory: 262.7M  
CPU: 7.807s  
CGroup: /system.slice/logstash.service  
└─9498 /usr/bin/java -Xms256m -Xmx1g -XX:+UseParNewGC -XX:+UseConcMarkSweepGC -XX:CMSInitiatingOccupancyFraction=75 -XX:+UseCMSInitiatingOccupancyOnly -XX:+D

avril 14 23:52:43 ubuntu systemd[1]: Started logstash.  
@ubuntu:~$ sudo netstat -paunt | grep 12345  
@ubuntu:~$  
@ubuntu:~$ telnet 192.168.1.107 12345  
Trying 192.168.1.107...  
telnet: Unable to connect to remote host: Connection refused

* * *

can some one help me i don't know why the logstash service don't read the config file

i think i have the same problem in this post but i add logstash to the adm group

> [@Logstash don't read conf.d settings file when running as daemon](https://discuss.elastic.co/t/logstash-dont-read-conf-d-settings-file-when-running-as-daemon/50423):
>
> I have alredy read all the previous thread that I found about this problem but they didn't help me so much. Until now, I have always used the -f option to launch logstash but now I must use it as daemon so I have copied the configuration file into the conf.d folder and started the service. Nothing, the service is running without error but simply it don't do nothing (elasticsearch don't receive nothing). So, as suggested in many previous thread, I have try to run it using the --debug option: /…

i tried also like #magnusbaeck sayed the --verbose option but nothing work

the log file is empty

the service is running without error but simply it don't do nothing

Please guys i need help

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 12, 2018, 10:28pm UTC](https://discuss.elastic.co/t/unable-to-run-logstash-6-2-3-as-a-service/128058/2 "2018-05-12T22:28:48Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
