# Unable to run this command bin/logstash -e "input { http { port =\> 9200 } } output { stdout { codec =\> rubydebug} }

**URL:** https://discuss.elastic.co/t/unable-to-run-this-command-bin-logstash-e-input-http-port-9200-output-stdout-codec-rubydebug/183298
**Category:** Logstash
**Created:** [May 29, 2019, 10:14am UTC](https://discuss.elastic.co/t/unable-to-run-this-command-bin-logstash-e-input-http-port-9200-output-stdout-codec-rubydebug/183298 "2019-05-29T10:14:43Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Vishnu\_mk](https://avatars.discourse-cdn.com/v4/letter/v/71c47a/32.png) [@Vishnu\_mk](https://discuss.elastic.co/u/Vishnu_mk)
#### Post date: [May 29, 2019, 10:14am UTC](https://discuss.elastic.co/t/unable-to-run-this-command-bin-logstash-e-input-http-port-9200-output-stdout-codec-rubydebug/183298/1 "2019-05-29T10:14:43Z")

</div>

While running the following command I am getting this error  
`bin/logstash -e "input { http { port => 9200 } } output { stdout { codec => rubydebug} }"`

```
[2019-05-29T15:39:04,236][INFO][logstash.inputs.http] Starting http input listener {:address=>"0.0.0.0:9200", :ssl=>"false"}
    [2019-05-29T15:39:04,238][ERROR][logstash.pipeline] A plugin had an unrecoverable error. Will restart this plugin.
      Pipeline_id:main
      Plugin: <LogStash::Inputs::Http port=>9200, id=>"2103d9d6bb5059d5a4d3d6c58899b0e35d31c6327126ac82e1fdd823cf106575", enable_metric=>true, codec=><LogStash::Codecs::Plain id=>"plain_053fb897-d248-4456-812c-1ea7f3645d4d", enable_metric=>true, charset=>"UTF-8">, host=>"0.0.0.0", ssl=>false, ssl_verify_mode=>"none", ssl_handshake_timeout=>10000, tls_min_version=>1, tls_max_version=>1.2, cipher_suites=>["TLS_ECDHE_ECDSA_WITH_AES_256_GCM_SHA384", "TLS_ECDHE_RSA_WITH_AES_256_GCM_SHA384", "TLS_ECDHE_ECDSA_WITH_AES_128_GCM_SHA256", "TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256", "TLS_ECDHE_ECDSA_WITH_AES_256_CBC_SHA384", "TLS_ECDHE_RSA_WITH_AES_256_CBC_SHA384", "TLS_ECDHE_RSA_WITH_AES_128_CBC_SHA256", "TLS_ECDHE_ECDSA_WITH_AES_128_CBC_SHA256"], additional_codecs=>{"application/json"=>"json"}, response_headers=>{"Content-Type"=>"text/plain"}, remote_host_target_field=>"host", request_headers_target_field=>"headers", threads=>4, max_pending_requests=>200, max_content_length=>104857600, verify_mode=>"none">
      Error: Address already in use

```

Regard

---

<div class="post-metadata">

### Author: ![Badger](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/badger/32/25190_2.png) [@Badger](https://discuss.elastic.co/u/Badger)
#### Post date: [May 29, 2019, 12:13pm UTC](https://discuss.elastic.co/t/unable-to-run-this-command-bin-logstash-e-input-http-port-9200-output-stdout-codec-rubydebug/183298/2 "2019-05-29T12:13:38Z")

</div>

> [@Vishnu\_mk](#):
>
> Error: Address already in use

Something is already using port 9200. So you cannot configure an http input to use that. You can confirm that using "netstat -an". You may be able to find what is using it with lsof.

---

<div class="post-metadata">

### Author: ![Vishnu\_mk](https://avatars.discourse-cdn.com/v4/letter/v/71c47a/32.png) [@Vishnu\_mk](https://discuss.elastic.co/u/Vishnu_mk)
#### Post date: [May 29, 2019, 12:33pm UTC](https://discuss.elastic.co/t/unable-to-run-this-command-bin-logstash-e-input-http-port-9200-output-stdout-codec-rubydebug/183298/3 "2019-05-29T12:33:46Z")

</div>

Thanks badger

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [June 26, 2019, 12:33pm UTC](https://discuss.elastic.co/t/unable-to-run-this-command-bin-logstash-e-input-http-port-9200-output-stdout-codec-rubydebug/183298/4 "2019-06-26T12:33:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
