# Unable to search elastic search (code=exited, status=2)

**URL:** <https://discuss.elastic.co/t/unable-to-search-elastic-search-code-exited-status-2/148915>\
**Category:** Elasticsearch\
**Created:** [September 18, 2018, 4:54am UTC](https://discuss.elastic.co/t/unable-to-search-elastic-search-code-exited-status-2/148915 "2018-09-18T04:54:45Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![suhas-ingrainhub](https://avatars.discourse-cdn.com/v4/letter/s/b2d939/32.png) [@suhas-ingrainhub](https://discuss.elastic.co/u/suhas-ingrainhub)\
**Post date:** [September 18, 2018, 4:54am UTC](https://discuss.elastic.co/t/unable-to-search-elastic-search-code-exited-status-2/148915/1 "2018-09-18T04:54:45Z")

</div>

Elasticsearch version: 1.4.4  
JVM version: 1.8.0\_171  
OS version: Ubuntu 16.04LTS (Linux 4.13.0-41-generic [#46](https://github.com/elastic/elasticsearch/issues/46)~16.04.1-Ubuntu SMP Thu May 3 10:06:43 UTC 2018 x86\_64 x86\_64 x86\_64 GNU/Linux)

Issue: Unable to start elastic search.

Commands used:  
sudo service elasticsearch stop  
sudo service elasticsearch start  
sudo service elasticsearch status

● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; disabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Mon 2018-09-17 11:20:23 IST; 2s ago  
Docs: [http://www.elastic.co](http://www.elastic.co/)  
Process: 32485 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet (code=exited, status=2)  
Main PID: 32485 (code=exited, status=2)

Sep 17 11:20:23 WFX-SVR-006 systemd[1]: Started Elasticsearch.  
Sep 17 11:20:23 WFX-SVR-006 systemd[1]: elasticsearch.service: Main process exited, code=exited, status=2/INVALIDARGUMENT  
Sep 17 11:20:23 WFX-SVR-006 systemd[1]: elasticsearch.service: Unit entered failed state.  
Sep 17 11:20:23 WFX-SVR-006 systemd[1]: elasticsearch.service: Failed with result 'exit-code'.

Note:  
Unable to restart as well since it gives same error when restarted.  
Logs:  
Unable to check logs in /var/log/elasticsearch since its "elasticsearch" service itself is not able to start.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 16, 2018, 4:54am UTC](https://discuss.elastic.co/t/unable-to-search-elastic-search-code-exited-status-2/148915/2 "2018-10-16T04:54:56Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
