# Unable to send data to elasticsearch from apm server?

**URL:** <https://discuss.elastic.co/t/unable-to-send-data-to-elasticsearch-from-apm-server/179502>\
**Category:** APM\
**Created:** [May 3, 2019, 9:03am UTC](https://discuss.elastic.co/t/unable-to-send-data-to-elasticsearch-from-apm-server/179502 "2019-05-03T09:03:55Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mohammed\_khan](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mohammed_khan/32/42668_2.png) [@Mohammed\_khan](https://discuss.elastic.co/u/Mohammed_khan)\
**Post date:** [May 3, 2019, 9:03am UTC](https://discuss.elastic.co/t/unable-to-send-data-to-elasticsearch-from-apm-server/179502/1 "2019-05-03T09:03:55Z")

</div>

Unable to send data to elasticsearch but connection is eshtablished, all elasticsearch, kibana, apm server are upto date.(version :- 7.0.0)  
**Provide logs and/or server output (if relevant)**:

2019-05-03T13:32:17.425+0530 INFO pipeline/output.go:95 Connecting to backoff(elasticsearch(http://ec2-\*\*\*\*\***:9200))  
2019-05-03T13:32:19.123+0530 INFO elasticsearch/client.go:734 Attempting to connect to Elasticsearch version 7.0.0  
2019-05-03T13:32:19.618+0530 INFO template/load.go:129 Template already exists and will not be overwritten.  
2019-05-03T13:32:19.619+0530 INFO [index-management] idxmgmt/supporter.go:196 Loaded index template.  
2019-05-03T13:32:19.626+0530 INFO pipeline/output.go:105 Connection to backoff(elasticsearch(http://ec2-**:9200)) established  
2019-05-03T13:32:48.144+0530 ERROR [request] beater/common\_handler.go:299 error handling request {"request\_id": "85c353ee-eeb4-47c6-96db-7fddfcbc672d", "method": "OPTIONS", "URL": "/intake/v2/rum/events", "content\_length": 0, "remote\_address": "127.0.0.1", "user-agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36", "response\_code": 403, "error": {"error":"forbidden request: endpoint is disabled"}}  
2019-05-03T13:32:50.921+0530 ERROR [request] beater/common\_handler.go:299 error handling request {"request\_id": "e595dd17-96e5-42fd-9bcc-9b2d78c494e5", "method": "OPTIONS", "URL": "/intake/v2/rum/events", "content\_length": 0, "remote\_address": "127.0.0.1", "user-agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36", "response\_code": 403, "error": {"error":"forbidden request: endpoint is disabled"}}  
2019-05-03T14:24:16.819+0530 ERROR [request] beater/common\_handler.go:299 error handling request {"request\_id": "d44c8037-177b-4b8e-a80a-44bba7a783fb", "method": "OPTIONS", "URL": "/intake/v2/rum/events", "content\_length": 0, "remote\_address": "127.0.0.1", "user-agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36", "response\_code": 403, "error": {"error":"forbidden request: endpoint is disabled"}}  
2019-05-03T14:24:18.831+0530 ERROR [request] beater/common\_handler.go:299 error handling request {"request\_id": "6815f0ab-ba1e-47af-aad8-4a71a0569414", "method": "OPTIONS", "URL": "/intake/v2/rum/events", "content\_length": 0, "remote\_address": "127.0.0.1", "user-agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36", "response\_code": 403, "error": {"error":"forbidden request: endpoint is disabled"}}  
2019-05-03T14:24:22.652+0530 ERROR [request] beater/common\_handler.go:299 error handling request {"request\_id": "ab8c121d-6d22-4cc1-99c0-3bb94e57b01d", "method": "OPTIONS", "URL": "/intake/v2/rum/events", "content\_length": 0, "remote\_address": "127.0.0.1", "user-agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36", "response\_code": 403, "error": {"error":"forbidden request: endpoint is disabled"}}  
2019-05-03T14:24:27.179+0530 ERROR [request] beater/common\_handler.go:299 error handling request {"request\_id": "06ade643-5f69-40af-b87f-4d18404971bf", "method": "OPTIONS", "URL": "/intake/v2/rum/events", "content\_length": 0, "remote\_address": "127.0.0.1", "user-agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36", "response\_code": 403, "error": {"error":"forbidden request: endpoint is disabled"}}  
2019-05-03T14:24:27.895+0530 ERROR [request] beater/common\_handler.go:299 error handling request {"request\_id": "c9224b4b-e1f8-4768-9a91-b81679ca782c", "method": "OPTIONS", "URL": "/intake/v2/rum/events", "content\_length": 0, "remote\_address": "127.0.0.1", "user-agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36", "response\_code": 403, "error": {"error":"forbidden request: endpoint is disabled"}}  
2019-05-03T14:24:34.245+0530 ERROR [request] beater/common\_handler.go:299 error handling request {"request\_id": "5c56b187-37d0-4b16-973d-ceb17f9629bd", "method": "OPTIONS", "URL": "/intake/v2/rum/events", "content\_length": 0, "remote\_address": "127.0.0.1", "user-agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36", "response\_code": 403, "error": {"error":"forbidden request: endpoint is disabled"}}  
2019-05-03T14:24:37.192+0530 ERROR [request] beater/common\_handler.go:299 error handling request {"request\_id": "36864b2f-a804-4033-beaf-928160b609ec", "method": "OPTIONS", "URL": "/intake/v2/rum/events", "content\_length": 0, "remote\_address": "127.0.0.1", "user-agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/74.0.3729.131 Safari/537.36", "response\_code": 403, "error": {"error":"forbidden request: endpoint is disabled"}}

---

<div class="post-metadata">

**Author:** ![felixbarny](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/felixbarny/32/27341_2.png) [@felixbarny](https://discuss.elastic.co/u/felixbarny)\
**Post date:** [May 3, 2019, 9:24am UTC](https://discuss.elastic.co/t/unable-to-send-data-to-elasticsearch-from-apm-server/179502/2 "2019-05-03T09:24:40Z")

</div>

Hi and thanks for your question. Seems like you have to enable the rum endpoint: [https://www.elastic.co/guide/en/apm/server/current/configuration-rum.html](https://www.elastic.co/guide/en/apm/server/current/configuration-rum.html)

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [May 24, 2019, 5:24am UTC](https://discuss.elastic.co/t/unable-to-send-data-to-elasticsearch-from-apm-server/179502/3 "2019-05-24T05:24:45Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
