# Unable to Set UP TLS for Kibana

**URL:** <https://discuss.elastic.co/t/unable-to-set-up-tls-for-kibana/351380>\
**Category:** Kibana\
**Created:** [January 18, 2024, 9:00pm UTC](https://discuss.elastic.co/t/unable-to-set-up-tls-for-kibana/351380 "2024-01-18T21:00:20Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![audric\_w](https://avatars.discourse-cdn.com/v4/letter/a/fbc32d/32.png) [@audric\_w](https://discuss.elastic.co/u/audric_w)\
**Post date:** [January 18, 2024, 9:00pm UTC](https://discuss.elastic.co/t/unable-to-set-up-tls-for-kibana/351380/1 "2024-01-18T21:00:20Z")

</div>

Hi,

I've encountered a problem when trying to disable TLSv1.1 for Kibana using the command below:

```auto
server.ssl.supportedProtocols: "TLSv1.2"

```

However, after adding that command, the Kibana cannot be started:

```auto
Jan 19 03:39:51 systemd[1]: kibana.service: Main process exited, code=exited, status=1/FAILURE
Jan 19 03:39:51 systemd[1]: kibana.service: Failed with result 'exit-code'.
Jan 19 03:39:54 systemd[1]: kibana.service: Service RestartSec=3s expired, scheduling restart.
Jan 19 03:39:54 systemd[1]: kibana.service: Scheduled restart job, restart counter is at 3.
Jan 19 03:39:54 systemd[1]: Stopped Kibana.
Jan 19 03:39:54 systemd[1]: kibana.service: Start request repeated too quickly.
Jan 19 03:39:54 systemd[1]: kibana.service: Failed with result 'exit-code'.
Jan 19 03:39:54 systemd[1]: Failed to start Kibana.

```

After disabling the command, the Kibana can be started. Below the snapshot of kibana.yml:

```auto
# Enables SSL and paths to the PEM-format SSL certificate and SSL key files, respectively.
# These settings enable SSL for outgoing requests from the Kibana server to the browser.
server.ssl.enabled: true
server.ssl.certificate: /etc/kibana/certs/data01.crt
server.ssl.key: /etc/kibana/certs/data01.key
#server.ssl.supportedProtocols: "TLSv1.2"

```

Are there any config that I'm missing?

---

<div class="post-metadata">

**Author:** ![rtwolfe94022](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/rtwolfe94022/32/132253_2.png) [@rtwolfe94022](https://discuss.elastic.co/u/rtwolfe94022)\
**Post date:** [January 26, 2024, 1:30am UTC](https://discuss.elastic.co/t/unable-to-set-up-tls-for-kibana/351380/2 "2024-01-26T01:30:39Z")

</div>

From what you've described, it seems like you're on the right track but might be facing an issue with the SSL configuration for Kibana. The error you're seeing after setting `server.ssl.supportedProtocols: "TLSv1.2"` suggests that Kibana is having trouble with this specific setting.

---

<div class="post-metadata">

**Author:** ![leandrojmp](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/leandrojmp/32/107231_2.png) [@leandrojmp](https://discuss.elastic.co/u/leandrojmp)\
**Post date:** [January 26, 2024, 2:19am UTC](https://discuss.elastic.co/t/unable-to-set-up-tls-for-kibana/351380/3 "2024-01-26T02:19:27Z")

</div>

> [@audric\_w](#):
>
> `server.ssl.supportedProtocols: "TLSv1.2"`

Have you tried with `server.ssl.supportedProtocols: ["TLSv1.2"]`? Per the documentation this setting is an array.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 23, 2024, 2:20am UTC](https://discuss.elastic.co/t/unable-to-set-up-tls-for-kibana/351380/4 "2024-02-23T02:20:20Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
