# Unable to setup kibana

**URL:** <https://discuss.elastic.co/t/unable-to-setup-kibana/286983>\
**Category:** Kibana\
**Created:** [October 18, 2021, 11:31am UTC](https://discuss.elastic.co/t/unable-to-setup-kibana/286983 "2021-10-18T11:31:32Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![mohammed.sabil](https://avatars.discourse-cdn.com/v4/letter/m/f17d59/32.png) [@mohammed.sabil](https://discuss.elastic.co/u/mohammed.sabil)\
**Post date:** [October 18, 2021, 11:31am UTC](https://discuss.elastic.co/t/unable-to-setup-kibana/286983/1 "2021-10-18T11:31:32Z")

</div>

Hello Team,

I am using ansible playbook to run all three Elasticsearch, Kibana and logstash containers in one go.

After running the ansible playbook I can see all three containers are up and running.

Following is the ansible playbook.

```auto
- hosts: localhost

  tasks:

  - name: Create network
    docker_network:
      name: elk_network

  - name: Run elastic container
    docker_container:
      name: 'elastic'
      recreate: true
      restart_policy: unless-stopped
      image: 'elasticsearch:7.13.2'
      env:
        discovery.type=single-node
        xpack.security.enabled=false
      published_ports:
        - "0.0.0.0:9200:9200"
      networks:
        - name: "elk_network"

  - name: Run kibana container
    docker_container:
      name: 'kibana'
      recreate: true
      restart_policy: unless-stopped
      image: 'kibana:7.13.2'
      published_ports:
        - "0.0.0.0:5601:5601"
      networks:
        - name: "elk_network"

  - name: Run logstash container
    docker_container:
      name: 'logstash'
      recreate: true
      restart_policy: unless-stopped
      image: 'logstash:7.13.2'
      published_ports:
        - "0.0.0.0:5044:5044"
      volumes:
        - "./conf.d/:/usr/share/logstash/pipeline/conf.d/:ro"
      networks:
        - name: "elk_network"

```

When I am trying setup a kibana from another server, I am getting following error message.

Kindly suggest on this.

Regard,  
Sabil.  
Overwriting ILM policy is disabled. Set `setup.ilm.overwrite: true` for enabling.

Index setup finished.  
Loading dashboards (Kibana must be running and reachable)  
Exiting: error connecting to Kibana: fail to get the Kibana version: HTTP GET request to [http://localhost:5601/api/status](http://localhost:5601/api/status) fails: parsing kibana response: invalid character 'K' looking for beginning of value. Response: Kibana server is not ready yet.

---

<div class="post-metadata">

**Author:** ![azasypkin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/azasypkin/32/42216_2.png) [@azasypkin](https://discuss.elastic.co/u/azasypkin)\
**Post date:** [October 18, 2021, 12:01pm UTC](https://discuss.elastic.co/t/unable-to-setup-kibana/286983/2 "2021-10-18T12:01:39Z")

</div>

> [@mohammed.sabil](#):
>
> Exiting: error connecting to Kibana: fail to get the Kibana version: HTTP GET request to [http://localhost:5601/api/status](http://localhost:5601/api/status) fails: parsing kibana response: invalid character 'K' looking for beginning of value. Response: Kibana server is not ready yet.

We need more logs from Kibana to suggest anything, can you enable verbose logging (`logging.verbose: true`) and share the log output? For now it seems that Kibana just cannot connect to Elasticsearch. Are you able to `cURL` Elasticsearch from Kibana container?

Best,  
Oleg

---

<div class="post-metadata">

**Author:** ![mohammed.sabil](https://avatars.discourse-cdn.com/v4/letter/m/f17d59/32.png) [@mohammed.sabil](https://discuss.elastic.co/u/mohammed.sabil)\
**Post date:** [October 18, 2021, 12:05pm UTC](https://discuss.elastic.co/t/unable-to-setup-kibana/286983/3 "2021-10-18T12:05:27Z")

</div>

@azasypkin Yes, I am able to curl [http://elasticsearch:9200](http://elasticsearch:9200) from Kibana container.

here is the error message I can see in kinbana logs.

```auto
{"type":"log","@timestamp":"2021-10-18T11:10:00+00:00","tags":["error","savedobjects-service"],"pid":952,"message":"Unable to retrieve version information from Elasticsearch nodes."}

```

Thank you.

---

<div class="post-metadata">

**Author:** ![azasypkin](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/azasypkin/32/42216_2.png) [@azasypkin](https://discuss.elastic.co/u/azasypkin)\
**Post date:** [October 18, 2021, 12:17pm UTC](https://discuss.elastic.co/t/unable-to-setup-kibana/286983/4 "2021-10-18T12:17:52Z")

</div>

> [@mohammed.sabil](#):
>
> `{"type":"log","@timestamp":"2021-10-18T11:10:00+00:00","tags":["error","savedobjects-service"],"pid":952,"message":"Unable to retrieve version information from Elasticsearch nodes."}`

Sorry, but that's not enough, we need full verbose logs from the moment when Kibana starts. Can you try to capture them and share?

---

<div class="post-metadata">

**Author:** ![dalei2019](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dalei2019/32/92374_2.png) [@dalei2019](https://discuss.elastic.co/u/dalei2019)\
**Post date:** [October 18, 2021, 1:00pm UTC](https://discuss.elastic.co/t/unable-to-setup-kibana/286983/5 "2021-10-18T13:00:52Z")

</div>

Same issue.  
Detailed log :

> [@Cannot disable TLS and security in EKS](https://discuss.elastic.co/t/cannot-disable-tls-and-security-in-eks/222335/10):
>
> Same issue. After add selfSignedCertificate into ES. Search by http is correct. # curl -u "elastic:$PASSWORD" -k "http://xxxxxx:30300" { "name" : "es-monitor-es-master-1", "cluster\_name" : "es-monitor", "cluster\_uuid" : "jxYqF\_E0QuSAzQsJII63xQ", "version" : { "number" : "7.14.1", "build\_flavor" : "default", "build\_type" : "docker", "build\_hash" : "66b55ebfa59c92c15db3f69a335d500018b3331e", "build\_date" : "2021-08-26T09:01:05.390870785Z", "build\_snapshot" : fals…

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 15, 2021, 1:01pm UTC](https://discuss.elastic.co/t/unable-to-setup-kibana/286983/6 "2021-11-15T13:01:43Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
