# Unable to start apm-server

**URL:** <https://discuss.elastic.co/t/unable-to-start-apm-server/192570>\
**Category:** APM\
**Tags:** server\
**Created:** [July 28, 2019, 3:02pm UTC](https://discuss.elastic.co/t/unable-to-start-apm-server/192570 "2019-07-28T15:02:00Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![rahulnama](https://avatars.discourse-cdn.com/v4/letter/r/8c91f0/32.png) [@rahulnama](https://discuss.elastic.co/u/rahulnama)\
**Post date:** [July 28, 2019, 3:02pm UTC](https://discuss.elastic.co/t/unable-to-start-apm-server/192570/1 "2019-07-28T15:02:00Z")

</div>

Hello Team

Installed apm-server 7.2.0 on RHEL(Amazon EC2). Unable to start the service.

When I checked with apm-server test config the output is

 ![image](https://us1.discourse-cdn.com/elastic/original/3X/7/9/79050bc7a7ebb3aa6f658c30e5fe8cd9b642a190.png)

Also, I don't find any log file inside log/apm-server/

---

<div class="post-metadata">

**Author:** ![rahulnama](https://avatars.discourse-cdn.com/v4/letter/r/8c91f0/32.png) [@rahulnama](https://discuss.elastic.co/u/rahulnama)\
**Post date:** [July 28, 2019, 3:41pm UTC](https://discuss.elastic.co/t/unable-to-start-apm-server/192570/2 "2019-07-28T15:41:50Z")

</div>

I've also tried on installing ubuntu. the error remains same.

```
root@ip-10-0-0-64:/etc/apt/sources.list.d# apm-server test config
Exiting: error loading config file: config file ("/etc/apm-server/apm-server.yml") must be owned by the user identifier (uid=0) or root
```

---

<div class="post-metadata">

**Author:** ![axw](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/axw/32/28197_2.png) [@axw](https://discuss.elastic.co/u/axw)\
**Post date:** [July 29, 2019, 1:11am UTC](https://discuss.elastic.co/t/unable-to-start-apm-server/192570/3 "2019-07-29T01:11:36Z")

</div>

[https://www.elastic.co/guide/en/apm/server/current/setting-up-and-running.html#running-deb-rpm](https://www.elastic.co/guide/en/apm/server/current/setting-up-and-running.html#running-deb-rpm)

You need to run the program as the `apm-server` user, like this:

```
sudo -u apm-server apm-server test config
```

---

<div class="post-metadata">

**Author:** ![rahulnama](https://avatars.discourse-cdn.com/v4/letter/r/8c91f0/32.png) [@rahulnama](https://discuss.elastic.co/u/rahulnama)\
**Post date:** [July 29, 2019, 6:57am UTC](https://discuss.elastic.co/t/unable-to-start-apm-server/192570/4 "2019-07-29T06:57:21Z")

</div>

yea it worked. Thanks 🙂

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [August 19, 2019, 2:57am UTC](https://discuss.elastic.co/t/unable-to-start-apm-server/192570/5 "2019-08-19T02:57:24Z")

</div>

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.
