# Unable to start Elastic 5-6-3 under Docker

**URL:** <https://discuss.elastic.co/t/unable-to-start-elastic-5-6-3-under-docker/149681>\
**Category:** Elasticsearch\
**Created:** [September 24, 2018, 1:17pm UTC](https://discuss.elastic.co/t/unable-to-start-elastic-5-6-3-under-docker/149681 "2018-09-24T13:17:01Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![ybello](https://avatars.discourse-cdn.com/v4/letter/y/958977/32.png) [@ybello](https://discuss.elastic.co/u/ybello)\
**Post date:** [September 24, 2018, 1:17pm UTC](https://discuss.elastic.co/t/unable-to-start-elastic-5-6-3-under-docker/149681/1 "2018-09-24T13:17:02Z")

</div>

Hi Folks  
I have error right after the "elasticsearch" startup script is start  
It's seam that we have " **Failed to resolve host null"** or " **Caused by: java.net.UnknownHostException: elastic: Name or service not known**"  
Can you please advise ? We have been quite desperate for a few days now  
Thanks for your help --.

attached the log out put...

[ec2-user@qa-linux03 docker-repo.2]$ docker run -it -p 8189:8189 d324130b42ab

[2018-09-24T12:31:22,307][WARN][o.e.b.ElasticsearchUncaughtExceptionHandler] [] uncaught exception in thread [main]  
org.elasticsearch.bootstrap.StartupException: BindTransportException[Failed to resolve host null]; nested: UnknownHostException[elastic: Name or service not known];  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:136) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:123) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:70) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:134) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84) ~[elasticsearch-5.6.3.jar:5.6.3]  
Caused by: org.elasticsearch.transport.BindTransportException: **Failed to resolve host null**  
at org.elasticsearch.transport.TcpTransport.bindServer(TcpTransport.java:731) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.transport.netty4.Netty4Transport.doStart(Netty4Transport.java:174) ~[?:?]  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:69) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.transport.TransportService.doStart(TransportService.java:209) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.common.component.AbstractLifecycleComponent.start(AbstractLifecycleComponent.java:69) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.node.Node.start(Node.java:694) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:278) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:351) ~[elasticsearch-5.6.3.jar:5.6.3]  
at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:132) ~[elasticsearch-5.6.3.jar:5.6.3]  
... 6 more  
**Caused by: java.net.UnknownHostException: elastic: Name or service not known**  
at java.net.Inet4AddressImpl.lookupAllHostAddr(Native Method) ~[?:1.8.0\_181]  
at java.net.InetAddress$2.lookupAllHostAddr(InetAddress.java:928) ~[?:1.8.0\_181]  
at java.net.InetAddress.getAddressesFromNameService(InetAddress.java:1323) ~[?:1.8.0\_181]  
at java.net.InetAddress.getAllByName0(InetAddress.java:1276) ~[?:1.8.0\_181]  
at java.net.InetAddress.getAllByName(InetAddress.java:1192) ~[?:1.8.0\_181]  
at java.net.InetAddress.getAllByName(InetAddress.java:1126) ~[?:1.8.0\_181]

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 22, 2018, 3:00pm UTC](https://discuss.elastic.co/t/unable-to-start-elastic-5-6-3-under-docker/149681/3 "2018-10-22T15:00:33Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
