# Unable to start elastic search -bound or publishing to a non-loopback address, enforcing bootstrap checks ERROR: \[1\] bootstrap checks failed \[1\]: max file descriptors \[4096\] for elasticsearch process is too low, increase to at least \[65535\]

**URL:** <https://discuss.elastic.co/t/unable-to-start-elastic-search-bound-or-publishing-to-a-non-loopback-address-enforcing-bootstrap-checks-error-1-bootstrap-checks-failed-1-max-file-descriptors-4096-for-elasticsearch-process-is-too-low-increase-to-at-least-65535/344696>\
**Category:** Elasticsearch\
**Created:** [October 10, 2023, 3:36am UTC](https://discuss.elastic.co/t/unable-to-start-elastic-search-bound-or-publishing-to-a-non-loopback-address-enforcing-bootstrap-checks-error-1-bootstrap-checks-failed-1-max-file-descriptors-4096-for-elasticsearch-process-is-too-low-increase-to-at-least-65535/344696 "2023-10-10T03:36:53Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![ramyanamala013](https://avatars.discourse-cdn.com/v4/letter/r/47e85d/32.png) [@ramyanamala013](https://discuss.elastic.co/u/ramyanamala013)\
**Post date:** [October 10, 2023, 3:36am UTC](https://discuss.elastic.co/t/unable-to-start-elastic-search-bound-or-publishing-to-a-non-loopback-address-enforcing-bootstrap-checks-error-1-bootstrap-checks-failed-1-max-file-descriptors-4096-for-elasticsearch-process-is-too-low-increase-to-at-least-65535/344696/1 "2023-10-10T03:36:53Z")

</div>

Dear all,

while starting Elasticsearch i'm getting below error please help

[2023-10-10T07:27:32,014][INFO][o.e.x.s.a.s.FileRolesStore] [visitor-es-node-1] parsed [0] roles from file [/opt/MBRL/Elastic/elasticsearch-6.8.8/config/roles.yml]  
[2023-10-10T07:27:32,412][INFO][o.e.x.m.p.l.CppLogMessageHandler] [visitor-es-node-1] [controller/30432] [Main.cc@109] controller (64 bit): Version 6.8.8 (Build 398321ce7838fd) Copyright (c) 2020 Elasticsearch BV  
[2023-10-10T07:27:32,788][DEBUG][o.e.a.ActionModule] [visitor-es-node-1] Using REST wrapper from plugin org.elasticsearch.xpack.security.Security  
[2023-10-10T07:27:32,981][INFO][o.e.d.DiscoveryModule] [visitor-es-node-1] using discovery type [zen] and host providers [settings]  
[2023-10-10T07:27:33,640][INFO][o.e.n.Node] [visitor-es-node-1] initialized  
[2023-10-10T07:27:33,640][INFO][o.e.n.Node] [visitor-es-node-1] starting ...  
[2023-10-10T07:27:33,754][INFO][o.e.t.TransportService] [visitor-es-node-1] publish\_address {10.0.222.34:9300}, bound\_addresses {10.0.222.34:9300}  
[2023-10-10T07:27:33,775][INFO][o.e.b.BootstrapChecks] [visitor-es-node-1] bound or publishing to a non-loopback address, enforcing bootstrap checks  
ERROR: [1] bootstrap checks failed  
[1]: max file descriptors [4096] for elasticsearch process is too low, increase to at least [65535]  
[2023-10-10T07:27:33,809][INFO][o.e.n.Node] [visitor-es-node-1] stopping ...  
[2023-10-10T07:27:33,827][INFO][o.e.n.Node] [visitor-es-node-1] stopped  
[2023-10-10T07:27:33,827][INFO][o.e.n.Node] [visitor-es-node-1] closing ...  
[2023-10-10T07:27:33,836][INFO][o.e.n.Node] [visitor-es-node-1] closed  
[2023-10-10T07:27:33,838][INFO][o.e.x.m.p.NativeController] [visitor-es-node-1] Native controller process has stopped - no new native processes can be started

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [October 10, 2023, 6:26am UTC](https://discuss.elastic.co/t/unable-to-start-elastic-search-bound-or-publishing-to-a-non-loopback-address-enforcing-bootstrap-checks-error-1-bootstrap-checks-failed-1-max-file-descriptors-4096-for-elasticsearch-process-is-too-low-increase-to-at-least-65535/344696/2 "2023-10-10T06:26:44Z")

</div>

Please read [Bootstrap Checks | Elasticsearch Guide [8.10] | Elastic](https://www.elastic.co/guide/en/elasticsearch/reference/current/bootstrap-checks.html)

---

<div class="post-metadata">

**Author:** ![ramyanamala013](https://avatars.discourse-cdn.com/v4/letter/r/47e85d/32.png) [@ramyanamala013](https://discuss.elastic.co/u/ramyanamala013)\
**Post date:** [October 10, 2023, 6:56am UTC](https://discuss.elastic.co/t/unable-to-start-elastic-search-bound-or-publishing-to-a-non-loopback-address-enforcing-bootstrap-checks-error-1-bootstrap-checks-failed-1-max-file-descriptors-4096-for-elasticsearch-process-is-too-low-increase-to-at-least-65535/344696/3 "2023-10-10T06:56:30Z")

</div>

Dear @dadoonet

Thanks for your response, it's working setup  
Today I just stopped and started, encountered the issue

---

<div class="post-metadata">

**Author:** ![dadoonet](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/dadoonet/32/137187_2.png) [@dadoonet](https://discuss.elastic.co/u/dadoonet)\
**Post date:** [October 10, 2023, 7:34am UTC](https://discuss.elastic.co/t/unable-to-start-elastic-search-bound-or-publishing-to-a-non-loopback-address-enforcing-bootstrap-checks-error-1-bootstrap-checks-failed-1-max-file-descriptors-4096-for-elasticsearch-process-is-too-low-increase-to-at-least-65535/344696/4 "2023-10-10T07:34:34Z")

</div>

May be you were running it under another user or you modified something in the current session of the user but this has not been saved. So if you started from a new shell, it's running in another context.

But in all case, check this according to the documentation I shared.

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 7, 2023, 7:35am UTC](https://discuss.elastic.co/t/unable-to-start-elastic-search-bound-or-publishing-to-a-non-loopback-address-enforcing-bootstrap-checks-error-1-bootstrap-checks-failed-1-max-file-descriptors-4096-for-elasticsearch-process-is-too-low-increase-to-at-least-65535/344696/5 "2023-11-07T07:35:26Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
