# Unable to Start ElasticSearch 5.6.16

**URL:** <https://discuss.elastic.co/t/unable-to-start-elasticsearch-5-6-16/192791>\
**Category:** Elasticsearch\
**Created:** [July 29, 2019, 11:29pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-5-6-16/192791 "2019-07-29T23:29:13Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![jboyes](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@jboyes](https://discuss.elastic.co/u/jboyes)\
**Post date:** [July 29, 2019, 11:29pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-5-6-16/192791/1 "2019-07-29T23:29:13Z")

</div>

I just downgraded from v6.5.4 to v5.6.16 to meet the requirements of a web app I am installing.

When I start the service (service elasticsearch start) it says OK, but when I check the status (service elasticsearch start), I get the following:

[root@ctl elasticsearch]# service elasticsearch status  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Mon 2019-07-29 18:02:53 CDT; 11min ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 19878 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p {PID\_DIR}/elasticsearch.pid --quiet -Edefault.path.logs={LOG\_DIR} -Edefault.path.data={DATA\_DIR} -Edefault.path.conf={CONF\_DIR} (code=exited, status=1/FAILURE)  
Process: 19876 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 19878 (code=exited, status=1/FAILURE)

Jul 29 18:02:53 ctl elasticsearch[19878]: at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:123)  
Jul 29 18:02:53 ctl elasticsearch[19878]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:70)  
Jul 29 18:02:53 ctl elasticsearch[19878]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:134)  
Jul 29 18:02:53 ctl elasticsearch[19878]: at org.elasticsearch.cli.Command.main(Command.java:90)  
Jul 29 18:02:53 ctl elasticsearch[19878]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:91)  
Jul 29 18:02:53 ctl elasticsearch[19878]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:84)  
Jul 29 18:02:53 ctl elasticsearch[19878]: Refer to the log for complete error details.  
Jul 29 18:02:53 ctl systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Jul 29 18:02:53 ctl systemd[1]: Unit elasticsearch.service entered failed state.  
Jul 29 18:02:53 ctl systemd[1]: elasticsearch.service failed

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [August 1, 2019, 1:41pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-5-6-16/192791/2 "2019-08-01T13:41:37Z")

</div>

Hey John,

the fourth last logging line states that you should refer to the log for complete error details. Have you checked the elasticsearch log in `/var/log/elasticsearch`? Is there any additional info available that might help to debug this issue further?

--Alex

---

<div class="post-metadata">

**Author:** ![jboyes](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@jboyes](https://discuss.elastic.co/u/jboyes)\
**Post date:** [August 1, 2019, 3:49pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-5-6-16/192791/3 "2019-08-01T15:49:34Z")

</div>

Nothing is entered in the log file.

---

<div class="post-metadata">

**Author:** ![spinscale](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/spinscale/32/25011_2.png) [@spinscale](https://discuss.elastic.co/u/spinscale)\
**Post date:** [August 1, 2019, 7:26pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-5-6-16/192791/4 "2019-08-01T19:26:33Z")

</div>

ok, then it is likely that using `journalctl` you can get far more information than just the few lines above... can you try using it? You can also run `journalctl -f` (IIRC) and then try to start Elasticsearch.

---

<div class="post-metadata">

**Author:** ![jboyes](https://avatars.discourse-cdn.com/v4/letter/j/ed655f/32.png) [@jboyes](https://discuss.elastic.co/u/jboyes)\
**Post date:** [August 5, 2019, 9:06pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-5-6-16/192791/5 "2019-08-05T21:06:05Z")

</div>

> [@jboyes](#):
>
> service elasticsearch status

@spinscale

I was finally able to get this information from the logs

Aug 05 15:52:13 ctl elasticsearch[22288]: Exception in thread "main" org.elasticsearch.bootstrap.BootstrapException: org.apache.lucene.index.IndexFormatTooNewException: Format version is not supported (resource BufferedChecksumIndexInput(SimpleFSIndexInput(path="/etc/elasticsearch/elasticsearch.keystore"))): 3 (needs to be between 1 and 2)

I deleted and recreated the keystore file and now receive the following from  
service elasticsearch status

● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Mon 2019-08-05 16:24:26 CDT; 102ms ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 23585 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet -Edefault.path.logs=${LOG\_DIR} -Edefault.path.data=${DATA\_DIR} -Edefault.path.conf=${CONF\_DIR} (code=exited, status=1/FAILURE)  
Process: 23583 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 23585 (code=exited, status=1/FAILURE)

Aug 05 16:24:21 ctl systemd[1]: Starting Elasticsearch...  
Aug 05 16:24:21 ctl systemd[1]: Started Elasticsearch.  
Aug 05 16:24:26 ctl systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Aug 05 16:24:26 ctl systemd[1]: Unit elasticsearch.service entered failed state.  
Aug 05 16:24:26 ctl systemd[1]: elasticsearch.service failed.

There is nothing in the elasticsearch.log file nor anything pointing to the error using journalctl

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [September 2, 2019, 9:06pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-5-6-16/192791/6 "2019-09-02T21:06:05Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
