# Unable to start elasticsearch-5.6.2-1 at non default data location on RedHat7

**URL:** https://discuss.elastic.co/t/unable-to-start-elasticsearch-5-6-2-1-at-non-default-data-location-on-redhat7/102568
**Category:** Elasticsearch
**Created:** [October 3, 2017, 2:08pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-5-6-2-1-at-non-default-data-location-on-redhat7/102568 "2017-10-03T14:08:00Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![sameernatekar](https://avatars.discourse-cdn.com/v4/letter/s/d07c76/32.png) [@sameernatekar](https://discuss.elastic.co/u/sameernatekar)
#### Post date: [October 3, 2017, 2:08pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-5-6-2-1-at-non-default-data-location-on-redhat7/102568/1 "2017-10-03T14:08:00Z")

</div>

[root@iax3950x6-v30 elasticsearch]# service elasticsearch start  
Starting elasticsearch (via systemctl): [OK]  
[root@iax3950x6-v30 elasticsearch]# service elasticsearch status  
● elasticsearch.service - Elasticsearch  
Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)  
Active: failed (Result: exit-code) since Tue 2017-10-03 19:16:35 IST; 651ms ago  
Docs: [http://www.elastic.co](http://www.elastic.co)  
Process: 20235 ExecStart=/usr/share/elasticsearch/bin/elasticsearch -p ${PID\_DIR}/elasticsearch.pid --quiet -Edefault.path.logs=${LOG\_DIR} -Edefault.path.data=${DATA\_DIR} -Edefault.path.conf=${CONF\_DIR} (code=exited, status=1/FAILURE)  
Process: 20233 ExecStartPre=/usr/share/elasticsearch/bin/elasticsearch-systemd-pre-exec (code=exited, status=0/SUCCESS)  
Main PID: 20235 (code=exited, status=1/FAILURE)

Oct 03 19:16:35 iax3950x6-v30 elasticsearch[20235]: 2017-10-03 19:16:35,477 main ERROR Null object returned for RollingFile in Appenders.  
Oct 03 19:16:35 iax3950x6-v30 elasticsearch[20235]: 2017-10-03 19:16:35,477 main ERROR Null object returned for RollingFile in Appenders.  
Oct 03 19:16:35 iax3950x6-v30 elasticsearch[20235]: 2017-10-03 19:16:35,478 main ERROR Null object returned for RollingFile in Appenders.  
Oct 03 19:16:35 iax3950x6-v30 elasticsearch[20235]: 2017-10-03 19:16:35,478 main ERROR Unable to locate appender "rolling" for logger config "root"  
Oct 03 19:16:35 iax3950x6-v30 elasticsearch[20235]: 2017-10-03 19:16:35,478 main ERROR Unable to locate appender "index\_indexing\_slowlog\_rolling" ...g.index"  
Oct 03 19:16:35 iax3950x6-v30 elasticsearch[20235]: 2017-10-03 19:16:35,479 main ERROR Unable to locate appender "index\_search\_slowlog\_rolling" fo...slowlog"  
Oct 03 19:16:35 iax3950x6-v30 elasticsearch[20235]: 2017-10-03 19:16:35,479 main ERROR Unable to locate appender "deprecation\_rolling" for logger ...ecation"  
Oct 03 19:16:35 iax3950x6-v30 systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE  
Oct 03 19:16:35 iax3950x6-v30 systemd[1]: Unit elasticsearch.service entered failed state.  
Oct 03 19:16:35 iax3950x6-v30 systemd[1]: elasticsearch.service failed.  
Hint: Some lines were ellipsized, use -l to show in full.

---

<div class="post-metadata">

### Author: ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)
#### Post date: [October 31, 2017, 2:08pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-5-6-2-1-at-non-default-data-location-on-redhat7/102568/2 "2017-10-31T14:08:23Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
