# Unable to start Elasticsearch 7.6.2 due to java.lang.NoSuchFieldError: LUCENE\_6\_0\_0

**URL:** <https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-6-2-due-to-java-lang-nosuchfielderror-lucene-6-0-0/232006>\
**Category:** Elasticsearch\
**Created:** [May 11, 2020, 12:24pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-6-2-due-to-java-lang-nosuchfielderror-lucene-6-0-0/232006 "2020-05-11T12:24:38Z")\
**Posts on this page:** 1\
**Showing post:** 11

<div class="post-metadata">

**Author:** ![markt277](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/markt277/32/33829_2.png) [@markt277](https://discuss.elastic.co/u/markt277)\
**Post date:** [May 12, 2020, 4:03pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-6-2-due-to-java-lang-nosuchfielderror-lucene-6-0-0/232006/11 "2020-05-12T16:03:49Z")

</div>

I finally managed to get Elasticsearch running. The problem was that the uninstallation/upgrade process had left orphaned files from version 6.0.1. The solution was to completely delete /usr/share/elasticsearch/\* as mentioned here: [Version 6.4.2 does not start (java.lang.NoSuchFieldError: LOG\_DEFAULT\_LEVEL\_SETTING)](https://discuss.elastic.co/t/version-6-4-2-does-not-start-java-lang-nosuchfielderror-log-default-level-setting/151158) and make sure Elasticsearch 6.0.1 was completed uninstalled before installing a fresh copy of 7.6.2.

Additionally, I had to chown -R elasticsearch:elasticsearch /opt/elasticsearch/ (the location of my indices) because the old elasticsearch user was still set as the owner of the directory and the fresh install of 7.6.2 had not corrected that.

I also encountered the same problem mentioned here [Problems with access to Elasticsearch form outside machine](https://discuss.elastic.co/t/problems-with-access-to-elasticsearch-form-outside-machine/172450/2) and setting `discovery.seed_hosts: []` solved that.

---

_[View the full topic](https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-6-2-due-to-java-lang-nosuchfielderror-lucene-6-0-0/232006)._
