# Unable to start Elasticsearch 7.6.2

**URL:** <https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-6-2/254128>\
**Category:** Elasticsearch\
**Created:** [November 3, 2020, 10:02am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-6-2/254128 "2020-11-03T10:02:44Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![Laamimech\_Salah](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/laamimech_salah/32/77605_2.png) [@Laamimech\_Salah](https://discuss.elastic.co/u/Laamimech_Salah)\
**Post date:** [November 3, 2020, 10:02am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-6-2/254128/1 "2020-11-03T10:02:45Z")

</div>

Hi,

We are upgrading the ELK stack from v6.8.13 to v7.6.2 and we've encountered the following issue with OS Linux RHEL 7.1 :

```auto
    [2020-11-02T15:44:00,757][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler]fatal error in thread [main], exiting
    java.lang.ExceptionInInitializerError: null
            at org.elasticsearch.systemd.SystemdPlugin.sd_notify(SystemdPlugin.java:114) ~[?:?]
            at org.elasticsearch.systemd.SystemdPlugin.onNodeStarted(SystemdPlugin.java:124) ~[?:?]
            at java.util.ArrayList.forEach(ArrayList.java:1507) ~[?:?]
            at org.elasticsearch.node.Node.start(Node.java:787) ~[elasticsearch-7.6.2.jar:7.6.2]
            at org.elasticsearch.bootstrap.Bootstrap.start(Bootstrap.java:273) ~[elasticsearch-7.6.2.jar:7.6.2]
            at org.elasticsearch.bootstrap.Bootstrap.init(Bootstrap.java:358) ~[elasticsearch-7.6.2.jar:7.6.2]
            at org.elasticsearch.bootstrap.Elasticsearch.init(Elasticsearch.java:170) ~[elasticsearch-7.6.2.jar:7.6.2]
            at org.elasticsearch.bootstrap.Elasticsearch.execute(Elasticsearch.java:161) ~[elasticsearch-7.6.2.jar:7.6.2]
            at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86) ~[elasticsearch-7.6.2.jar:7.6.2]
            at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:125) ~[elasticsearch-cli-7.6.2.jar:7.6.2]
            at org.elasticsearch.cli.Command.main(Command.java:90) ~[elasticsearch-cli-7.6.2.jar:7.6.2]
            at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126) ~[elasticsearch-7.6.2.jar:7.6.2]
            at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92) ~[elasticsearch-7.6.2.jar:7.6.2]
    Caused by: java.security.AccessControlException: access denied ("java.io.FilePermission" "/usr/lib64/libsystemd.so.0" "read")
            at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472) ~[?:?]
            at java.security.AccessController.checkPermission(AccessController.java:1036) ~[?:?]
            at java.lang.SecurityManager.checkPermission(SecurityManager.java:408) ~[?:?]
            at java.lang.SecurityManager.checkRead(SecurityManager.java:747) ~[?:?]
            at java.io.File.exists(File.java:815) ~[?:?]
            at com.sun.jna.NativeLibrary.findLibraryPath(NativeLibrary.java:697) ~[jna-4.5.1.jar:4.5.1 (b0)]
            at com.sun.jna.NativeLibrary.loadLibrary(NativeLibrary.java:202) ~[jna-4.5.1.jar:4.5.1 (b0)]
            at com.sun.jna.NativeLibrary.getInstance(NativeLibrary.java:427) ~[jna-4.5.1.jar:4.5.1 (b0)]
            at com.sun.jna.Native.register(Native.java:1647) ~[jna-4.5.1.jar:4.5.1 (b0)]
            at org.elasticsearch.systemd.Libsystemd.lambda$static$0(Libsystemd.java:34) ~[?:?]
            at java.security.AccessController.doPrivileged(AccessController.java:312) ~[?:?]
            at org.elasticsearch.systemd.Libsystemd.<clinit>(Libsystemd.java:33) ~[?:?] 

```

We checked the library libsystemd.so.0 and it's not found. Any ideas to resolve this issue ?

Thank you

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 1, 2020, 10:02am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-6-2/254128/2 "2020-12-01T10:02:45Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
