# Unable to start elasticsearch 7.8 container with a password

**URL:** <https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-8-container-with-a-password/248304>\
**Category:** Elasticsearch\
**Created:** [September 11, 2020, 10:37am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-8-container-with-a-password/248304 "2020-09-11T10:37:36Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Ayush\_Agrahari](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/ayush_agrahari/32/74932_2.png) [@Ayush\_Agrahari](https://discuss.elastic.co/u/Ayush_Agrahari)\
**Post date:** [September 11, 2020, 10:37am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-8-container-with-a-password/248304/1 "2020-09-11T10:37:36Z")

</div>

Hello,  
I am attempting to setup an elastisearch cluster using a hot and warm bode using one docker-compose. However, when starting up the setup I am unable to log in, and see the following error in docker logs:

```auto
"stacktrace": ["org.elasticsearch.action.UnavailableShardsException: at least one primary shard for the index [.security-7] is unavailable

```

Please find data of `_cat/shards/.security-7` below

```auto
.security-7 0 r STARTED 51 145.5kb 192.168.112.3 warm1
.security-7 0 p STARTED 51 110.5kb 192.168.0.23 elastic-stack-node-0

```

@vamsikrishna_medeti

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [September 13, 2020, 11:29pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-8-container-with-a-password/248304/2 "2020-09-13T23:29:37Z")

</div>

What is the output from the `_cat/recovery?v` end point?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [October 11, 2020, 11:29pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-8-container-with-a-password/248304/3 "2020-10-11T23:29:52Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
