# Unable to start Elasticsearch 7.9.3

**URL:** <https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-9-3/255280>\
**Category:** Elasticsearch\
**Created:** [November 13, 2020, 2:45am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-9-3/255280 "2020-11-13T02:45:37Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![mdAsh](https://avatars.discourse-cdn.com/v4/letter/m/d26b3c/32.png) [@mdAsh](https://discuss.elastic.co/u/mdAsh)\
**Post date:** [November 13, 2020, 2:45am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-9-3/255280/1 "2020-11-13T02:45:37Z")

</div>

Hi,

Faced similar issue by:

1. [Unable to start Elasticsearch 7.6.2](https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-6-2/254128)
2. [RPM upgrade from 7.1.1 to 7.5.0 fatal error](https://discuss.elastic.co/t/rpm-upgrade-from-7-1-1-to-7-5-0-fatal-error/210419)

MainError:

```auto
Caused by: java.security.AccessControlException: access denied ("java.io.FilePermission" "/usr/lib64/libsystemd.so.0" "read")

```

I cannot find file: /usr/lib64/libsystemd.so.0

Installed elasticsearch v7.9.3 in RedHat 7.1. Followed the steps mentioned at [https://www.elastic.co/guide/en/elasticsearch/reference/7.9/rpm.html](https://www.elastic.co/guide/en/elasticsearch/reference/7.9/rpm.html). Installed using rpm manually and run elasticsearch using systemd command in CLI

Received the following error in log file at var/log/elasticsearch/ \<cluster\_name\>.log:

```auto
[2020-11-13T10:18:58,127][INFO][o.e.p.PluginsService] [node_elk02v2] loaded module [x-pack-watcher]
[2020-11-13T10:18:58,128][INFO][o.e.p.PluginsService] [node_elk02v2] no plugins loaded
[2020-11-13T10:18:58,191][INFO][o.e.e.NodeEnvironment] [node_elk02v2] using [1] data paths, mounts [[/ (rootfs)]], net usable_space [40.7gb], net total_space [44.4gb], types [rootfs]
[2020-11-13T10:18:58,192][INFO][o.e.e.NodeEnvironment] [node_elk02v2] heap size [512mb], compressed ordinary object pointers [true]
[2020-11-13T10:18:58,311][INFO][o.e.n.Node] [node_elk02v2] node name [node_elk02v2], node ID [vsNN-w3yTVW7kGr4gWFz0w], cluster name [engineer_lab_2]
[2020-11-13T10:19:03,655][INFO][o.e.x.m.p.l.CppLogMessageHandler] [node_elk02v2] [controller/3286] [Main.cc@114] controller (64 bit): Version 7.9.3 (Build 6c27059cb8397a) Copyright (c) 2020 Elasticsearch BV
[2020-11-13T10:19:04,800][INFO][o.e.x.s.a.s.FileRolesStore] [node_elk02v2] parsed [0] roles from file [/etc/elasticsearch/roles.yml]
[2020-11-13T10:19:06,225][INFO][o.e.t.NettyAllocator] [node_elk02v2] creating NettyAllocator with the following configs: [name=unpooled, factors={es.unsafe.use_unpooled_allocator=false, g1gc_enabled=true, g1gc_region_size=1mb, heap_size=512mb}]
[2020-11-13T10:19:06,322][INFO][o.e.d.DiscoveryModule] [node_elk02v2] using discovery type [zen] and seed hosts providers [settings]
[2020-11-13T10:19:06,929][WARN][o.e.g.DanglingIndicesState] [node_elk02v2] gateway.auto_import_dangling_indices is disabled, dangling indices will not be automatically detected or imported and must be managed manually
[2020-11-13T10:19:07,545][INFO][o.e.n.Node] [node_elk02v2] initialized
[2020-11-13T10:19:07,545][INFO][o.e.n.Node] [node_elk02v2] starting ...
[2020-11-13T10:19:07,722][INFO][o.e.t.TransportService] [node_elk02v2] publish_address {10.1.0.187:9300}, bound_addresses {10.1.0.187:9300}
[2020-11-13T10:19:08,178][INFO][o.e.b.BootstrapChecks] [node_elk02v2] bound or publishing to a non-loopback address, enforcing bootstrap checks
[2020-11-13T10:19:08,208][INFO][o.e.c.c.ClusterBootstrapService] [node_elk02v2] skipping cluster bootstrapping as local node does not match bootstrap requirements: [node_elk01v2]
[2020-11-13T10:19:18,218][WARN][o.e.c.c.ClusterFormationFailureHelper] [node_elk02v2] master not discovered yet, this node has not previously joined a bootstrapped (v7+) cluster, and this node must discover master-eligible nodes [node_elk01v2] to bootstrap a cluster: have discovered [{node_elk02v2}{vsNN-w3yTVW7kGr4gWFz0w}{5tguuSdrS5qN6WEQ-nphJw}{10.1.0.187}{10.1.0.187:9300}{dilmrt}{ml.machine_memory=8203763712, xpack.installed=true, transform.node=true, ml.max_open_jobs=20}]; discovery will continue using [10.1.0.186:9300] from hosts providers and [{node_elk02v2}{vsNN-w3yTVW7kGr4gWFz0w}{5tguuSdrS5qN6WEQ-nphJw}{10.1.0.187}{10.1.0.187:9300}{dilmrt}{ml.machine_memory=8203763712, xpack.installed=true, transform.node=true, ml.max_open_jobs=20}] from last-known cluster state; node term 0, last-accepted version 0 in term 0
[2020-11-13T10:19:18,769][ERROR][o.e.b.ElasticsearchUncaughtExceptionHandler] [node_elk02v2] fatal error in thread [elasticsearch[node_elk02v2][scheduler][T#1]], exiting
java.lang.ExceptionInInitializerError: null
        at org.elasticsearch.systemd.SystemdPlugin.sd_notify(SystemdPlugin.java:126) ~[?:?]
        at org.elasticsearch.systemd.SystemdPlugin.lambda$createComponents$0(SystemdPlugin.java:115) ~[?:?]
        at org.elasticsearch.threadpool.Scheduler$ReschedulingRunnable.doRun(Scheduler.java:213) ~[elasticsearch-7.9.3.jar:7.9.3]
        at org.elasticsearch.common.util.concurrent.ThreadContext$ContextPreservingAbstractRunnable.doRun(ThreadContext.java:737) ~[elasticsearch-7.9.3.jar:7.9.3]
        at org.elasticsearch.common.util.concurrent.AbstractRunnable.run(AbstractRunnable.java:37) ~[elasticsearch-7.9.3.jar:7.9.3]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:515) ~[?:?]
        at java.util.concurrent.FutureTask.run(FutureTask.java:264) ~[?:?]
        at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:304) ~[?:?]
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1130) ~[?:?]
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:630) ~[?:?]
        at java.lang.Thread.run(Thread.java:832) [?:?]
Caused by: java.security.AccessControlException: access denied ("java.io.FilePermission" "/usr/lib64/libsystemd.so.0" "read")
        at java.security.AccessControlContext.checkPermission(AccessControlContext.java:472) ~[?:?]
        at java.security.AccessController.checkPermission(AccessController.java:1036) ~[?:?]
        at java.lang.SecurityManager.checkPermission(SecurityManager.java:408) ~[?:?]
        at java.lang.SecurityManager.checkRead(SecurityManager.java:747) ~[?:?]
        at java.io.File.exists(File.java:818) ~[?:?]
        at com.sun.jna.NativeLibrary.findLibraryPath(NativeLibrary.java:725) ~[jna-5.5.0.jar:5.5.0 (b0)]
        at com.sun.jna.NativeLibrary.loadLibrary(NativeLibrary.java:202) ~[jna-5.5.0.jar:5.5.0 (b0)]
        at com.sun.jna.NativeLibrary.getInstance(NativeLibrary.java:455) ~[jna-5.5.0.jar:5.5.0 (b0)]
        at com.sun.jna.Native.register(Native.java:1722) ~[jna-5.5.0.jar:5.5.0 (b0)]
        at org.elasticsearch.systemd.Libsystemd.lambda$static$0(Libsystemd.java:34) ~[?:?]
        at java.security.AccessController.doPrivileged(AccessController.java:312) ~[?:?]
        at org.elasticsearch.systemd.Libsystemd.<clinit>(Libsystemd.java:33) ~[?:?]
        ... 11 more

```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [December 11, 2020, 2:45am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-7-9-3/255280/2 "2020-12-11T02:45:57Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
