# Unable to start ElasticSearch after install on CENTOS 8

**URL:** <https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-install-on-centos-8/259650>\
**Category:** Elasticsearch\
**Created:** [December 25, 2020, 8:51pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-install-on-centos-8/259650 "2020-12-25T20:51:06Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Shariq\_Tejar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shariq_tejar/32/79231_2.png) [@Shariq\_Tejar](https://discuss.elastic.co/u/Shariq_Tejar)\
**Post date:** [December 25, 2020, 8:51pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-install-on-centos-8/259650/1 "2020-12-25T20:51:06Z")

</div>

```auto
elasticsearch.service - Elasticsearch
   Loaded: loaded (/usr/lib/systemd/system/elasticsearch.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sat 2020-12-26 01:45:20 PKT; 10s ago
     Docs: https://www.elastic.co
  Process: 273668 ExecStart=/usr/share/elasticsearch/bin/systemd-entrypoint -p ${PID_DIR}/elasticsearch.pid --quiet (code=exited, status=1/FAILURE)
 Main PID: 273668 (code=exited, status=1/FAILURE)

Dec 26 01:45:20 localhost.localdomain systemd-entrypoint[273668]: at org.elasticsearch.cli.EnvironmentAwareCommand.createEnv(EnvironmentAwareCommand.java:100)
Dec 26 01:45:20 localhost.localdomain systemd-entrypoint[273668]: at org.elasticsearch.cli.EnvironmentAwareCommand.createEnv(EnvironmentAwareCommand.java:91)
Dec 26 01:45:20 localhost.localdomain systemd-entrypoint[273668]: at org.elasticsearch.cli.EnvironmentAwareCommand.execute(EnvironmentAwareCommand.java:86)
Dec 26 01:45:20 localhost.localdomain systemd-entrypoint[273668]: at org.elasticsearch.cli.Command.mainWithoutErrorHandling(Command.java:127)
Dec 26 01:45:20 localhost.localdomain systemd-entrypoint[273668]: at org.elasticsearch.cli.Command.main(Command.java:90)
Dec 26 01:45:20 localhost.localdomain systemd-entrypoint[273668]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:126)
Dec 26 01:45:20 localhost.localdomain systemd-entrypoint[273668]: at org.elasticsearch.bootstrap.Elasticsearch.main(Elasticsearch.java:92)
Dec 26 01:45:20 localhost.localdomain systemd[1]: elasticsearch.service: Main process exited, code=exited, status=1/FAILURE
Dec 26 01:45:20 localhost.localdomain systemd[1]: elasticsearch.service: Failed with result 'exit-code'.
Dec 26 01:45:20 localhost.localdomain systemd[1]: Failed to start Elasticsearch.

```

---

<div class="post-metadata">

**Author:** ![Shariq\_Tejar](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/shariq_tejar/32/79231_2.png) [@Shariq\_Tejar](https://discuss.elastic.co/u/Shariq_Tejar)\
**Post date:** [December 26, 2020, 1:58pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-install-on-centos-8/259650/2 "2020-12-26T13:58:25Z")

</div>

please share me ref

---

<div class="post-metadata">

**Author:** ![Mohammad\_Mousavi](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/mohammad_mousavi/32/56508_2.png) [@Mohammad\_Mousavi](https://discuss.elastic.co/u/Mohammad_Mousavi)\
**Post date:** [December 26, 2020, 2:22pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-install-on-centos-8/259650/3 "2020-12-26T14:22:51Z")

</div>

What the log shows ?  
**cat** or **less** the file: /var/log/elasticsearch/elasticsearch.log

---

<div class="post-metadata">

**Author:** ![warkolm](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/warkolm/32/39224_2.png) [@warkolm](https://discuss.elastic.co/u/warkolm)\
**Post date:** [December 29, 2020, 6:00am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-install-on-centos-8/259650/4 "2020-12-29T06:00:35Z")

</div>

Welcome to our community! 😃  
Please don't just post part of your log with no other information and expect people to help.

What version are you running?  
What config changes did you make?  
What does your Elasticsearch log show?

---

<div class="post-metadata">

**Author:** ![Eduardo\_Iglesias](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/eduardo_iglesias/32/78395_2.png) [@Eduardo\_Iglesias](https://discuss.elastic.co/u/Eduardo_Iglesias)\
**Post date:** [January 11, 2021, 8:23pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-install-on-centos-8/259650/5 "2021-01-11T20:23:36Z")

</div>

Hello @Shariq_Tejar It can be thousand reasons for es not to run. Could you share the elasticsearch logs?

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [February 8, 2021, 8:23pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-install-on-centos-8/259650/6 "2021-02-08T20:23:44Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
