# Unable to Start Elasticsearch after installation

**URL:** <https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-installation/153971>\
**Category:** Elasticsearch\
**Created:** [October 25, 2018, 10:34am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-installation/153971 "2018-10-25T10:34:32Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![Micheal25](https://avatars.discourse-cdn.com/v4/letter/m/df788c/32.png) [@Micheal25](https://discuss.elastic.co/u/Micheal25)\
**Post date:** [October 25, 2018, 10:34am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-installation/153971/1 "2018-10-25T10:34:32Z")

</div>

Hello Team,  
I have installed the new rpm package( v6.4.2) on to a Redhat linux 7 machine, after the installation, i changes the path.data and path.log to custom location and changed the ES\_tempdir to customized location

After above two changes,i tried the systemctl start elasticsearch.service

but i don't see any evidence of elasticsearch started in that server, am i missing any other config changes here. Please advise...

---

<div class="post-metadata">

**Author:** ![fkelbert](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fkelbert/32/35762_2.png) [@fkelbert](https://discuss.elastic.co/u/fkelbert)\
**Post date:** [October 25, 2018, 1:03pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-installation/153971/2 "2018-10-25T13:03:44Z")

</div>

What do you see in the logs?

---

<div class="post-metadata">

**Author:** ![Micheal25](https://avatars.discourse-cdn.com/v4/letter/m/df788c/32.png) [@Micheal25](https://discuss.elastic.co/u/Micheal25)\
**Post date:** [October 26, 2018, 4:59am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-installation/153971/3 "2018-10-26T04:59:05Z")

</div>

I see wide variety of them, most annoying one is mentioned below.

[root@xxxxxxxxxx elasticsearch]# bin/elasticsearch  
Error: Could not find or load main class .etc.elasticsearch

---

<div class="post-metadata">

**Author:** ![fkelbert](https://sea2.discourse-cdn.com/elastic/user_avatar/discuss.elastic.co/fkelbert/32/35762_2.png) [@fkelbert](https://discuss.elastic.co/u/fkelbert)\
**Post date:** [October 26, 2018, 8:41am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-installation/153971/4 "2018-10-26T08:41:08Z")

</div>

It would be good to understand:

- What does your config file look like, exactly?
- Do the mentioned paths exist?
- Do the corresponding have appropriate permissions?
- What is the full relevant output of the log?

---

<div class="post-metadata">

**Author:** ![Micheal25](https://avatars.discourse-cdn.com/v4/letter/m/df788c/32.png) [@Micheal25](https://discuss.elastic.co/u/Micheal25)\
**Post date:** [October 26, 2018, 10:48am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-installation/153971/5 "2018-10-26T10:48:54Z")

</div>

ok, I haven't done much changes to my config yet.. I also didn't change the default path.data and path.log in eleasticsearch.yml

Also everytime i trigger "systemctl start elasticsearch.service", i dont see any log files getting generated under the /var/log/elasticsearch. I am able to some hint on the sattus through the journalctf tail

Next, I am trying to execute the service via root user, which is explictiy confirm at time, so i going to create a new user "elasticsearch" and group for the same now.

I will create the user and try the execution once and confirm the output.

---

<div class="post-metadata">

**Author:** ![Micheal25](https://avatars.discourse-cdn.com/v4/letter/m/df788c/32.png) [@Micheal25](https://discuss.elastic.co/u/Micheal25)\
**Post date:** [October 26, 2018, 1:24pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-installation/153971/6 "2018-10-26T13:24:14Z")

</div>

No luck yet, still getting the below error after doing the changes..

```
bash-4.2$ bin/elasticsearch
Error: Could not find or load main class .etc.elasticsearch

```

output from journalctl

```
Oct 26 06:23:40 RCOVLNX3403.corp.frk.com systemd[1]: Started Elasticsearch.
Oct 26 06:23:40 RCOVLNX3403.corp.frk.com systemd[1]: Starting Elasticsearch...
Oct 26 06:23:40 RCOVLNX3403.corp.frk.com polkitd[846]: Unregistered Authentication Agent for unix-process:94895:131135418 (system bus name :1.8406, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
Oct 26 06:23:51 RCOVLNX3403.corp.frk.com elasticsearch[94901]: Error: Could not find or load main class .etc.elasticsearch
Oct 26 06:23:51 RCOVLNX3403.corp.frk.com systemd[1]: elasticsearch.service: main process exited, code=exited, status=1/FAILURE
Oct 26 06:23:51 RCOVLNX3403.corp.frk.com systemd[1]: Unit elasticsearch.service entered failed state.
Oct 26 06:23:51 RCOVLNX3403.corp.frk.com systemd[1]: elasticsearch.service failed.
```

---

<div class="post-metadata">

**Author:** ![system](https://us1.discourse-cdn.com/elastic/original/3X/1/a/1ac57faf039f6b580b3f104ef42a2a89e41014de.png) [@system](https://discuss.elastic.co/u/system)\
**Post date:** [November 23, 2018, 1:24pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-after-installation/153971/7 "2018-11-23T13:24:18Z")

</div>

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.
