# Unable to start Elasticsearch as a service

**URL:** https://discuss.elastic.co/t/unable-to-start-elasticsearch-as-a-service/272722
**Category:** Elasticsearch
**Tags:** elastic-stack-security
**Created:** [May 11, 2021, 4:00pm UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-as-a-service/272722 "2021-05-11T16:00:44Z")
**Posts on this page:** 1
**Showing post:** 5

<div class="post-metadata">

### Author: ![pavank](https://avatars.discourse-cdn.com/v4/letter/p/f0a364/32.png) [@pavank](https://discuss.elastic.co/u/pavank)
#### Post date: [May 12, 2021, 4:36am UTC](https://discuss.elastic.co/t/unable-to-start-elasticsearch-as-a-service/272722/5 "2021-05-12T04:36:44Z")

</div>

I also tried to reset the password for Kibana based on this post:  
[I lost the password that has been changed](https://discuss.elastic.co/t/i-lost-the-password-that-has-been-changed/91867/2)  
I am getting this error for both users Elastic and Kibana.

```auto
[root@jcpvirtualserver-new ~]# curl -u elastic:1QdjDELm7ITSikVh -XPUT -k 'https://localhost:9200/_xpack/security/user/elastic/_password?pretty' -H 'Content-Type: application/json' -d' { "password" : "janssenelastic" } '
{
  "error" : {
    "root_cause" : [
      {
        "type" : "security_exception",
        "reason" : "unable to authenticate user [elastic] for REST request [/_xpack/security/user/elastic/_password?pretty]",
        "header" : {
          "WWW-Authenticate" : [
            "Basic realm=\"security\" charset=\"UTF-8\"",
            "Bearer realm=\"security\"",
            "ApiKey"
          ]
        }
      }
    ],
    "type" : "security_exception",
    "reason" : "unable to authenticate user [elastic] for REST request [/_xpack/security/user/elastic/_password?pretty]",
    "header" : {
      "WWW-Authenticate" : [
        "Basic realm=\"security\" charset=\"UTF-8\"",
        "Bearer realm=\"security\"",
        "ApiKey"
      ]
    }
  },
  "status" : 401
}

```

```auto
[root@jcpvirtualserver-new ~]# curl -u elastic:1QdjDELm7ITSikVh -XPUT -k 'https://localhost:9200/_xpack/security/user/kibana/_password?pretty' -H 'Content-Type: application/json' -d' { "password" : "janssenkibana" } '
{
  "error" : {
    "root_cause" : [
      {
        "type" : "security_exception",
        "reason" : "unable to authenticate user [elastic] for REST request [/_xpack/security/user/kibana/_password?pretty]",
        "header" : {
          "WWW-Authenticate" : [
            "Basic realm=\"security\" charset=\"UTF-8\"",
            "Bearer realm=\"security\"",
            "ApiKey"
          ]
        }
      }
    ],
    "type" : "security_exception",
    "reason" : "unable to authenticate user [elastic] for REST request [/_xpack/security/user/kibana/_password?pretty]",
    "header" : {
      "WWW-Authenticate" : [
        "Basic realm=\"security\" charset=\"UTF-8\"",
        "Bearer realm=\"security\"",
        "ApiKey"
      ]
    }
  },
  "status" : 401
}

```

Is there any other way to authenticate the built-in users?

Regards,  
Pavan

---

_[View the full topic](https://discuss.elastic.co/t/unable-to-start-elasticsearch-as-a-service/272722)._
